Contents

PART 1: GETTING STARTED

Introduction .................................................. 9
What you can do with Studio 8 ................................. 10
Installing Studio 8............................................. 14
Activating your Studio products ............................... 16
Registering your Studio products ............................... 16

Chapter 1: Learning Studio ................................. 17
Getting the most from the Studio documentation .......... 17
Using the Studio help systems ................................ 32

Chapter 2: Studio Basics ................................. 43
Dreamweaver basics ............................................ 43
Flash basics ................................................... 57
Fireworks basics .............................................. 102
Contribute basics ............................................. 112
FlashPaper basics .......................................... 118

Chapter 3: Web Development Workflow ................. 121
About the web development workflow ....................... 121
Planning your website ........................................ 122
Setting up the development environment .................... 123
Planning page design and layout .............................. 125
Creating content assets ...................................... 128
Assembling, testing, and deploying ........................... 130
Maintaining and updating your site ......................... 133
PART 2: SETTING UP YOUR ENVIRONMENT AND PLANNING YOUR PAGE DESIGN

Chapter 4: Tutorial: Setting Up Your Site and Project Files . . 137
Learn about Dreamweaver sites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137
Set up your project files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139
Define a local folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 140

Chapter 5: Tutorial: Creating Page Mock-ups . . . . . . . . . . . . . . . . . . . . . 143
Review your task . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 143
Create and save a new document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 145
Import and place images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146
Create a composite of the content area . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148
Place text and images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 153
Export the image for the web . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 160

Chapter 6: Tutorial: Creating a Table-based Page Layout . . . . . . . . 163
Examine the design comp . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 163
Create and save a new page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 165
Insert tables . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166
Set table properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 170
Insert an image placeholder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 175
Add color to the page . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 177

PART 3: CREATING CONTENT ASSETS

Chapter 7: Tutorial: Handling Photographs . . . . . . . . . . . . . . . . . . . . . . . . 183
Review your task . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 183
Batch process large image files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184
Compose the images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 186
Preview and export the images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191
View the final optimized images . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192

Chapter 8: Tutorial: Creating a Page Banner . . . . . . . . . . . . . . . . . . . . . . . . 195
Review your task . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 195
Add a background and place the logo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 196
Organize your objects with layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201
Create a contrasting background for the logo . . . . . . . . . . . . . . . . . . . . . . . . . 203
Create an outline around the banner . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 207
Create a slanted edge effect . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 209
Add a tag line to the banner . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 210
Export an optimized image file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 211
Chapter 9: Tutorial: Building Your First Flash Application . . . . 215
Review your task ............................................. 216
Examine the completed application ......................... 216
Create a new document ....................................... 218
Create symbols ................................................ 221
Edit a symbol Timeline .................................... 225
Add actions to frames ....................................... 227
Add labels to frames ......................................... 228
Add motion tweens .......................................... 229
Edit the main Timeline ..................................... 231
Create the border ........................................... 232
Add a symbol .................................................. 238
Add a text box ................................................ 239
Add the movie clip to the Stage ............................. 242
Add a button component .................................... 243
Add ActionScript code ...................................... 244
Publish your document ...................................... 250
Resources ....................................................... 251

Chapter 10: Tutorial: Building a Video Player (Flash Professional only) ........................................ 255
Review your task ............................................. 255
Examine the completed application ......................... 256
Encode a video file ......................................... 258
Create a new Flash document ................................ 259
Add a media component .................................... 261
Publish your document ...................................... 264
The next steps ................................................ 265

PART 4: ASSEMBLING AND DEPLOYING YOUR WEBSITE

Chapter 11: Tutorial: Adding Content to Pages ............... 269
Locate your files ............................................. 269
Review your task ............................................. 271
Insert images .................................................. 272
Insert and play a Flash file ................................ 279
Insert Flash Video ........................................... 282
Insert text ..................................................... 285
Create links .................................................... 290
Preview your page in a browser ............................ 292
Chapter 12: Tutorial: Formatting Your Page with CSS .... 295
Locate your files ........................................ 296
Review your task ......................................... 297
Learn about CSS ......................................... 298
Create a new style sheet ............................... 300
Attach a style sheet ...................................... 302
Explore the CSS Styles panel ....................... 305
Create a new CSS rule ................................. 307
Apply a class style to text ............................ 309
Format the navigation bar text .................... 310
(Optional) Center the contents of the page ... 321

Chapter 13: Tutorial: Publishing Your Site ............... 325
Learn about remote sites ............................... 325
Define a remote folder ................................. 326
Upload your local files ............................... 329
Troubleshoot the remote folder setup (optional) .. 330

Chapter 14: Tutorial: Setting Up Your Website for Contribute Users ......................... 333
Review your task ....................................... 334
Learn about website connections and administration. .... 334
Connect to a website as an administrator ............. 335
Set administrative settings ............................ 336
Create a user role ...................................... 337
Edit a role’s settings .................................. 338
Create a connection key and send it to users ........ 340

Index ...................................................... 343
In this part, you’ll familiarize yourself with the Macromedia Studio 8 software suite and learn everything you need to do before you begin building your website.

This part contains the following sections:

Introduction ......................................................... 9
Learning Studio ..................................................... 17
Studio Basics ......................................................... 43
Web Development Workflow ................................. 121
Introduction

This manual introduces you to Macromedia Studio 8, an integrated web development suite that includes Macromedia Dreamweaver 8, Macromedia Flash Professional 8, Macromedia Fireworks 8, Macromedia Contribute 3.1, and Macromedia FlashPaper 2.

This manual gives an overview of the products, introduces conceptual information about website development, and shows you how to build a simple but functional website through a series of tutorials.

The information in this manual is designed for beginners, especially users who are unfamiliar with one or all of the products in the Studio 8 family. Intermediate and advanced users can benefit by learning recommended techniques.

This chapter contains the following sections:

- What you can do with Studio 8 ................................................................. 10
- Installing Studio 8 .................................................................................. 14
- Activating your Studio products ............................................................ 16
- Registering your Studio products ............................................................ 16

NOTE
This manual is not a comprehensive reference for all of the features of the Studio products. For in-depth information, see each product's help system. To use a product's help system, in the product's Help menu, select Using Product Name.
What you can do with Studio 8

Studio 8 includes five Macromedia products: Dreamweaver, Flash, Fireworks, Contribute, and FlashPaper. This section provides a brief overview of each product.

This section covers the following topics:

■ “What you can do with Dreamweaver” on page 10
■ “What you can do with Flash” on page 11
■ “What you can do with Fireworks” on page 12
■ “What you can do with Contribute” on page 13
■ “What you can do with FlashPaper” on page 13

What you can do with Dreamweaver

The visual editing features in Macromedia Dreamweaver let you quickly create web pages without writing a line of code. You can view all your site elements or assets and drag them from an easy-to-use panel directly into a document. You can streamline your development workflow by creating and editing images in Macromedia Fireworks or another graphics application, and then import them directly into Dreamweaver. Dreamweaver also provides tools that make it easy to add Macromedia Flash assets to web pages.

In addition to drag-and-drop features that help you build web pages, Dreamweaver provides a full-featured coding environment that includes code-editing tools such as code coloring, tag completion, a coding toolbar, and code collapse. Also provided is language reference material about Cascading Style Sheets (CSS), JavaScript, ColdFusion Markup Language (CFML), and other languages. Macromedia Roundtrip HTML technology imports your hand-coded HTML documents without reformatting the code; you can then reformat code with your preferred formatting style.

Dreamweaver also lets you build dynamic, database-driven web applications using server technologies such as CFML, ASP.NET, ASP, JSP, and PHP. If you prefer working with XML data, Dreamweaver provides tools that let you easily create XSLT pages, attach XML files, and display XML data on your web pages.
Dreamweaver is fully customizable. Using new behaviors, Property inspectors, and site reports, you can create your own objects and commands, modify keyboard shortcuts, and even write JavaScript code to extend Dreamweaver capabilities.

For more information on the resources available for learning Dreamweaver, see “Getting the most from the Dreamweaver documentation” on page 18.

**What you can do with Flash**

With the wide array of features in Macromedia Flash, you can create many types of applications. The following are some examples of the kinds of applications Flash can generate:

- **Animations**  These include banner ads, online greeting cards, and cartoons. Many other types of Flash applications include animation elements as well.

- **Games**  Many games are built with Flash. Games usually combine the animation capabilities of Flash with the logic capabilities of ActionScript.

- **User interfaces**  Many website designers use Flash to design user interfaces. The interfaces include simple navigation bars as well as much more complex interfaces. You can find an example of a navigation bar created with Flash across the top of the www.macromedia.com home page.

- **Flexible messaging areas**  These are areas in web pages that designers use for displaying information that may change over time. A flexible messaging area (FMA) on a restaurant website might display information about each day’s menu specials. You can find an example of an FMA on the www.macromedia.com home page. The procedures in “Tutorial: Building Your First Flash Application” on page 215 guide you through the process of building an FMA.

- **Rich Internet applications**  These include a wide spectrum of applications that provide a rich user interface for displaying and manipulating remotely stored data over the Internet. A rich Internet application could be a calendar application, a price-finding application, a shopping catalog, an education and testing application, or any other application that presents remote data with a graphically rich interface.

You can find many examples of real projects created by Flash users on the Macromedia website at www.macromedia.com/cfusion/showcase/.
To build a Flash application, you typically perform the following basic steps:

1. Decide which basic tasks the application will perform.
2. Create and import media elements, such as images, video, sound, and text.
3. Arrange the media elements on the Stage and in the Timeline to define when and how they appear in your application.
4. Apply special effects to media elements.
5. Write ActionScript code to control how the media elements behave, including how the elements respond to user interactions.
6. Test your application throughout the creation process to determine if it is working as planned and find any bugs in its construction.
7. Publish your FLA file as a SWF file that can be displayed in a web page and played back with Flash Player.

Depending on your project and your working style, you may use these steps in a different order. As you become familiar with Flash and its workflows, you will discover a style of working that suits you best.

**What you can do with Fireworks**

You can use Macromedia Fireworks to create, edit, and animate web graphics, add advanced interactivity, and optimize images in a professional environment. In Fireworks, you can create and edit bitmap and vector graphics in a single application. Everything is editable, all the time. And you can automate the workflow to meet the demands of time-consuming updates and changes.

Fireworks integrates with other Macromedia products such as Dreamweaver, Flash, FreeHand, and Director, as well as your other favorite graphics applications and HTML editors, to provide a truly integrated web solution. You can easily export Fireworks graphics with HTML and JavaScript code customized for the HTML editor you're using.
What you can do with Contribute

As a web developer or designer, you use a website-creation application, such as Dreamweaver, to build your website. That includes planning, designing, developing, testing, and publishing the website. When that work is done, you can use Macromedia Contribute to manage your site, and to set up users to maintain content on the site.

As a Contribute administrator, you set up Contribute users and help them use Contribute to maintain the website. You can set folder and user permissions, which determine who can edit website content and what they can edit.

Contribute users maintain the website. The Contribute browse-edit-publish workflow helps users easily find the page to edit, make changes to the page, and then update the page on the website. The user needs no experience in HTML or web design. Because Contribute works like a word processor, the user experience for editing pages is intuitive and familiar. Users can add or update text, images, tables, links, and Microsoft Word and Excel documents.

What you can do with FlashPaper

Macromedia FlashPaper lets you easily convert any printable document to a Flash document (SWF file or PDF file). Flash documents are typically much smaller than other document types, and you can view them in any browser that supports Flash, or directly in Flash Player.

You can view Flash documents across platforms, and retain the formatting, graphics, fonts, special characters, and colors of source documents, regardless of the application and platform used to create the document. For example, if you created a Microsoft Excel spreadsheet on a Windows XP computer, you can use FlashPaper to convert it to a Flash document, and then send it to a Macintosh user.

Because you can embed a Flash document in a web page, you can publish file types that most people can’t easily view on the web today, such as Microsoft Project, Microsoft Visio, and even QuarkXPress and AutoCAD. When a user opens your web page, the Flash document opens instantly, so the user can view the file without leaving the web page.
Flash documents also work well as stand-alone files. Anyone who has Flash Player installed on their computer can view SWF files, and anyone who has Adobe Acrobat Reader installed on their computer can view PDF files.

**NOTE** You cannot edit a Flash document in FlashPaper; if you need to update the document, make changes to the original document, and then convert it again to a Flash document.

**Installing Studio 8**

This section describes the installation procedure for Studio 8. You can install Studio 8 on Windows and Macintosh systems. Macromedia recommends that you install the suite of tools in one simple operation, but you can selectively install individual applications if you choose to do so. Before you install Studio 8, be sure you meet the minimum system requirements for each Studio product. For a complete list of product system requirements and recommendations, visit [www.macromedia.com/go/sysreqs/](http://www.macromedia.com/go/sysreqs/).

To install Studio 8 on Windows or Macintosh operating systems:

1. Insert the Studio 8 CD into your computer’s CD-ROM drive to display the Studio 8 installation screen.
If the screen does not appear, or if you are installing from a network drive, in Windows, use Windows Explorer to locate the Studio 8 Installer.exe file in the Accessibility directory, double-click the filename, and follow the installation instructions. On the Macintosh, double-click the Install Studio 8 icon on the desktop.

2. Do one of the following:
   - To install the Studio 8 suite of tools, click Install. (Macromedia recommends this option.)
   - To install only a single application, select it from the screen, and then click Install.
     You can repeat this process to install other products individually.

3. Follow the installation instructions.

4. Click Done when the installation process is complete.
   The installed Studio 8 applications are now available.

5. In Windows, select Programs > Macromedia from the Windows Start menu. On the Macintosh, open the Applications folder.

   **To view extra material provided with Studio 8:**
   - Click the Browse CD Contents link at the bottom right of the installation screen.

   **To uninstall the applications (Windows):**
   - Select Start > Settings > Control Panel > Add/Remove Programs, and select the application to uninstall.

   **To uninstall the applications (Macintosh):**
   - Drag a product folder from the Application folder to the Trash icon.
Activating your Studio products

If you are a single-license user, you must activate the license for your Macromedia products within 30 days of installation. When you activate one of the Studio 8 products, the other products are also activated.

You can activate the product through an Internet connection in a process that takes only a few moments. Product activation does not require you to submit personal information, just your product serial number.

To activate a product:
1. Double-click the Dreamweaver, Flash, Fireworks, or Contribute executable icon to start one of the products.
2. Click Continue to go to the next screen.
3. Enter your serial number in the Macromedia Product Activation window and click Continue.

After activation, your Studio 8 products are ready to use.

Registering your Studio products

It’s a good idea to register your Studio 8 products electronically or by mail. Registration entitles you to additional Macromedia support. When you register one of the Studio 8 products, the other products are also registered.

When you register, you can sign up to receive up-to-the-minute notices about upgrades and new Macromedia products. You can also sign up for timely e-mail notices about product updates and new content that appears on www.macromedia.com.

To register a product:
- In any of the Studio 8 products, select Help and then select either the online or the print registration option.
CHAPTER 1
Learning Studio

Macromedia Studio 8 includes a variety of resources to help you learn the Studio programs quickly. This chapter outlines all of the documentation resources that are available to you, and provides detailed information about using the help systems in the Studio products.

This chapter contains the following sections:
Getting the most from the Studio documentation ..................17
Using the Studio help systems ........................................32

Getting the most from the Studio documentation

This section describes the documentation in the Studio products. It also points you to helpful online resources.

This section covers the following topics:
■ “Getting the most from the Dreamweaver documentation” on page 18
■ “Getting the most from the Flash documentation” on page 21
■ “Getting the most from the Fireworks documentation” on page 27
■ “Getting the most from the Contribute and FlashPaper documentation” on page 29
## Getting the most from the Dreamweaver documentation

Dreamweaver includes a variety of media to help you learn the program quickly and become proficient in creating web pages. The Dreamweaver help system includes several documents that help you learn about Dreamweaver, Dreamweaver Extensibility, and ColdFusion. You can also consult a number of additional online resources as you learn how to build web pages.

## Accessing the Dreamweaver documentation

The following table summarizes the documentation included in the Dreamweaver help system.

You can purchase printed versions of select titles. For more information, see [www.macromedia.com/go/buy_books](http://www.macromedia.com/go/buy_books).

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| Getting Started with Dreamweaver | Basic introduction to Dreamweaver concepts and the interface, with detailed beginner tutorials. Intended for beginning users, as well as intermediate and advanced users who want to learn about new features. | • View in Dreamweaver: Select Help > Getting Started with Dreamweaver  
• View online: [http://livedocs.macromedia.com/go/livedocs_dreamweaver/](http://livedocs.macromedia.com/go/livedocs_dreamweaver/)  
• Get the PDF: [www.macromedia.com/go/dw_documentation](http://www.macromedia.com/go/dw_documentation) |
| Using Dreamweaver       | Comprehensive information about all Dreamweaver features. Intended for all Dreamweaver users.                                                                                                                                                                   | • View in Dreamweaver: Select Help > Dreamweaver Help, or Help > Using Dreamweaver  
• View online: [http://livedocs.macromedia.com/go/livedocs_dreamweaver/](http://livedocs.macromedia.com/go/livedocs_dreamweaver/)  
• Get the PDF: [www.macromedia.com/go/dw_documentation](http://www.macromedia.com/go/dw_documentation) |
<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| Extending Dreamweaver | Description of the Dreamweaver framework and application programming interface (API). Intended for advanced users who want to build extensions or customize the Dreamweaver interface.                      | • View in Dreamweaver: Select Help > Extending Dreamweaver  
• View online: http://livedocs.macromedia.com/go/livedocs_dreamweaver/  
• Get the PDF: www.macromedia.com/go/dw_documentation |
| Dreamweaver API Reference | Descriptions of the utility API and the JavaScript API, both of which let you perform various supporting tasks when developing Dreamweaver extensions. Intended for advanced users who want to build extensions or customize the Dreamweaver interface. | • View in Dreamweaver: Select Help > Dreamweaver API Reference  
• View online: http://livedocs.macromedia.com/go/livedocs_dreamweaver/  
• Get the PDF: www.macromedia.com/go/dw_documentation |
## Accessing additional online Dreamweaver resources

The following table summarizes additional online resources for learning Dreamweaver.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dreamweaver Support Center</td>
<td>TechNotes, plus support and problem-solving information for Dreamweaver users.</td>
<td><a href="http://www.macromedia.com/go/dreamweaver_support">www.macromedia.com/go/dreamweaver_support</a></td>
</tr>
<tr>
<td>Dreamweaver Developer Center</td>
<td>Articles and tutorials to help you improve your skills and learn new ones.</td>
<td><a href="http://www.macromedia.com/go/dreamweaver_devcenter">www.macromedia.com/go/dreamweaver_devcenter</a></td>
</tr>
</tbody>
</table>
The Macromedia Flash help system contains a great deal of information and resources that describe the full range of Flash authoring capabilities and the ActionScript language. Many online resources are also available to help you learn Flash. This document is intended to help you navigate these resources and find the information that is most helpful to you in realizing your goals with Flash.

Accessing the Flash documentation

The following tables summarize the documents included in the Flash help system.

You can purchase printed versions of select titles. For more information, see www.macromedia.com/go/buy_books.
# Feature information

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| **Getting Started with Flash** | Basic introduction to Flash concepts and interface, with a detailed beginner tutorial. Intended for beginning Flash users.                                                                                           | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/fl_documentation                                                                                       |
| **Using Flash**            | Comprehensive information about all the features of Flash except ActionScript. Intended for all Flash users.                                                                                                                                                 | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/fl_documentation                                                                                       |
| **Flash 8 Video Encoder Help** | Complete information about using the Flash 8 Video Encoder application. Intended for Flash designers creating video content.                                                                                                                       | • View in Flash 8 Video Encoder: Select Help > Using Flash Video Encoder  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/fl_documentation                                                                                       |
## Tutorials and samples

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flash Tutorials</td>
<td>A collection of step-by-step tutorials that teach a variety of both beginning and advanced Flash techniques. Intended for all Flash users.</td>
<td>• View in Flash: Select Help &gt; Flash Help&lt;br&gt;• View online: livedocs.macromedia.com/go/livedocs_flash&lt;br&gt;• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
<tr>
<td>Flash Samples</td>
<td>A collection of sample files demonstrating various Flash features and techniques, with a detailed description of each one. Intended for all Flash users.</td>
<td>• View in Flash: Select Help &gt; Flash Help&lt;br&gt;• View online: livedocs.macromedia.com/go/livedocs_flash&lt;br&gt;• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
</tbody>
</table>

## ActionScript

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Learning ActionScript 2.0 in Flash</td>
<td>A detailed introduction to coding with ActionScript, including extensive reusable code examples. Intended for beginning and intermediate ActionScript users.</td>
<td>• View in Flash: Select Help &gt; Flash Help&lt;br&gt;• View online: livedocs.macromedia.com/go/livedocs_flash&lt;br&gt;• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
<tr>
<td>ActionScript 2.0 Language Reference</td>
<td>Dictionary-style reference entries for each term in the ActionScript language. Intended for all ActionScript users.</td>
<td>• View in Flash: Select Help &gt; Flash Help&lt;br&gt;• View online: livedocs.macromedia.com/go/livedocs_flash&lt;br&gt;• Get the PDF: <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
</tbody>
</table>
Components

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| Using Components       | Information about how to use and customize components in your Flash documents. Intended for all Flash users. | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/fl_documentation |
| Component Language Reference | Dictionary-style reference entries for each term in the ActionScript component API. Intended for all Flash users. | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/fl_documentation |

Extending Flash

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| Extending Flash        | Information about adding functionality to the Flash authoring tool with JavaScript. Intended for JavaScript users and advanced Flash users. | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/fl_documentation |
### Flash Lite

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| **Getting Started with Flash Lite** | Introductory information about Flash Lite workflows and authoring considerations. Intended for mobile and device developers and intermediate Flash users.                                                                      | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation                                                                                     |
| **Developing Flash Lite Applications** | Information about creating Flash content for mobile phones and devices. Intended for mobile and device developers and intermediate Flash users.                                                                               | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation                                                                                     |
| **Learning Flash Lite 1.x ActionScript** | Information about writing ActionScript for mobile phones and devices. Intended for mobile and device developers and intermediate Flash users.                                                                                | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation                                                                                     |
| **Flash Lite 1.x ActionScript Language Reference** | Dictionary-style reference entries for each term in the Flash Lite 1.x ActionScript language. Intended for mobile and device developers and intermediate Flash users.                                                      | • View in Flash: Select Help > Flash Help  
• View online: livedocs.macromedia.com/go/livedocs_flash  
• Get the PDF: www.macromedia.com/go/flash_lite_documentation                                                                                     |
## Accessing additional online Flash resources

The following table summarizes additional online resources for learning Flash.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flash Support Center</td>
<td>TechNotes, plus support and problem-solving information.</td>
<td>• <a href="http://www.macromedia.com/go/flash_support">www.macromedia.com/go/flash_support</a></td>
</tr>
<tr>
<td>Flash Developer Center</td>
<td>Articles and tutorials to help you improve your skills and learn new ones.</td>
<td>• <a href="http://www.macromedia.com/go/flash_devcenter">www.macromedia.com/go/flash_devcenter</a></td>
</tr>
<tr>
<td>Flash Documentation Resource Center</td>
<td>PDF and HTML versions of the Flash documentation.</td>
<td>• <a href="http://www.macromedia.com/go/fl_documentation">www.macromedia.com/go/fl_documentation</a></td>
</tr>
<tr>
<td>Macromedia Online Forums</td>
<td>Discussion and problem-solving information by Flash users, technical support representatives, and the Flash development team.</td>
<td>• <a href="http://www.macromedia.com/go/flash_forums">www.macromedia.com/go/flash_forums</a></td>
</tr>
<tr>
<td>Macromedia Training</td>
<td>Classroom and online instruction offered by Macromedia training partners.</td>
<td>• <a href="http://www.macromedia.com/go/flash_training">www.macromedia.com/go/flash_training</a></td>
</tr>
<tr>
<td>Flash Resource Manager (English only)</td>
<td>An alternative viewer for viewing the Flash help system outside the Flash application.</td>
<td>• <a href="http://www.macromedia.com/go/flash_resource_manager">www.macromedia.com/go/flash_resource_manager</a></td>
</tr>
</tbody>
</table>
Getting the most from the Fireworks documentation

Fireworks includes a variety of media to help you learn the program quickly. The Fireworks help system includes several documents that help you learn about using and extending Fireworks. You can also consult a number of additional online resources as you learn to use Fireworks.

Accessing the Fireworks documentation

The following table summarizes the documentation included in the Fireworks help system.

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| Getting Started with Fireworks | Basic introduction to Fireworks concepts and interface, with a detailed beginner tutorials. Intended for beginning Fireworks users. | • View in Fireworks: Select Help > Getting Started with Fireworks  
• View online: www.macromedia.com/go/livedocs_fireworks  
• Get the PDF: www.macromedia.com/go/ fireworks_documentation |
| Using Fireworks            | Comprehensive information about all the features of Fireworks. Intended for all Fireworks users. | • View in Fireworks: Select Help > Using Fireworks  
• View online: www.macromedia.com/go/livedocs_fireworks  
• Get the PDF: www.macromedia.com/go/ fireworks_documentation |
| Extending Fireworks        | Information about adding functionality to Fireworks with JavaScript. Intended for JavaScript users and advanced Fireworks users. | • View in Fireworks: Select Help > Extending Fireworks  
• View online: www.macromedia.com/go/livedocs_fireworks  
• Get the PDF: www.macromedia.com/go/ fireworks_documentation |
Accessing additional online Fireworks resources

The following table summarizes additional online resources for learning Fireworks.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Center</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fireworks Developer Center</td>
<td>Articles and tutorials to help you improve your skills and learn new ones.</td>
<td><a href="http://www.macromedia.com/go/fireworks_devnet">www.macromedia.com/go/fireworks_devnet</a></td>
</tr>
<tr>
<td>Fireworks Support Center</td>
<td>TechNotes, plus support and problem-solving information for Fireworks users.</td>
<td><a href="http://www.macromedia.com/go/fireworks_support">www.macromedia.com/go/fireworks_support</a></td>
</tr>
<tr>
<td>Macromedia Training</td>
<td>Courses featuring hands-on tasks and real-world scenarios.</td>
<td><a href="http://www.macromedia.com/go/fireworks_training">www.macromedia.com/go/fireworks_training</a></td>
</tr>
</tbody>
</table>
Getting the most from the Contribute and FlashPaper documentation

Contribute and FlashPaper include a variety of media to help you learn the programs quickly. Both products include several documents that help you learn about using Contribute and FlashPaper. You can also consult a number of additional online resources as you learn how to use Contribute and FlashPaper.

Accessing the Contribute and FlashPaper documentation

The following table summarizes the documentation included in Contribute and FlashPaper.

<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| Contribute Quick Start | Basic introduction to installing Contribute, connecting to a website, and completing some simple tasks quickly. Intended for beginning Contribute users. | • In Contribute: Select Help > Quick Start Guide  
• View the FlashPaper format: www.macromedia.com/go/contribute_docs_en |
| Deploying Contribute   | Overview of what a system administrator should know when deploying Contribute within an organization. Topics include setting network and server permissions, configuring Contribute to work with your website, managing users, and understanding site structure. Intended for Contribute administrators. | • View online: livedocs.macromedia.com  
• Get the PDF: www.macromedia.com/go/contribute_docs_en  
• In Contribute: Select Help > Macromedia Contribute Help, and open Administering Contribute. |
<table>
<thead>
<tr>
<th>Title</th>
<th>Description/Audience</th>
<th>Where to Find It</th>
</tr>
</thead>
</table>
| Using and Administering Contribute | Comprehensive information about the Contribute features. Intended for all Contribute users and administrators.                                                                                                                                                                                                                                             | • In Contribute: Select Help > Macromedia Contribute Help
• View online: livedocs.macromedia.com
• Get the PDF: www.macromedia.com/go/contribute_docs_en                                                                                                                                                                                                                                        |
| How Do I panel             | Quick step-by-step instructions on completing some common Contribute tasks. Intended for Contribute users and administrators.                                                                                                                                                                                                                           | • In Contribute: Select View > Sidebar                                                                                                                                                                                                 |
| Contribute tutorial        | Step-by-step tutorial that guides you through representative Contribute tasks. In the tutorial you’ll update the web pages of a sample website and quickly become familiar with Contribute features. Intended for beginning Contribute users.                                                                                                           | • In Contribute: Select Help > Contribute Tutorial                                                                                                                                                                                      |
| Using FlashPaper           | Comprehensive information about all FlashPaper features. Intended for all FlashPaper users.                                                                                                                                                                                                                                                       | • In Contribute: Select Help > FlashPaper Help
• www.macromedia.com/go/flashpaper_documentation                                                                                                                                                                                                                                              |
## Accessing additional online Contribute and FlashPaper resources

The following table summarizes additional online resources for learning Contribute and FlashPaper.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
<th>Where to Find It</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contribute Documentation Resource Center</td>
<td>Product manuals, errata, tutorials, and release notes.</td>
<td>• <a href="http://www.macromedia.com/go/contribute_docs_en">www.macromedia.com/go/contribute_docs_en</a></td>
</tr>
<tr>
<td>Contribute Developer Center</td>
<td>Articles and tutorials to help you improve your skills and learn new ones.</td>
<td>• <a href="http://www.macromedia.com/go/contribute_devcenter">www.macromedia.com/go/contribute_devcenter</a></td>
</tr>
<tr>
<td>Contribute Support Center</td>
<td>TechNotes, plus support and problem-solving information for Contribute users.</td>
<td>• <a href="http://www.macromedia.com/go/contribute_support">www.macromedia.com/go/contribute_support</a></td>
</tr>
<tr>
<td>Contribute Forum</td>
<td>Discussion and problem-solving information by Contribute users, technical support representatives, and the Contribute development team.</td>
<td>• <a href="http://www.macromedia.com/go/contribute_forums">www.macromedia.com/go/contribute_forums</a></td>
</tr>
<tr>
<td>Macromedia Training</td>
<td>Courses featuring hands-on tasks and real-world scenarios.</td>
<td>• <a href="http://www.macromedia.com/go/contribute_training">www.macromedia.com/go/contribute_training</a></td>
</tr>
<tr>
<td>FlashPaper Documentation Resource Center</td>
<td>Product manuals, errata, tutorials, and release notes.</td>
<td>• <a href="http://www.macromedia.com/go/flashpaper_documentation">www.macromedia.com/go/flashpaper_documentation</a></td>
</tr>
<tr>
<td>FlashPaper Support Center</td>
<td>TechNotes, plus support and problem-solving information for FlashPaper users.</td>
<td>• <a href="http://www.macromedia.com/go/flashpaper_support">www.macromedia.com/go/flashpaper_support</a></td>
</tr>
</tbody>
</table>
Using the Studio help systems

The online help systems for the Studio products are available in the Help menu of each product. Each help system provides detailed information on all tasks you can perform with the Studio products.

This section describes how to use the Studio help systems to find the information you need.

This section covers the following topics:

- “Using the Dreamweaver, Fireworks, Contribute, and FlashPaper help systems” on page 32
- “Using the Flash help system” on page 35

Using the Dreamweaver, Fireworks, Contribute, and FlashPaper help systems

The online help systems available in the Help menu for each Studio product provide detailed information on all tasks you can perform with the product. The Dreamweaver, Fireworks, Contribute, and FlashPaper help systems all work the same way.

For information about using the Flash help system, see “Using the Flash help system” on page 35.
This section covers the following topics:

- “Opening in-product help” on page 33
- “Searching help” on page 33
- “Using the help index” on page 34
- “Using the Start page” on page 34
- “Printing the documentation” on page 35
- “Purchasing printed documentation” on page 35
- “Discussing the Studio documentation with LiveDocs” on page 35

Opening in-product help

You can access in-product help while you work in the product.

To open Dreamweaver Help:

- Select Help > Dreamweaver Help.

To open Fireworks Help:

- Select Help > Fireworks Help.

To open Contribute Help:

- Select Help > Macromedia Contribute Help.

To open FlashPaper Help:

- Select Help > FlashPaper Help.

Searching help

You can do a full text search in the help systems.

To search in-product help (Windows):

1. In the help system, click the Search tab.
2. Type a word or phrase in the text box, and then click List Topics.
3. Double-click a topic in the list of results to display it.

To search in-product help (Macintosh):

1. In the help system, type a word or phrase in the Ask a Question text box, and then press Enter.
2. Double-click a topic in the list of results to display it.
Using the help index

You can find information quickly in the help index.

To use the index (Windows):
1. In the help system, click the Index tab.
2. Scroll to an index entry in the alphabetized list and double-click it to display the indexed information.

To use the index (Macintosh):
1. In the help system, click the Index link in the table of contents.
2. Click a letter and scroll to an index entry in the list.
3. Click a number beside the entry to display the indexed information.

Changing the font size

You can change the size of the font used by the help system.

To change the font size in the Windows help viewer:
1. Open Internet Explorer.
   The font size in the Windows help viewer is set in Internet Explorer.
2. Select View > Text Size, and then select a size.

To change the font size in the Macintosh help viewer:
- In help, select Edit > Decrease Font Size, or Edit > Increase Font Size.

Using the Start page

When you start a Studio product without opening a document, the Start page appears in the work environment. The Start page gives you quick access to tutorials, recent files, and the product Exchange, where you can add new capabilities to some features. You can use the Start page much like a web page. To use any of the features you see, you simply click them.

To disable the Start page:
1. Run a Studio product without opening a document.
   The Start page is displayed.
2. Click Don't Show Again.
Printing the documentation
The Studio documentation is available in PDF format on the Macromedia website at www.macromedia.com/go/st_documentation.
You can print all or part of the PDF on your own printer, or you can take the PDF to a copy shop to have it printed.

Purchasing printed documentation
You can purchase printed versions of select Studio titles. For more information, see www.macromedia.com/go/buy_books.

Discussing the Studio documentation with LiveDocs
The documentation is also available online in LiveDocs format. The LiveDocs version of help looks very similar to the in-product help, but it allows you to comment on the contents of individual help pages. You can add useful information on a specific topic based on your own experience, or solicit advice from fellow users.

Using the Flash help system
The Flash online help system available in the Help menu provides detailed information on all tasks you can perform with Flash. The Flash help system works differently than the help systems in Dreamweaver, Fireworks, Contribute, and FlashPaper.

NOTE
For information about using the help systems for the other Studio products, see "Using the Dreamweaver, Fireworks, Contribute, and FlashPaper help systems" on page 32.
This section covers the following topics:

- “Opening the Help panel” on page 36
- “Searching the help system” on page 36
- “Using context-sensitive help” on page 38
- “Printing the Flash documentation” on page 39
- “Purchasing printed documentation” on page 39
- “Discussing the Flash documentation with LiveDocs” on page 39
- “Controlling the appearance of the Help panel” on page 40
- “Getting updates to Flash Help” on page 41

Opening the Help panel

The Flash Help panel contains the full set of user-assistance information provided with the Flash application.

To access help and the table of contents:

1. To open the Help panel, select Help > Flash Help or press F.
2. If the table of contents is not visible, click the Table of Contents button to display the Table of Contents pane.
   A list of help books is displayed.
3. Click a book title to open it and display its topics.
4. Click a topic title to display it.

NOTE: The topic hierarchy for the current topic is displayed at the top of each help page.

Searching the help system

Flash Basic 8 and Flash Professional 8 provide thorough search capabilities that help you easily find the information you need. In the Flash Help panel, you can search for help pages that contain specific words or phrases. You can search Flash Help in the following ways:

**Single-word** searches return a list of help pages that contain the specified word. For example, you might type **timeline** in the search text box. This search returns a list of help pages that contain the word **timeline** or **Timeline**.
Multiple-word searches return a list of help pages that each contain all of
the search terms you enter. In this case the word and is implicit in the
search. For example, you might type movie clip in the search text box. This
action returns a list of pages that contain both movie and clip—that is, clip
movie, movie clip, or movie...clip, and so on.

Explicit AND/OR searches use the words and or or to refine the search
results. For example, you might type timeline and keyframe or tween in
the search text box. This action returns a list of help pages that contain
timeline and keyframe and help pages that contain timeline and tween.

Exact phrase searches allow you to use quotation marks to return only
pages that contain the specific phrase you enter. For example, you might
type “motion tween” in the search text box. This action returns a list of
help pages that contain the phrase motion tween, but not pages that contain
separate instances of motion and tween.

Exact phrase with explicit AND/OR searches allow you to use a
combination of quotation marks and the words and or or to further refine
your searches. For example, you might type “motion tween” and
“ActionScript” in the search field. This action returns a list of pages that
contain both the phrase motion tween and the word ActionScript.

To search for a word or phrase in the Help panel:
1. In the Category menu, select a category of books to search.
   To search all of the books, select All Books.
2. Enter a word or phrase in the text box, and then click Search.
   A list of help topics that contain the word or phrase is displayed,
   organized by book.
3. Click a help topic to select it from the list.
   The topic appears in the Table of Contents pane of the Help panel.
   The table of contents path to the topic appears at the top of each
   help page.

Click Clear to return to the Table of Contents view.

To find reference information about a specific ActionScript term, use the
ActionScript 2.0 Language Reference, or use Search.
To search for a word or phrase within a specific help page:
1. Locate the help page you want to search.
2. Click in the help page so it has the focus.
3. Press Ctrl+F (Windows) or Command+F (Macintosh).
4. In the Find dialog box, enter the word or phrase you want to search for and click Find Next.

If the word or phrase exists in the current help page, it is highlighted in the Help panel.

Using context-sensitive help

The Help panel contains context-sensitive reference information that you can access from the Actions panel. By clicking an ActionScript term in the Actions panel, you can display help information about that term.

To access context-sensitive help from the Actions panel:
1. To select an item for reference, do any one of the following:
   - Select an item in the Actions panel toolbox pane (on the left side of the Actions panel).
   - Select an ActionScript term in the Actions panel in the Script pane.
   - Place the insertion point before an ActionScript term in the Actions panel in the Script pane.
2. To open the Help panel reference page for the selected item, do one of the following:
   - Press F1.
   - Right-click the item and select View Help.
   - Click Reference above the Script pane.

To access context-sensitive help from a Flash panel:
- Click the pop-up menu in the panel and select Help.

To access context-sensitive help from a dialog box:
- Click the Help icon in the dialog box.

NOTE

The Flash Tutorials book in the Help panel contains many tutorials that introduce you to the features of Flash. These tutorials allow you to practice on isolated examples. If you are new to Flash, or if you have used only a limited set of Flash features, start with the Flash Tutorials book.
Printing the Flash documentation

Printable versions of each of the books in the Flash help system are available on the Macromedia website. You can also print individual help pages from within the Flash Help panel.

To print an individual book or chapter from the Macromedia website:
2. Locate the PDF file for the book you wish to print.
3. Download the PDF file.
4. Open the PDF file in Adobe Reader.
5. Print the file, or a single chapter from the file if you prefer.
   The Flash End User License Agreement allows you to print the documentation PDFs at retail copy stores if you prefer.

To print an individual help page:
1. Click Print in the Help panel toolbar.
2. In the Print dialog box, select the printer and other printing options, and then click Print.

You can also purchase the printed manuals at the Macromedia Online Store at www.macromedia.com/go/books_and_training.

Purchasing printed documentation

To purchase printed versions of the Flash documentation, go to www.macromedia.com/go/books.

Discussing the Flash documentation with LiveDocs

In addition to accessing Flash documentation in the Flash Help panel, you can get the same documentation online in the LiveDocs format. To find that equivalent page on the LiveDocs website, you simply click the View Comments on LiveDocs link at the bottom of a help page in the Help panel. The Flash LiveDocs are available at livedocs.macromedia.com/go/livedocs_flash.
One of the advantages of LiveDocs is the ability to see comments that clarify the documentation, or correct any errata or issues that arise after a software release. LiveDocs is not the place to ask for help requests, such as asking questions about your code that doesn't work, or how to complete a specific task. LiveDocs is the correct place to provide feedback about the documentation (for example, if you notice a sentence or paragraph that could be clarified).

When you click the link to add a comment on LiveDocs, you see several points about the kinds of comments that are acceptable on the system. Please read these guidelines closely, or your comment might be removed from the website if it does not conform to the guidelines.

If you have a question about Flash, please ask it on the Macromedia Flash web forums: www.macromedia.com/go/flash_forums. The web forums are the best place to ask questions, because many Macromedia employees, Team Macromedia volunteers, Macromedia user group managers and members, and even technical writers monitor these forums.

**Controlling the appearance of the Help panel**

You can control how the Help panel appears in Flash.

**Arranging the Help panel in the Flash workspace**

You can arrange the Help panel position in the workspace to optimize its usability. You can easily control the size of the display area, and where and when the Help panel is displayed. For more details about working with panels, see “Using panels and the Property inspector” on page 81.

**To arrange the Help panel in a docked position:**

1. Dock the Help panel in the desired position.
2. Expand the Help panel if it is not already expanded.
3. Drag the split bar between the panel or panel group and the Document window so you can see the Stage area.
4. Press F1 to collapse and expand the Help panel as needed.
To arrange the Help panel in an undocked (floating) position:
1. Undock the Help panel to the desired position.
2. Expand the Help panel if it is not already expanded.
3. Resize the panel window.
4. Press F1 to close or open the Help panel as needed.

Changing the size of text displayed in the Help panel
If you are using a laptop, you may find it useful to change the text in the Help panel to a larger size. You can change the size of the text in the Help panel by changing the size of the text in your web browser.

To use your browser to change the size of the text displayed in the Help panel:
1. Open your browser and edit the preferences to change the size of text in the browser to a larger size. You must restart Flash for the change to take effect.

Getting updates to Flash Help
The Update feature in Flash allows you to update your help system with new and revised documentation, including procedures and lessons. You can click the Update button to see if new information is available.

To update Flash Help:
1. Verify that you’re connected to the Internet.
2. Click Update in the Help panel toolbar and follow the instructions to download the help system update.

When a help update is released, Macromedia creates and posts a new PDF of each updated book on the Macromedia documentation page at www.macromedia.com/go/fl_documentation/.

Tip
In Windows, you can change the size of the text in the Help panel by clicking in the Table of Contents pane of the Help panel, pressing Control, and scrolling the mouse wheel. This also changes the size of text in your web browser.
Macromedia Studio offers an integrated workspace that allows for seamless transition between products. You will find that panels, menus, selection icons, and other user interface elements are similar across products and are easy to use. As you move between products, the consistent and familiar workspace helps you increase productivity while decreasing the amount of time you need to spend learning a new product.

This chapter contains the following sections:

- **Dreamweaver basics** .................................................. 43
- **Flash basics** ............................................................... 57
- **Fireworks basics** ......................................................... 102
- **Contribute basics** ....................................................... 112
- **FlashPaper basics** ....................................................... 118

**Dreamweaver basics**

To get the most out of your Dreamweaver experience, you should understand the basic elements of the Dreamweaver workspace. This section gives you an overview of Dreamweaver files and introduces you to the most important and commonly used workspace elements.

This section contains the following topics:

- “About Dreamweaver files” on page 44
- “Getting to know the Dreamweaver workspace” on page 45
About Dreamweaver files

You can work with a variety of file types in Dreamweaver. The primary kind of file you will work with is the HTML file. HTML files—or Hypertext Markup Language files—contain the tag-based language responsible for displaying a web page in a browser. You can save HTML files with either the .html or the .htm extension. Dreamweaver saves files using the .html extension by default.

Following are some of the other common file types you might use when working in Dreamweaver:

**CSS**, or Cascading Style Sheet files, have a .css extension. They are used to format HTML content and control the positioning of various page elements. For more information on working with these types of files, see “Understanding Cascading Style Sheets” in *Using Dreamweaver*.

**GIF**, or Graphics Interchange Format files, have a .gif extension. GIF format is a popular web graphic format for cartoons, logos, graphics with transparent areas, and animations. GIF files contain a maximum of 256 colors.

**JPEG**, or Joint Photographic Experts Group files (named after the organization that created the format), have a .jpg extension and are usually photographs or high-color images. The JPEG format is best for digital or scanned photographs, images using textures, images with gradient color transitions, and any images that require more than 256 colors.

**XML**, or Extensible Markup Language files, have a .xml extension. They contain data in a raw form that can be formatted using XSL (Extensible Stylesheet Language). For more information on working with these types of files, see Chapter 36, “Displaying XML Data in Web Pages,” in *Using Dreamweaver*.

**XSL**, or Extensible Stylesheet Language files, have a .xsl or .xslt extension. They are used to style XML data that you want to display on a web page. For more information on working with these types of files, see Chapter 36, “Displaying XML Data in Web Pages,” in *Using Dreamweaver*.

**CFML**, or ColdFusion Markup Language files, have a .cfm extension. They are used to process dynamic pages. For more information on working with these types of files, see Chapter 40, “Building ColdFusion Applications Rapidly,” in *Using Dreamweaver*. 
ASPX, or ASP.NET files, have a .aspx extension. They are used to process dynamic pages. For more information on working with these types of files, see Chapter 41, “Building ASP.NET Applications Rapidly,” in Using Dreamweaver.

PHP, or PHP: Hypertext Preprocessor files, have a .php extension. They are used to process dynamic pages. For more information on working with these types of files, see Chapter 43, “Building PHP Applications Rapidly,” in Using Dreamweaver.

Getting to know the Dreamweaver workspace

The Dreamweaver workspace lets you view documents and object properties. The workspace also places many of the most common operations in toolbars so that you can quickly make changes to your documents.

This section is designed to give you an overview of the Dreamweaver 8 workspace. For more comprehensive information about any of the workspace elements introduced in this section, see Chapter 1, “Exploring the Workspace,” in Using Dreamweaver.

This section contains the following topics:

- “The workspace layout” on page 46
- “The Document window” on page 48
- “The Document toolbar” on page 49
- “The status bar” on page 50
- “The Insert bar” on page 51
- “The Coding toolbar” on page 53
- “The Property inspector” on page 54
- “The Files panel” on page 55
- “The CSS Styles panel” on page 56
The workspace layout

In Windows, Dreamweaver provides an all-in-one-window integrated layout. In the integrated workspace, all windows and panels are integrated into a single larger application window.

**NOTE**

The Windows workspace also has a Coder option, which docks the panel groups on the left side and displays the Document window in Code view by default. For more information, see “Using the coder-oriented workspace (Windows only)” in *Using Dreamweaver*. To use this option, see “Choosing the workspace layout (Windows only)” in *Using Dreamweaver*. 
On the Macintosh, Dreamweaver can display multiple documents in a single window with tabs that identify each document. Dreamweaver can also appear as part of a floating workspace in which each document appears in its own individual window. Panel groups are initially docked together, but can be undocked into their own windows. Windows “snap” automatically to each other, to the sides of the screen, and to the Document window as you drag or resize them.

You can switch between different layouts both in Windows and on the Macintosh. For more information, see “Choosing the workspace layout (Windows only)” and “Displaying tabbed documents (Macintosh)” in Using Dreamweaver.
The Document window

The Document window shows the current document. You can select any of the following views:

**Design view** is a design environment for visual page layout, visual editing, and rapid application development. In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what you would see viewing the page in a browser.

**Code view** is a hand-coding environment for writing and editing HTML, JavaScript, server-language code—such as PHP or ColdFusion Markup Language (CFML)—and any other kind of code. For more information, see Chapter 20, “Coding in Dreamweaver,” in *Using Dreamweaver*.

**Code and Design view** lets you view both Code view and Design view for the same document in a single window.

When the Document window has a title bar, the title bar displays the page title and, in parentheses, the file’s path and filename. After the filename, Dreamweaver displays an asterisk if you’ve made changes that you haven’t saved yet.

When the Document window is maximized in the integrated workspace layout (Windows only), it has no title bar; in that case the page title and the file’s path and filename appear in the title bar of the main workspace window.

Additionally, when a Document window is maximized, tabs appear at the top of the Document window area showing the filenames of all open documents. To switch to a document, click its tab.

For more information about using the Document window, see Chapter 1, “Exploring the Workspace,” in *Using Dreamweaver*. 
The Document toolbar

The Document toolbar contains buttons that let you toggle between different views of your document quickly: Code, Design, and a split view that shows both Code and Design views.

The toolbar also contains some common commands and options related to viewing the document and transferring it between the local and remote sites.

The following options appear in the Document toolbar:

**Show Code View** displays only the Code view in the Document window.

**Show Code and Design Views** displays Code view in part of the Document window and Design view in another part. When you select this combined view, the option Design View on Top becomes available in the View Options menu. Use this option to specify which view appears at the top of your Document window.

**Show Design View** displays only the Design view in the Document window.

**Server Debug** displays a report to help you debug the current ColdFusion page. The report includes errors, if any, in your page.

**Document Title** allows you to enter a title for your document, to be displayed in the browser’s title bar. If your document already has a title, it appears in this field.

**No Browser/Check Errors** enables you to check cross-browser compatibility.

**Validate Markup** lets you validate the current document or a selected tag.
File Management displays the File Management pop-up menu.

Preview/Debug in Browser allows you to preview or debug your document in a browser. Select a browser from the pop-up menu.

Refresh Design View refreshes the document’s Design view after you make changes in Code view. Changes you make in Code view don’t automatically appear in Design view until you perform certain actions, such as saving the file or clicking this button.

View Options allows you to set options for Code view and Design view, including which view should appear above the other. Options in the menu are for the current view: Design view, Code view, or both.

Visual Aids lets you use different visual aids to design your pages.

For more information about using the Document toolbar, see Chapter 1, “Exploring the Workspace,” in Using Dreamweaver.

The status bar

The status bar at the bottom of the Document window provides additional information about the document you are creating.

The tag selector shows the hierarchy of tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all its contents. Click <body> to select the entire body of the document. To set the class or id attributes for a tag in the tag selector, right-click (Windows) or Control-click (Macintosh) the tag and select a class or ID from the context menu. The tag selector is the preferable method for selecting tags because it ensures that you are always selecting the tag with accuracy.
The Hand tool lets you click the document and drag it in the Document window. Click the Select tool to disable the Hand tool.

The Zoom tool and Set Magnification pop-up menu let you set a magnification level for your document. For more information, see “Zooming in and out” in Using Dreamweaver.

The Window Size pop-up menu (visible in Design view only) lets you resize the Document window to predetermined or custom dimensions. For more information, see “Resizing the Document window” in Using Dreamweaver.

To the right of the Window Size pop-up menu are the estimated document size and estimated download time for the page, including all dependent files such as images and other media files. For more information, see “Setting download time and size preferences” in Using Dreamweaver.

For more information about using the status bar, see Chapter 1, “Exploring the Workspace,” in Using Dreamweaver.

**The Insert bar**

The Insert bar contains buttons for creating and inserting objects such as tables, layers, and images. When you roll the pointer over a button, a tooltip appears with the name of the button.

The buttons are organized into several categories, which you can switch on the left side of the Insert bar. Additional categories appear when the current document contains server code, such as ASP or CFML documents. When you start Dreamweaver, the category you were last working in opens.

Some categories have buttons with pop-up menus. When you select an option from a pop-up menu, it becomes the default action for the button. For example, if you select Image Placeholder from the Image button's pop-up menu, the next time you click the Image button, Dreamweaver inserts an image placeholder. Anytime you select a new option from the pop-up menu, the default action for the button changes.
The Insert bar is organized in the following categories:

**The Common category** enables you to create and insert the most commonly used objects, such as images and tables.

**The Layout category** enables you to insert tables, `div` tags, layers, and frames. You can also choose among three views of tables: Standard (default), Expanded Tables, and Layout. When Layout mode is selected, you can use the Dreamweaver layout tools: Draw Layout Cell and Draw Layout Table.

**The Forms category** contains buttons for creating forms and inserting form elements.

**The Text category** enables you to insert a variety of text- and list-formatting tags, such as `b`, `em`, `p`, `h1`, and `ul`.

**The HTML category** enables you to insert HTML tags for horizontal rules, head content, tables, frames, and scripts.

**Server-code categories** are available only for pages that use a particular server language, including ASP, ASP.NET, CFML Basic, CFML Flow, CFML Advanced, JSP, and PHP. Each of these categories provides server-code objects that you can insert in Code view.

**The Application category** enables you to insert dynamic elements such as recordsets, repeated regions, and record insertion and update forms.

**The Flash elements category** enables you to insert Macromedia Flash elements.

**The Favorites category** enables you to group and organize the Insert bar buttons you use the most in one common place.

For more information about using the Insert bar, see Chapter 1, “Exploring the Workspace,” in *Using Dreamweaver*. 
The Coding toolbar

The Coding toolbar contains buttons that let you perform many standard coding operations, such as collapsing and expanding code selections, highlighting invalid code, applying and removing comments, indenting code, and inserting recently used code snippets. The Coding toolbar is visible only in Code view and appears vertically on the left side of the Document window.

You cannot undock or move the Coding toolbar, but you can hide it. For more information, see “Displaying toolbars” in Using Dreamweaver.

For more information about using the Coding toolbar, see “Inserting code quickly with the Coding toolbar” in Using Dreamweaver.
The Property inspector

The Property inspector lets you examine and edit the most common properties for the currently selected page element, such as text or an inserted object. The contents of the Property inspector vary depending on the element selected. For example, if you select an image on your page, the Property inspector changes to show properties for the image (such as the file path to the image, the width and height of the image, the border around the image, if any, and so on).

The Property inspector is at the bottom of the workspace by default, but you can dock it at the top of the workspace if you want. Or, you can make it a floating panel in the workspace. For more information about moving the Property inspector, see “Docking and undocking panels and panel groups” in Using Dreamweaver.

For more information about using the Property inspector, see “Using the Property inspector” in Using Dreamweaver.
The Files panel

You use the Files panel to view and manage the files in your Dreamweaver site.

When you view sites, files, or folders in the Files panel, you can change the size of the viewing area, as well as expand or collapse the Files panel. When the Files panel is collapsed it displays the contents of the local site, the remote site, or the testing server as a list of files. When expanded, it displays the local site and either the remote site or testing server. The Files panel can also display a visual site map of the local site.

For Dreamweaver sites, you can also customize the Files panel by changing the view—either your local or remote site—that appears by default in the collapsed panel.

For more information about using the Files panel to manage your site, see Chapter 4, “Managing Your Files,” in Using Dreamweaver.
The CSS Styles panel

The CSS Styles panel lets you track the CSS rules and properties affecting a currently selected page element (Current mode), or the rules and properties affecting an entire document (All mode). A toggle button at the top of the CSS Styles panel lets you switch between the two modes. The CSS Styles panel also lets you modify CSS properties in both All and Current mode.

You can resize any of the panes by dragging the borders between the panes.

In Current mode, the CSS Styles panel displays three panes: a Summary for Selection pane that displays the CSS properties for the current selection in the document, a Rules pane that displays the location of selected properties (or a cascade of rules for the selected tag, depending on your selection), and a Properties pane that lets you edit CSS properties for the rule defining the selection.
In All mode, the CSS Styles panel displays two panes: an All Rules pane (on top), and a Properties pane (on bottom). The All Rules pane displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the current document. The Properties pane lets you edit CSS properties for any selected rule in the All Rules pane.

Any changes you make in the Properties pane are applied immediately, letting you preview your work as you go.

For more information about the CSS Styles panel, see “About the CSS Styles panel” in Using Dreamweaver.

Flash basics

To get the most out of your Flash experience, you should understand the basic elements of the Flash workspace. This section gives you an overview of Flash files and introduces you to the most important and commonly used workspace elements, including the Stage, Property inspector, and Tools panel.

This section contains the following topics:

- “About Flash files” on page 57
- “Getting to know the Flash workspace” on page 59

About Flash files

The primary Flash file type, FLA files, contain three basic types of information that comprise a Flash document. These include the following:

Media objects are the various graphic, text, sound and video objects that comprise the content of your Flash document. By importing or creating these elements in Flash and then arranging them on the Stage and in the Timeline, you define what the viewer of your document will see and when they will see it.

The Timeline is the place in Flash where you tell Flash when specific media objects should appear on the Stage. The Timeline is like a spreadsheet that progresses from left to right, with the columns representing time. The rows represent layers, with the content in higher layers appearing above the content in lower layers on the Stage.
ActionScript code is the programming code you can add to Flash documents to make them respond to user interactions and to more finely control the behavior of your Flash documents. Much can be accomplished in Flash without ActionScript, but using ActionScript offers many more possibilities.

Flash can be used to work with a variety of file types. Each type has a separate purpose. The following list describes each file type and its uses:

- FLA files are the primary files you work with in Flash. These are the files that contain the basic media, Timeline, and script information for a Flash document.
- SWF files are the compressed versions of FLA files. These files are the ones you display in a web page.
- AS files are ActionScript files. You can use these files if you prefer to keep some or all of your ActionScript code outside of your FLA files. These can be helpful for code organization and for projects that have multiple people working on different parts of the Flash content.
- SWC files contain the reusable Flash components. Each SWC file contains a compiled movie clip, ActionScript code, and any other assets that the component requires.
- ASC files are files used to store ActionScript that will be executed on a computer running Flash Communication Server. These files provide the ability to implement server-side logic that works in conjunction with ActionScript in a SWF file.
- JSFL files are JavaScript files that you can use to add new functionality to the Flash authoring tool. See Extending Flash for more information.
- FLP files are Flash Project files (Flash Professional 8 only). You can use Flash Projects to manage multiple document files in a single project. Flash Projects allow you to group multiple, related files together to create complex applications.
Getting to know the Flash workspace

The following sections provide a detailed introduction to the tools, panels, and other elements of the Flash workspace.

This section contains the following topics:

- “Using the Start page” on page 59
- “Using the Stage” on page 60
- “Using the Timeline” on page 62
- “Using frames and keyframes” on page 66
- “Using layers” on page 69
- “About the main toolbar and edit bar” on page 75
- “Using the Tools panel” on page 76
- “Using the grid, guides, and rulers” on page 78
- “Using panels and the Property inspector” on page 81
- “Setting preferences in Flash” on page 87
- “Customizing keyboard shortcuts” on page 92
- “Using context menus” on page 95
- “Accessibility in the Flash authoring environment” on page 95

Using the Start page

Whenever Flash is running with no documents open, the Start page appears. The Start page provides easy access to frequently used actions.

The Start page contains the following four areas:

- **Open a Recent Item** lets you open your most recent documents. You can also display the Open File dialog box by clicking the Open icon.

- **Create New** lists Flash file types, such as Flash documents and ActionScript files. You can quickly create a new file by clicking the desired file type in the list.

- **Create from Template** lists the templates most commonly used to create new Flash documents. You can create a new file by clicking the desired template in the list.

- **Extend** links to the Macromedia Flash Exchange website, where you can download helper applications for Flash, Flash extensions, and related information.
The Start page also offers quick access to Help resources. You can take a tour of Flash, learn about Flash documentation resources, and find Macromedia Authorized Training facilities.

**To hide the Start page:**
- On the Start page, select Don’t Show Again.

**To display the Start page again, do one of the following:**
- (Windows) Select Edit > Preferences and select Show Start Page in the General category.
- (Macintosh) Select Flash > Preferences and select Show Start Page in the General category.

**Using the Stage**

The Stage is the rectangular area where you place graphic content, including vector art, text boxes, buttons, imported bitmap graphics or video clips, and so on when creating Flash documents. The Stage in the Flash authoring environment represents the rectangular space in Macromedia Flash Player or in a web browser window where your Flash document appears during playback. You can zoom in and out to change the view of the Stage as you work.

The grid, guides, and rulers help you position content precisely on the Stage. For more information, see “Using the grid, guides, and rulers” on page 78.
Zooming

To view the entire Stage on the screen, or to view a particular area of your drawing at high magnification, you can change the magnification level. The maximum magnification depends on the resolution of your monitor and the document size. The minimum value for zooming out on the Stage is 8%. The maximum value for zooming in on the Stage is 2000%.

To magnify or reduce your view of the Stage, do one of the following:

- To zoom in on a certain element, select the Zoom tool in the Tools panel, and click the element. To switch the Zoom tool between zooming in or out, use the Enlarge or Reduce modifiers (in the options area of the Tools panel when the Zoom tool is selected) or Alt-click (Windows) or Option-click (Macintosh).

- To zoom in on a specific area of your drawing, drag a rectangular selection on the Stage with the Zoom tool. Flash sets the magnification level so that the specified rectangle fills the window.

- To zoom in on or out of the entire Stage, select View > Zoom In or View > Zoom Out.

- To zoom in or out by a specified percentage, select View > Magnification, and select a percentage from the submenu or select a percentage from the Zoom control at the upper-right corner of the Timeline.

- To scale the Stage so it fits completely in the application window, select View > Magnification > Fit in Window.

- To display the contents of the current frame, select View > Magnification > Show All, or select Show All from the Zoom control at the upper-right side of the application window. If the scene is empty, the entire Stage appears.
To display the entire Stage, select View > Magnification > Show Frame or select Show Frame from the Zoom control at the upper-right corner of the Timeline.

To display the workspace surrounding the Stage, select View > Work Area. The work area is shown in light gray. Use the Work Area command to view elements in a scene that are partly or completely outside of the Stage area. For example, to have a bird fly into a frame, you would initially position the bird outside of the Stage in the work area and then animate it into the Stage area.

Moving the view of the Stage
When the Stage is magnified, you may not be able to see all of it. The Hand tool lets you move the Stage to change the view without having to change the magnification.

To move the Stage view:
1. In the Tools panel, select the Hand tool. To temporarily switch between another tool and the Hand tool, hold down the Spacebar and click the tool in the Tools panel.
2. Drag the Stage.

Using the Timeline
The Timeline organizes and controls a document’s content over time in layers and frames. Like films, Flash documents divide lengths of time into frames. Layers are like multiple film strips stacked on top of one another, each containing a different image that appears on the Stage. The major components of the Timeline are layers, frames, and the playhead.

Layers in a document are listed in a column on the left side of the Timeline. Frames contained in each layer appear in a row to the right of the layer name. The Timeline header at the top of the Timeline indicates frame numbers. The playhead indicates the current frame displayed on the Stage. As a Flash document plays, the playhead moves from left to right through the Timeline.
The Timeline status display at the bottom of the Timeline indicates the selected frame number, the current frame rate, and the elapsed time to the current frame.

When an animation is played, the actual frame rate is displayed; this may differ from the document’s frame rate setting if the computer can’t calculate and display the animation quickly enough.

You can change the way frames are displayed in the Timeline, as well as display thumbnails of frame content in the Timeline. The Timeline shows where there is animation in a document, including frame-by-frame animation, tweened animation, and motion paths. For more information on animation, see “Creating Motion” in Using Flash.

Controls in the layers section of the Timeline let you hide, show, lock, or unlock layers, as well as display layer contents as outlines. For more information, see “Editing layers and layer folders” on page 72.

You can insert, delete, select, and move frames in the Timeline. You can also drag frames to a new location on the same layer or to a different layer. For more information, see “Working with frames in the Timeline” on page 66.

Changing the appearance of the Timeline
By default, the Timeline appears at the top of the main application window, above the Stage. To change its position, you can dock the Timeline to the bottom or either side of the main application window, or display the Timeline as its own window. You can also hide the Timeline.
You can resize the Timeline to change the number of layers and frames that are visible. When there are more layers than can be displayed in the Timeline, you can view additional layers by using the scroll bars on the right side of the Timeline.

**To move the Timeline when it is docked to the application window:**
- Drag the gripper at the left of the word Timeline in the panel title bar.

![Timeline](image)

**To dock an undocked Timeline:**
- Drag the Timeline title bar to an edge of the application window. Press Control and drag to prevent the Timeline from docking.

**To lengthen or shorten layer name fields:**
- Drag the bar separating the layer names and the frames portions of the Timeline.

**To resize the Timeline, do one of the following:**
- If the Timeline is docked to the main application window, drag the bar separating the Timeline from the Stage area.
- If the Timeline is not docked to the main application window, drag the lower-right corner (Windows) or the size box in the lower-right corner (Macintosh).

**Moving the playhead**
The playhead moves through the Timeline as a document plays to indicate the current frame displayed on the Stage. The Timeline header shows the frame numbers of the animation. To display a frame on the Stage, you move the playhead to the frame in the Timeline.
When you're working with a large number of frames that can't all be displayed in the Timeline at once, you can move the playhead along the Timeline to easily display a specific frame.

**To go to a frame:**
- Click the frame's location in the Timeline header, or drag the playhead to the desired position.

**To center the Timeline on the current frame:**
- Click the Center Frame button at the bottom of the Timeline.

**Changing the display of frames in the Timeline**
You can change the size of frames in the Timeline, and add color to sequences of frames to highlight them. You can also include thumbnail previews of frame content in the Timeline. These thumbnails are useful as an overview of the animation, but they require extra screen space.
To change the display of frames in the Timeline:

1. Click the Frame View button in the upper-right corner of the Timeline to display the Frame View pop-up menu.

2. Select from the following options:
   - To change the width of frame cells, select Tiny, Small, Normal, Medium, or Large. (The Large frame-width setting is useful for viewing the details of sound waveforms.)
   - To decrease the height of frame cell rows, select Short.
   - To turn the tinting of frame sequences on or off, select Tinted Frames.
   - To display thumbnails of the content of each frame scaled to fit the Timeline frames, select Preview. This can cause the apparent content size to vary.
   - To display thumbnails of each full frame (including empty space), select Preview in Context. This is useful for viewing the way elements move within their frames over the course of the animation, but previews are generally smaller than with the Preview option.

Using frames and keyframes

A keyframe is a frame in which you define a change to an object’s properties for an animation or include ActionScript code to control some aspect of your document. Flash can tween, or automatically fill in, the frames between keyframes you define in order to produce fluid animations. Because keyframes let you produce animation without drawing each individual frame, they make creating animation easier. You can easily change the length of a tweened animation by dragging a keyframe in the Timeline.

The order in which frames and keyframes appear in the Timeline determines the order in which they are displayed in a Flash application. You can arrange keyframes in the Timeline to edit the sequence of events in an animation.

Working with frames in the Timeline

In the Timeline, you work with frames and keyframes, placing them in the order you want the objects in the frames to appear. You can change the length of a tweened animation by dragging a keyframe in the Timeline.
You can perform the following modifications on frames or keyframes:

- Insert, select, delete, and move frames or keyframes
- Drag frames and keyframes to a new location on the same layer or on a different layer
- Copy and paste frames and keyframes
- Convert keyframes to frames
- Drag an item from the Library panel onto the Stage to add the item to the current keyframe

The Timeline provides a view of tweened frames in an animation. For information on editing tweened frames, see “Creating Motion” in Using Flash.

Flash offers two different methods for selecting frames in the Timeline. In frame-based selection (the default) you select individual frames in the Timeline. In span-based selection, the entire frame sequence, from one keyframe to the next, is selected when you click any frame in the sequence. You can specify span-based selection in Flash preferences.

**To specify span-based selection:**

1. Select Edit > Preferences.
2. Select the General category.
3. In the Timeline section, select Span based selection.
4. Click OK.

For more information, see “Setting preferences in Flash” on page 87.

**To insert frames in the Timeline, do one of the following:**

- To insert a new frame, select Insert > Frame.
- To create a new keyframe, select Insert > Keyframe, or right-click (Windows) or Control-click (Macintosh) the frame where you want to place a keyframe, and select Insert Keyframe from the context menu.
- To create a new blank keyframe, select Insert > Blank Keyframe, or right-click (Windows) or Control-click (Macintosh) the frame where you want to place the keyframe, and select Insert Blank Keyframe from the context menu.
To select one or more frames in the Timeline:

- To select one frame, click the frame. If you have Span Based Selection enabled in the Preferences dialog box, clicking one frame selects the entire frame sequence between two keyframes. For more information, see “Setting preferences in Flash” on page 87.
- To select multiple contiguous frames, Shift-click additional frames.
- To select multiple discontiguous frames, Control-click (Windows) or Command-click (Macintosh) additional frames.

To select all frames in the Timeline:

- Select Edit > Timeline > Select All Frames.

To delete or modify a frame or keyframe, do one of the following:

- To delete a frame, keyframe, or frame sequence, select the frame, keyframe, or sequence and select Edit > Timeline > Remove Frame, or right-click (Windows) or Control-click (Macintosh) the frame, keyframe, or sequence and select Remove Frame from the context menu. Surrounding frames remain unchanged.
- To move a keyframe or frame sequence and its contents, drag the keyframe or sequence to the desired location.
- To extend the duration of a keyframe animation, press Alt and drag (Windows) or press Option and drag (Macintosh) the keyframe to the frame that you want to be the final frame of the sequence.
- To copy a keyframe or frame sequence by dragging, Alt-click (Windows) or Option-click (Macintosh) and drag the keyframe to the new location.
- To copy and paste a frame or frame sequence, select the frame or sequence and select Edit > Timeline > Copy Frames. Select a frame or sequence that you want to replace, and select Edit > Timeline > Paste Frames.
To convert a keyframe to a frame, select the keyframe and select Edit > Timeline > Clear Keyframe, or right-click (Windows) or Control-click (Macintosh) the keyframe and select Clear Keyframe from the context menu. The Stage contents of the cleared keyframe and all frames up to the subsequent keyframe are replaced with the Stage contents of the frame preceding the cleared keyframe.

To change the length of a tweened sequence, drag the beginning or ending keyframe left or right. To change the length of a frame-by-frame animation sequence, see “Creating frame-by-frame animations” in Using Flash.

To add an item from the library to the current keyframe, drag the item from the Library panel onto the Stage.

Using layers

Layers are like transparent sheets of acetate stacked on top of each other on the Stage. Layers help you organize the artwork in your document. You can draw and edit objects on one layer without affecting objects on another layer. Where there is nothing on a layer, you can see through it to the layers below.

To draw, paint, or otherwise modify a layer or folder, you select the layer in the Timeline to make it active. A pencil icon next to a layer or folder name in the Timeline indicates that the layer or folder is active. Only one layer can be active at a time (although more than one layer can be selected at a time).

When you create a new Flash document, it contains only one layer. You can add more layers to organize the artwork, animation, and other elements in your document. The number of layers you can create is limited only by your computer’s memory, and layers do not increase the file size of your published SWF file. Only the objects you place into layers add to the file size. You can also hide, lock, or rearrange layers.
You can also organize and manage layers by creating layer folders and placing layers in them. You can expand or collapse layer folders in the Timeline without affecting what you see on the Stage. It's a good idea to use separate layers or folders for sound files, ActionScript, frame labels, and frame comments. This helps you find these items quickly when you need to edit them.

In addition, you can use special guide layers to make drawing and editing easier, and mask layers to help you create sophisticated effects.

For an interactive introduction to working with layers in Flash, select Help > Flash Tutorials > Basic Tasks > Work with Layers.

Creating layers and layer folders
When you create a new layer or folder, it appears above the selected layer. The newly added layer becomes the active layer.

**To create a layer, do one of the following:**
- Click the Insert Layer button at the bottom of the Timeline.
- Select Insert > Timeline > Layer.
- Right-click (Windows) or Control-click (Macintosh) a layer name in the Timeline and select Insert Layer from the context menu.

**To create a layer folder, do one of the following:**
- Select a layer or folder in the Timeline, and then select Insert > Timeline > Layer Folder.
- Right-click (Windows) or Control-click (Macintosh) a layer name in the Timeline, and then select Insert Folder from the context menu.

The new folder appears above the layer or folder you selected.

Viewing layers and layer folders
As you work, you may want to show or hide layers or folders. A red X next to the name of a layer or folder in the Timeline indicates that it is hidden.

When you publish a Flash SWF file, any layers that were hidden in the FLA document are preserved and visible in the SWF file.

To help you distinguish which layer an object belongs to, you can display all objects on a layer as colored outlines. You can change the outline color used by each layer.
You can change the height of layers in the Timeline in order to display more information (such as sound waveforms) in the Timeline. You can also change the number of layers displayed in the Timeline.

To show or hide a layer or folder, do one of the following:

- Click in the Eye column to the right of the layer or folder name in the Timeline to hide that layer or folder. Click in it again to show the layer or folder.
- Click the eye icon to hide all the layers and folders in the Timeline. Click it again to show all layers and folders.
- Drag through the Eye column to show or hide multiple layers or folders.
- Alt-click (Windows) or Option-click (Macintosh) in the Eye column to the right of a layer or folder name to hide all other layers and folders. Alt-click or Option-click it again to show all layers and folders.

To view the contents of a layer as outlines, do one of the following:

- Click in the Outline column to the right of the layer's name to display all objects on that layer as outlines. Click in it again to turn off outline display.
- Click the outline icon to display objects on all layers as outlines. Click it again to turn off outline display on all layers.
- Alt-click (Windows) or Option-click (Macintosh) in the Outline column to the right of a layer's name to display objects on all other layers as outlines. Alt-click or Option-click in it again to turn off the outline display for all layers.

To change a layer’s outline color:

1. Do one of the following:
   - Double-click the layer’s icon (the icon to the left of the layer name) in the Timeline.
   - Right-click (Windows) or Control-click (Macintosh) the layer name and select Properties from the context menu.
   - Select the layer in the Timeline and select Modify > Layer.
2. In the Layer Properties dialog box, click the Outline Color box and select a new color, enter the hexadecimal value for a color, or click the Color Picker button and select a color.
3. Click OK.
To change layer height in the Timeline:

1. Do one of the following:
   - Double-click the layer's icon (the icon to the left of the layer name) in the Timeline.
   - Right-click (Windows) or Control-click (Macintosh) the layer name and select Properties from the context menu.
   - Select the layer in the Timeline and select Modify > Timeline > Layer Properties.

2. In the Layer Properties dialog box, select an option for Layer Height and click OK.

To change the number of layers displayed in the Timeline:

- Drag the bar that separates the Timeline from the Stage area.

Editing layers and layer folders

You can rename, copy, and delete layers and folders. You can also lock layers and folders to prevent them from being edited.

By default, new layers are named by the order in which they are created: Layer 1, Layer 2, and so on. You can rename layers to better reflect their contents.

To select a layer or folder, do one of the following:

- Click the name of a layer or folder in the Timeline.
- Click any frame in the Timeline of the layer you want to select.
- Select an object on the Stage that is located in the layer you want to select.

To select two or more layers or folders, do one of the following:

- To select contiguous layers or folders, Shift-click their names in the Timeline.
- To select discontiguous layers or folders, Control-click (Windows) or Command-click (Macintosh) their names in the Timeline.
To rename a layer or folder, do one of the following:
■ Double-click the name of the layer or folder in the Timeline and enter a new name.
■ Right-click (Windows) or Control-click (Macintosh) the name of the layer or folder and select Properties from the context menu. Enter the new name in the Name text box and click OK.
■ Select the layer or folder in the Timeline and select Modify > Timeline > Layer Properties. In the Layer Properties dialog box, enter the new name in the Name text box and click OK.

To lock or unlock one or more layers or folders, do one of the following:
■ Click in the Lock column to the right of the name of a layer or folder to lock it. Click in the Lock column again to unlock the layer or folder.
■ Click the padlock icon to lock all layers and folders. Click it again to unlock all layers and folders.
■ Drag through the Lock column to lock or unlock multiple layers or folders.
■ Alt-click (Windows) or Option-click (Macintosh) in the Lock column to the right of a layer or folder name to lock all other layers or folders. Alt-click or Option-click in the Lock column again to unlock all layers or folders.

To copy a layer:
1. Click the layer name in the Timeline to select the entire layer.
2. Select Edit > Timeline > Copy Frames.
3. Click the Insert Layer button to create a new layer.
4. Click the new layer and select Edit > Timeline > Paste Frames.

To copy the contents of a layer folder:
1. Click the triangle to the left of the folder name in the Timeline to collapse it, if necessary.
2. Click the folder name to select the entire folder.
3. Select Edit > Timeline > Copy Frames.
4. Select Insert > Timeline > Layer Folder to create a new folder.
5. Click the new folder and select Edit > Timeline > Paste Frames.
To delete a layer or folder:
1. Select the layer or folder by clicking its name in the Timeline or any frame in the layer.
2. Do one of the following:
   - Click the Delete Layer button in the Timeline.
   - Drag the layer or folder to the Delete Layer button.
   - Right-click (Windows) or Control-click (Macintosh) the layer or folder name and select Delete Layer from the context menu.

Organizing layers and layer folders
You can rearrange layers and folders in the Timeline to organize your document.

Layer folders help organize your workflow by letting you place layers in a tree structure. You can expand or collapse a folder to see the layers it contains without affecting which layers are visible on the Stage. Folders can contain both layers and other folders, allowing you to organize layers in much the same way you organize files on your computer.

The layer controls in the Timeline affect all layers within a folder. For example, locking a layer folder locks all layers within that folder.

To move a layer or layer folder into a layer folder:
- Drag the layer or layer folder name to the destination layer folder name.
  The layer or layer folder appears inside the destination layer folder in the Timeline.

To change the order of layers or folders:
- Drag one or more layers or folders in the Timeline to the desired position above or below other layers in the Timeline.

To expand or collapse a folder:
- Click the triangle to the left of the folder name.
To expand or collapse all folders:
- Right-click (Windows) or Control-click (Macintosh) and select Expand All Folders or Collapse All Folders from the context menu.

Using guide layers
For help in aligning objects when drawing, you can create guide layers. You can then align objects on other layers to the objects you create on the guide layers. Guide layers are not exported and do not appear in a published SWF file. You can make any layer a guide layer. Guide layers are indicated by a guide icon to the left of the layer name.
You can also create a motion guide layer to control the movement of objects in a motion tweened animation. For more information, see “Tweening motion along a path” in Using Flash.

To designate a layer as a guide layer:
- Select the layer and right-click (Windows) or Control-click (Macintosh) and select Guide from the context menu. Select Guide again to change the layer back to a normal layer.

About the main toolbar and edit bar
The menu bar at the top of the Flash application window displays menus with commands for controlling Flash functionality. The menus include File, Edit, View, Insert, Modify, Text, Commands, Control, Window, and Help.
The edit bar, at the top of the Timeline, contains controls and information for editing scenes and symbols, and for changing the magnification level of the Stage.
For information on changing the Stage magnification level, see “Zooming” on page 61. For information on editing symbols, see “Using Symbols, Instances, and Library Assets” in Using Flash. For information on working with scenes, see “Working with scenes” in Using Flash.
Using the Tools panel

The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage. The Tools panel is divided into four sections:

- The tools area contains drawing, painting, and selection tools.
- The view area contains tools for zooming and panning in the application window.
- The colors area contains modifiers for stroke and fill colors.
- The options area displays modifiers for the currently selected tool. Modifiers affect the tool’s painting or editing operations.

Using the Customize Tools panel dialog box, you can specify which tools to display in the Flash authoring environment. For more information, see “Customizing the Tools panel” on page 77.

For information on using the drawing and painting tools, see “About Flash drawing and painting tools” in Using Flash. For information on using the selection tools, see “Selecting objects” in Using Flash. For information on using the view modification tools, see “Moving the view of the Stage” on page 62.

To show or hide the Tools panel:

- Select Window > Tools.

Selecting tools

You can select tools by clicking in the Tools panel, or by using a keyboard shortcut.

To select a tool, do one of the following:

- Click the tool you want to use. Depending on the tool you select, a set of modifiers may be displayed in the options area at the bottom of the Tools panel.
- Press the tool’s keyboard shortcut. You can view the keyboard shortcuts by selecting Edit > Keyboard Shortcuts.
- To select a tool located in the pop-up menu for a visible tool such as the Rectangle tool, press the icon of the visible tool and select another tool from the pop-up menu.
Customizing the Tools panel

You can customize the Tools panel to specify which tools appear in the authoring environment. You use the Customize Tools panel dialog box to add or remove tools from the Tools panel.

You can display more than one tool in one location. When more than one tool is displayed in a location, the top tool in the group (the most recently used) is displayed with an arrow in the lower-right corner of its icon. When you press and hold the mouse button on the icon, the other tools in the group appear in a pop-up menu. You can then select a tool from the menu.

To customize the Tools panel:

1. To display the Customize Tools panel dialog box, do one of the following:
   - (Windows) Select Edit > Customize Tools panel.
   - (Macintosh) Select Flash > Customize Tools panel.

   The Available Tools menu indicates the tools that are currently available in the Flash. The Current Selection menu indicates the tool (or tools) currently assigned to the selected location in the Tools panel.

2. Click a tool in the Tools panel image or use the arrows to cycle through the tools to specify the location to which you want to assign another tool.

3. To add a tool to the selected location, select the tool in the Available Tools list and click the Add button. It is possible to assign a tool to more than one location.

4. To remove a tool from the selected location, select the tool in the Current Selection scroll list and click the Remove button.

5. Click OK to apply your changes and close the Customize Tools panel dialog box.

To restore the default Tools panel layout:

- Click Restore Default in the Customize Tools panel dialog box.
Using the grid, guides, and rulers

Flash can display rulers and guides that help you draw and lay out objects precisely. You can place guides in a document and snap objects to those guides, or turn on the grid and snap objects to it.

You can also snap objects to other objects or to pixels, or align objects using specified snap tolerance boundaries. For more information, see “Snapping” in Using Flash.

Using rulers

When rulers are displayed, they appear along the top and left sides of the document. You can change the unit of measure used in the rulers from the default of pixels to some other unit. When you move an element on the Stage with the rulers displayed, lines indicating the element's dimensions appear on the rulers.

To display or hide rulers:

■ Select View > Rulers.

To specify the rulers’ unit of measure for a document:

■ Select Modify > Document, and then select a unit from the Ruler Units menu at the lower-left side of the dialog box.

Using guides

You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides, and change the guide color and snap tolerance (how close objects must be to snap to a guide). Flash allows you to create nested Timelines. Draggable guides appear on Stage only when the Timeline in which they were created is active.

You can clear all the guides in the current editing mode—document-editing mode or symbol-editing mode. If you clear guides in document-editing mode, all the guides in the document are cleared. If you clear guides in symbol-editing mode, all the guides in all symbols are cleared.

To create custom guides or irregular guides, you use guide layers. For more information, see “Using guide layers” on page 75.
To display or hide the drawing guides:
■ Select View > Guides > Show Guides.

If the grid is visible and Snap to Grid is turned on when you create guides, guides will snap to the grid.

To turn snapping to guides on or off:
■ Select View > Snapping > Snap to Guides.

Snapping to guides takes precedence over snapping to the grid in places where guides fall between grid lines.

To move a guide:
1. Make sure rulers are visible by selecting View > Rulers.
2. With the Selection tool, click anywhere on the ruler and drag the guide to the desired place on the Stage.

To remove a guide:
■ With guides unlocked, use the Selection tool to drag the guide to the horizontal or vertical ruler. For information on locking and unlocking guides, see the following procedure.

To lock guides:
■ Select View > Guides > Lock Guides.

You can also use the Lock Guides option in the Edit Guides (View > Guides > Edit Guides) dialog box. For more information, see the following procedure.
To set guide preferences:

1. Select View > Guides > Edit Guides and do any of the following:
   - For Color, click the triangle in the color box and select a guide line color from the palette. The default guide color is green.
   - Select or deselect Show Guides to display or hide guides.
   - Select or deselect Snap to Guides to turn snapping to guides on or off.
   - Select or deselect Lock Guides to lock or unlock guides.
   - For Snap Accuracy, select an option from the pop-up menu.
   - If you want to remove all guides, click Clear All.
   - Clear All removes all guides from the current scene.
   - If you want to save the current settings as the default, click Save Default.

2. Click OK.

To clear guides:

- Select View > Guides > Clear Guides.
  
  If you are in document-editing mode, all guides in the document are cleared. If you are in symbol-editing mode, only guides used in symbols are cleared.

Using the grid

When the grid is displayed in a document, it appears as a set of lines behind the artwork in all scenes. You can snap objects to the grid, and you can modify the grid size and grid line color.

To display or hide the drawing grid, do one of the following:

- Select View > Grid > Show Grid.
- Press Control+” (quote) (Windows) or Command+” (quote) (Macintosh).

To turn snapping to grid lines on or off:

- Select View > Snapping > Snap to Grid.
To set grid preferences:
1. Select View > Grid > Edit Grid.
2. For Color, click the triangle in the color box and select a grid line color from the palette.
   The default grid line color is gray.
3. Select or deselect Show Grid to display or hide the grid.
4. Select or deselect Snap to Grid to turn snapping to grid lines on or off.
5. For grid spacing, enter values in the text boxes to the right of the horizontal and vertical arrows.
6. For Snap Accuracy, select an option from the pop-up menu.
7. If you want to save the current settings as the default, click Save Default.

Using panels and the Property inspector
Flash offers many ways to customize the workspace to your needs. Using panels and the Property inspector, you can view, organize, and change media and other assets and their attributes. You can show, hide, and resize panels. You can also group panels together and save custom panel sets to make the workspace match your personal preferences. The Property inspector changes to reflect the tool or asset you are working with, giving you quick access to frequently used features.

About the Property inspector
The Property inspector simplifies document creation by making it easy to access the most commonly used attributes of the current selection, either on the Stage or in the Timeline. You can make changes to the object or document attributes in the Property inspector without accessing the menus or panels that also control these attributes.
Depending on what is currently selected, the Property inspector displays information and settings for the current document, text, symbol, shape, bitmap, video, group, frame, or tool. When two or more different types of objects are selected, the Property inspector displays the total number of objects selected.

To display the Property inspector, do one of the following:
- Select Window > Properties > Properties.
- Press Control+F3 (Windows) or Command+F3 (Macintosh).

About the Library panel
The Library panel is where you store and organize symbols created in Flash, as well as imported files, including bitmap graphics, sound files, and video clips. The Library panel lets you organize library items in folders, see how often an item is used in a document, and sort items by type. For more information, see “Managing media assets with the library” in Using Flash.
To display the Library panel, do one of the following:
- Select Window > Library.
- Press Control+L (Windows) or Command+L (Macintosh).

About the Actions panel
The Actions panel lets you create and edit ActionScript code for an object or frame. Selecting a frame, button, or movie clip instance makes the Actions panel active. The Actions panel title changes to Button Actions, Movie Clip Actions, or Frame Actions, depending on what is selected.
For information on using the Actions panel and writing ActionScript code, including switching between editing modes, see “Using the Actions panel and Script window” in Learning ActionScript 2.0 in Flash.

To display the Actions panel, do one of the following:
- Select Window > Actions.
- Press F9.

Using panels
The various panels in Flash help you view, organize, and change elements in a document. The options available in panels control the characteristics of symbols, instances, colors, type, frames, and other elements. You can customize the Flash interface by displaying the panels you need for a specific task and hiding others.
Panels let you work with objects, colors, text, instances, frames, scenes, and entire documents. For example, you use the Color Mixer panel to create colors, and the Align panel to align objects to each other or the Stage. To view the complete list of panels available in Flash, see the Window menu.

Most panels include a pop-up menu with additional options. This pop-up menu is indicated by a control at the right end of the panel's title bar. (If no pop-up menu control appears, there is no pop-up menu for that panel.)

By default, panels appear grouped at the bottom and at the right of the Flash workspace.

**To open a panel:**
- Select the desired panel from the Window menu.

**To close a panel, do one of the following:**
- Select the desired panel from the Window menu.
- Right-click (Windows) or Control-click (Macintosh) the panel's title bar and select Close Panel Group from the context menu.

**To use a panel's pop-up menu:**
1. Click the control at the far right in the panel's title bar to view the pop-up menu.
2. Click an item in the menu.

![Clicking a panel's pop-up menu](image)

**To resize a panel:**
- Drag the panel's border (Windows) or drag the size box at the panel's lower-right corner (Macintosh).

**To expand or collapse a panel to its title bar:**
- Click the collapse arrow in the title bar. Click the collapse arrow again to expand the panel to its previous size.

![Clicking a panel's collapse arrow](image)
To close all panels:

■ Select Window > Hide Panels.

Arranging panels

In Flash, you can organize panels into groups. You can rearrange the order in which panels appear within panel groups. You can also create new panel groups and dock panels to existing panel groups. If you want a panel to appear on its own, separated from other panel groups, you can float the panel. This is particularly useful for panels that you want access to all the time, for example, the Help panel or the Actions panel.

To move a panel:

■ Drag the panel by its gripper (on the left side of the title bar).

To add a panel to an existing panel group:

■ Drag the panel by its gripper onto another panel. A black line appears next to the target panel to show where the panel will be placed.

To display multiple panels in a single panel window:

1. Click a panel’s pop-up menu.
2. Select the Group Panel Name With option.
3. Select another panel to add the current panel to from the submenu.

The first panel is added as a tab to the second panel.

A tabbed panel showing the Library and Movie Explorer panels
To float a panel:
- Drag the panel by its gripper and move it away from other panels.

To create a new panel group:
- Drag the panel by its gripper, away from other panel groups. Add additional panels to the first panel to form a new group.

Using panel sets
You can create custom panel arrangements, and save these as custom panel sets. You can switch the panel display to the default layout (displaying the Color Mixer, Actions, Property inspector and Library panels) or to a custom layout that you have saved previously.

To save a custom panel set:
1. Select Window > Save Current.
2. Enter a name for the layout and click OK.

To select a panel layout:
1. Select Window > Workspace Layout.
2. From the submenu, select Default Layout to reset panels to the default layout, or select a custom layout that you have saved previously.

To delete custom layouts:
1. Select Window > Workspace Layout > Manage.
2. In the Manage Workspace Layouts dialog box, select the panel set you want to delete.
3. Click Delete.
4. Click Yes to confirm the deletion.
5. Click OK.
Setting preferences in Flash

Flash lets you set preferences for general application operations, editing operations, and Clipboard operations. For more information about the drawing preferences, see “Specifying drawing settings” in Using Flash.

The General category in the Preferences dialog box
To set preferences:
1. Select Edit > Preferences (Windows) or Flash > Preferences (Macintosh).

2. In the Category list, select the one of the following:
   - General
   - ActionScript
   - Auto Format
   - Clipboard
   - Drawing
   - Text
   - Warning

3. Select from the respective options as described in the procedures that follow. For more information on ActionScript Editor preferences, see “Using the ActionScript editor” in Learning ActionScript 2.0 in Flash.

To set General preferences, select from the following options:
- For On Launch options, select an option to specify which document Flash opens when you start the application. Select Show Start Page to display the Start Page. Select New Document to open a new, blank document. Select Last Documents Open to open the documents that were open when you last quit Flash. Select No Document to start Flash without opening a document.

- For Undo, enter a value from 2 to 300 to set the number of undo/redo levels. Undo levels require memory; the more undo levels you use, the more system memory is consumed. The default is 100. Next select Document- or Object-level undo. Document-level undo maintains a single list of all your actions for the entire Flash document. Object-level undo maintains separate lists of your actions for each object in your Flash document. Object-level undo gives you greater flexibility, since you can undo an action on one object without having to also undo actions on other objects that may have been modified more recently than the target object.

- For Printing Options (Windows only), select Disable PostScript if you want to disable PostScript output when printing to a PostScript printer. By default, this option is deselected. Select this option if you have problems printing to a PostScript printer, but keep in mind that this will slow down printing.
For Test Movie Options, select Open Test Movie in Tabs to have Flash open a new document tab in the application window when you select Control > Test Movie. The default is to open the test movie in its own window.

For Selection Options, select or deselect Shift Select to control how Flash handles selection of multiple elements. When Shift Select is off, clicking additional elements adds them to the current selection. When Shift Select is on, clicking additional elements deselects other elements unless you hold down Shift.

Select Show Tooltips to display tooltips when the pointer pauses over a control. Deselect this option if you don’t want to see the tooltips.

Select Contact Sensitive to have objects become selected when any part of them is included in the marquee rectangle when dragging with the Selection or Lasso tools. The default is that objects are only selected when the tool’s marquee rectangle completely surrounds the object.

For Timeline Options, select Span Based Selection to use span-based selection in the Timeline, rather than the default frame-based selection. For more information on span-based and frame-based selection, see “Working with frames in the Timeline” on page 66.

Select Named Anchor on Scenes to have Flash make the first frame of each scene in a document a named anchor. Named anchors let you use the Forward and Back buttons in a browser to jump from scene to scene in a Flash application. For more information, see “Using the Timeline” on page 62.

For Highlight Color, select a color from the panel, or select Use Layer Color to use the current layer’s outline color.

For Project, select Close Files with Project to have all files in a project close when the project file is closed.

Select Save Files on Test or Publish Project to have each file in a project saved whenever the project is tested or published.

For more information, see “Creating and managing project (Flash Professional only) in Using Flash.”

To set ActionScript preferences:

See “About ActionScript preferences” in Learning ActionScript 2.0 in Flash.
To set AutoFormat preferences for ActionScript:
- Select any of the check boxes. To see the effect of each selection, look in the Preview pane.

To set Clipboard preferences, select from the following options:
- For Bitmaps (Windows only), select options for Color Depth and Resolution to specify these parameters for bitmaps copied to the Clipboard. Select Smooth to apply anti-aliasing. Enter a value in the Size Limit text box to specify the amount of RAM that is used when placing a bitmap image on the Clipboard. Increase this value when working with large or high-resolution bitmap images. If your computer has limited memory, select None.
- For Gradient Quality (Windows only), select an option to specify the quality of gradient fills placed in the Windows Metafile. Choosing a higher quality increases the time required to copy artwork. Use this setting to specify gradient quality when pasting items to a location outside of Flash. When you are pasting within Flash, the full gradient quality of the copied data is preserved regardless of the Gradients on Clipboard setting.
- For PICT Settings (Macintosh only), for Type, select Objects to preserve data copied to the Clipboard as vector artwork, or select one of the bitmap formats to convert the copied artwork to a bitmap. Enter a value for Resolution. Select Include PostScript to include PostScript data. For Gradients, select an option to specify gradient quality in the PICT. Choosing a higher quality increases the time required to copy artwork. Use the Gradients setting to specify gradient quality when pasting items to a location outside of Flash. When you are pasting within Flash, the full gradient quality of the copied data is preserved regardless of the Gradient setting.
- For FreeHand Text, select Maintain Text as Blocks to keep text editable in a pasted FreeHand file.

To set Drawing preferences:
- For Pen Tool options, see “Setting Pen tool preferences” in *Using Flash.*
- For Drawing Settings, see “Specifying drawing settings” in *Using Flash.*
To set text preferences, select one of the following options:

- For Font Mapping Default, select a font to use when substituting missing fonts in documents you open in Flash. For more information, see “Substituting missing fonts” in Using Flash.

- For Vertical Text options, select Default Text Orientation to make the default orientation of text vertical, which is useful for some Asian language fonts. By default, this option is deselected.
  Select Right to Left Text Flow to reverse the default text display direction. This option is deselected by default.
  Select No Kerning to turn off kerning for vertical text. This option is deselected by default but is useful to improve spacing for some fonts that use kerning tables.

- For Input Method, select the appropriate language.

To set warning preferences, select one of the following options:

- Select Warn on Save for Macromedia Flash 8 Compatibility to have Flash warn you when you try to save documents with content that is specific to the Flash Basic 8 or Flash Professional 8 authoring tool as a Flash MX 2004 file. This option is selected by default.

- Select Warn on Missing Fonts to have Flash warn you when you open a Flash document that uses fonts that are not installed on your computer. This option is selected by default.

- Select Warn on URL Changes in Launch and Edit to have Flash warn you if the URL for a document has changed since the last time you opened and edited it.

- Select Warn on Reading Generator Content to have Flash display a red X over any Generator objects as a reminder that Generator objects are not supported in Flash 8.

- Select Warn on Inserting Frames when Importing Content to have Flash alert you when it inserts frames in your document to accommodate audio or video files that you import.

- Select Warn on Encoding Conflicts When Exporting .as Files to have Flash alert you when selecting Default Encoding could potentially lead to data loss or character corruption. (For example, if you create a file with English, Japanese, and Korean characters and select Default Encoding on an English system, the Japanese and Korean characters will be corrupted.)
Select Warn on Conversion of Effect Graphic Objects to have Flash warn you when you attempt to edit a symbol that has Timeline effects applied to it.

Select Warn on Exporting to Flash Player 6 r65 to have Flash warn you when you export a document to this earlier version of Flash Player.

Select Warn on Sites with Overlapped Root Folder to have Flash warn you when you create a site in which the local root folder overlaps with another site.

Select Warn on Behavior Symbol Conversion to have Flash warn you when you convert a symbol with a behavior attached to a symbol of a different type—for example, when you convert a movie clip to a button.

Select Warn on Symbol Conversion to have Flash warn you when you convert a symbol to a symbol of a different type.

Select Warn on Automatically Converting from Drawing Object to Group to have Flash warn you when it converts a graphic object drawn in Object Drawing mode to a group.

Select Show Incompatibility Warnings on Feature Controls to have Flash display warnings on controls for features not supported by the Flash Player version that the current FLA file is targeting in its Publish Settings.

Customizing keyboard shortcuts

You can select keyboard shortcuts in Flash to match the shortcuts you use in other applications, or to streamline your Flash workflow. By default, Flash uses built-in keyboard shortcuts designed for the Flash application. You can also select a built-in keyboard shortcut set from one of several popular graphics applications, including Macromedia Fireworks, Adobe Illustrator, and Adobe Photoshop.

To create a custom keyboard shortcut set, you duplicate an existing set, and then add or remove shortcuts from the new set. You can also delete custom shortcut sets.
To view or print the current set of keyboard shortcuts:
1. Select Edit > Keyboard Shortcuts.
2. In the Keyboard Shortcuts dialog box, select the shortcut set you wish to view from the Current pop-up menu.
3. Click the Export Set as HTML button.

![Keyboard Shortcuts dialog box](image)

The Export Set as HTML button

4. In the Save As dialog box that appears, select a name and location for the exported HTML file. The default file name is the name of the selected shortcut set.
5. Click Save.
6. Find the exported file in the folder you selected and open the file in a web browser.
7. To print the file, use the browser’s Print command.

To select a keyboard shortcut set:
1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh).
2. In the Keyboard Shortcuts dialog box, select a shortcut set from the Current Set pop-up menu.

To create a new keyboard shortcut set:
1. Select a keyboard shortcut set as described in the previous procedure.
2. Click the Duplicate Set button.
3. Enter a name for the new shortcut set and click OK.

To rename a custom keyboard shortcut set:
1. In the Keyboard Shortcuts dialog box, select a shortcut set from the Current Set pop-up menu.
2. Click the Rename Set button.
3. In the Rename dialog box, enter a new name and click OK.
To add or remove a keyboard shortcut:

1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh) and select the set that you want to modify.

2. From the Commands pop-up menu, select Drawing Menu Commands, Drawing Tools, Test Movie Menu Commands, or Workplace Accessibility Commands to view shortcuts for the selected category.

3. In the Commands list, select the command for which you want to add or remove a shortcut.

   An explanation of the selected command appears in the description area in the dialog box.

4. Do one of the following:
   - To add a shortcut, click the Add Shortcut (+) button.
   - To remove a shortcut, click the Remove Shortcut (-) button and proceed to step 6.

5. If you are adding a shortcut, enter the new shortcut key combination in the Press Key text box.

6. Click Change.

7. Repeat this procedure to add or remove additional shortcuts.

8. Click OK.

To delete a keyboard shortcut set:

1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh). In the Keyboard Shortcuts dialog box, click the Delete Set button.

2. In the Delete Set dialog box, select a shortcut set and click Delete.

   You cannot delete the built-in keyboard shortcut sets that ship with Flash.
Using context menus

Context menus contain commands relevant to the current selection. For example, when you select a frame in the Timeline window, the context menu contains commands for creating, deleting, and modifying frames and keyframes. Context menus exist for many items and controls in many locations, including on the Stage, in the Timeline, in the Library panel, and in the Actions panel.

To open a context menu:
- Right-click (Windows) or Control-click (Macintosh) an item.

Accessibility in the Flash authoring environment

Accessibility support in the Flash authoring environment provides keyboard shortcuts for navigating and using interface controls, including panels, the Property inspector, dialog boxes, the Stage, and objects on the Stage, so that you can work with these interface elements without using the mouse.

You can customize the keyboard shortcuts for accessibility in the authoring environment using the Workspace Accessibility Commands section of the Keyboard Shortcuts dialog box. For more information, see "Customizing keyboard shortcuts" on page 92.

Some authoring environment accessibility features are unavailable on the Macintosh. For more information, see the following section.

About Flash authoring accessibility on the Macintosh

Accessibility for the Flash authoring environment on the Macintosh has the following limitations:
- The Panel Focus keyboard shortcut (Command+Option+Tab) is not supported for the Property inspector.
- The Panel Control Focus keyboard shortcut (Tab) is supported only for the Timeline, not for other panels or the Property inspector.

NOTE

Certain keyboard controls are available only in Windows. For more information, see "About Flash authoring accessibility on the Macintosh" on page 95.
Selecting panels or the Property inspector with keyboard shortcuts

You can select a panel or the Property inspector (also referred to as applying focus to the panel or Property inspector) by using the keyboard shortcut Control+Alt+Tab (Windows) or Command+Option+Tab (Macintosh).

You can apply focus to a panel or the Property inspector only when the panel or Property inspector is visible in the Flash application window. The panel can be expanded or collapsed.

When you use the keyboard shortcut to select panels, focus is applied to panels using the following criteria:

- Docked panels are given focus first.
- If the Timeline is displayed and docked, the Timeline is given focus the first time you press Control+Alt+Tab (Windows) or Command+Option+Tab (Macintosh).
- If the Timeline is not displayed and docked, or if you press the keyboard shortcut again, focus moves to the rightmost and highest docked panel. Pressing the keyboard shortcut repeatedly then moves the focus through the other docked panels, from right to left and from top to bottom of the workspace.
- If you move the focus through all the docked panels, or if there are no docked panels displayed, focus then moves to the rightmost and highest floating panel. Pressing the keyboard shortcut repeatedly then moves the focus through the other floating panels, from right to left and from top to bottom of the workspace.

To use keyboard shortcuts to select or deselect, expand, or collapse panels or the Property inspector:

- To move the focus through the panels currently displayed in the workspace, press Control+Alt+Tab (Windows) or Command+Option+Tab (Macintosh). A dotted line appears around the title of the currently focused panel.
- To move the focus to the previously selected panel, press Control+Shift+Alt+Tab (Windows) or Command+Shift+Option+Tab (Macintosh).
- To deselect a panel, press Escape, or move, dock, or undock the panel.
- To move the focus to the panel above or below the current panel in a panel group, press the Up Arrow or Down Arrow key.
To use keyboard shortcuts to expand or collapse panels or the Property inspector:

1. Press Ctrl+Alt+Tab (Windows) or Command+Option+Tab (Macintosh) until the panel you wish to expand or collapse has focus. A dotted line appears around the title of the currently focused panel.

2. Press the Spacebar to expand or collapse the currently selected panel.

To hide all panels and the Property inspector:

- Press F4. Press F4 again to display all panels and the Property inspector.

Selecting controls in a panel or the Property inspector using keyboard shortcuts

When a panel or the Property inspector has the current focus, you can use the Tab key to move the focus through the panel controls. You can use the Spacebar to activate the control that has the current focus (that is, pressing Spacebar is equivalent to clicking a control in the panel).

When you use the keyboard shortcut for panel controls, focus is applied to a control and the control is activated using the following criteria:

- The panel with the current focus must be expanded in order for you to select a control in the panel with the Tab key. If the panel is collapsed, pressing Tab has no effect.
- When the panel with the current focus is expanded, pressing Tab the first time moves the focus to the panel's pop-up menu.
- You can use the Right Arrow and Left Arrow keys to move the focus between the pop-up menu and the panel title bar.
- If the focus is on the pop-up menu, pressing Tab again moves the focus through the other controls in the panel. Pressing Tab again will not return the focus to the panel pop-up menu.
- When the pop-up menu has the focus, you can press Enter (Windows only) to display the pop-up menu items.
- In panels that are grouped, you can use the Up Arrow and Down Arrow keys to move the focus between the pop-up menus of the panels in the group.
- You can move the focus to a panel control only if the control is active. If a control is dimmed (inactive), you cannot apply focus to the control.
To move the focus from a panel title bar to a panel pop-up menu, do one of the following:

- Press Tab.
- Press the Right Arrow key. Press the Left Arrow key or Shift+Tab to return the focus to the panel title bar.
- If the panel is in a group, press the Up Arrow key to move the focus to the options pop-up menu of the panel immediately above the panel with the current focus. Press the Down Arrow key to move the focus to the pop-up menu of the panel immediately below the panel with the current focus.

To move the focus through the items in a panel pop-up menu:

1. With the focus currently applied to the panel pop-up menu, press the Spacebar to display the pop-up menu items.
2. Press the Down Arrow key to move through the items in the pop-up menu.
3. Press Enter (Windows) or Return (Macintosh) to activate the currently selected pop-up menu item.

To move the focus through the controls in a panel:

1. Press Tab when the focus is currently applied to the panel pop-up menu. Press Tab repeatedly to move the focus through the controls in the panel.
2. Press Enter (Windows only) to activate the currently selected panel control.

Navigating dialog box controls using keyboard shortcuts

In Windows operating systems, you can use keyboard shortcuts to navigate controls in dialog boxes. You can move from one control to another, apply controls, or cancel and exit the dialog box.

To navigate dialog box controls using keyboard shortcuts, do one of the following:

- Press Tab to move through the controls in the dialog box.
- To move through the controls within one section of a dialog box, press the Up Arrow and Down Arrow keys. For example, in the Spellings Setup dialog box, press the Up Arrow and Down Arrow keys to move through the controls within the Document Options section.
When the focus is applied to a dialog box control button—such as the OK, Cancel, or Apply button—press Enter to activate the button (equivalent to clicking the button).

When the focus is not applied to any dialog box control button—such as the OK, Cancel, or Apply button—press Enter to apply the current settings and close the dialog box (equivalent to clicking OK).

Press Escape to close the dialog box without applying the changes (equivalent to clicking Cancel).

When the focus is applied to the Help button, press Enter or Spacebar to view the Help content for the dialog box (equivalent to clicking Help).

Selecting the Stage or objects on the Stage using keyboard shortcuts

You can select the Stage or an object on the Stage using keyboard shortcuts. Selecting the Stage with a keyboard shortcut is equivalent to clicking on the Stage. Any other element currently selected becomes deselected when the Stage is selected.

Once the Stage is selected, you can use the Tab key to navigate through all objects on all layers, one at a time. You can select instances (including graphic symbols, buttons, movie clips, bitmaps, videos, or sounds), groups, or text boxes. You cannot select shapes (such as rectangles) unless those shapes are instances of symbols. You cannot select more than one object at a time using keyboard shortcuts. Objects are selected on the Stage using the following criteria:

- If an object is currently selected, pressing Shift+Tab selects the previous object.
- Pressing Tab the first time selects the first object that was created on the active frame in the active layer. When the last object on the top layer is selected, pressing Tab moves to the next layer beneath it and selects the first object there, and so on.
- When the last object on the last layer is selected, pressing Tab moves to the next frame and selects the first object on the top layer there.
Objects on layers that are hidden or locked cannot be selected with the Tab key.

**NOTE**
If you are currently typing text into a text box, you cannot select an object using the keyboard focus. You must first change the focus to the Stage and then select an object.

**To select the Stage:**
- Press Control+Alt+Home (Windows) or Command+Option+Home (Macintosh).

**To select an object on the Stage:**
- With the Stage selected, press Tab.

**Navigating tree controls using keyboard shortcuts**
You can navigate tree structures, the hierarchical displays of file structures in certain Flash panels, using keyboard shortcuts. You can expand and collapse folders in the tree control and move up and down between parent and child folders.

**To navigate tree controls with keyboard shortcuts, do any of the following:**
- To expand a collapsed folder, select the folder and press the Right Arrow key.
- To collapse an expanded folder, select the folder and press the Left Arrow key.
- To move to the parent folder of an expanded folder, press the Left Arrow key.
- To move to the child folder of an expanded folder, press the Right Arrow key.

**Working with library items using keyboard shortcuts**
You can cut, copy, and paste library items using keyboard shortcuts. You can cut or copy an item from the Library panel and paste it onto the Stage or into another library, or paste a folder into another library. If you paste a folder, each item in the folder is included.

You can use keyboard shortcuts to select a library item. For more information, see “Navigating tree controls using keyboard shortcuts” on page 100.
Items are cut, copied, and pasted using the following criteria:

- You can cut or copy one item or multiple items.
- You cannot paste a shape from the Stage into the library.
- You cannot paste a library item into a common library, because common libraries cannot be modified. However, you can create a new common library. For more information, see “Working with common libraries” in *Using Flash*.
- When you paste a library item onto the Stage, the item is centered.
- To paste a library item into a folder in the destination library, you can click the folder before pasting.
- You can paste a library item into a different location in the same library where it originated.
- If you attempt to paste a library item into a location containing another item by the same name, you can select whether to replace the existing item.

**To cut, copy, and paste library items using keyboard shortcuts:**

- To copy or paste a selected library item, press Control+X (Windows) or Command+X (Macintosh) to cut the item, or press Control+C (Windows) or Command+C (Macintosh) to copy the item.
- To paste a cut or copied item, click the Stage or in another library to set the insertion point, and press Control+V (Windows) or Command+V (Macintosh) to paste in the center of the Stage, or press Control+Shift+C (Windows) or Command+Shift+C (Macintosh) to paste in place (in the same location as the original).
Fireworks basics

To get the most out of your Fireworks experience, you should understand the basic elements of the Fireworks workspace. This section gives you an overview of Fireworks files and introduces you to the most important and commonly used workspace elements.

About Fireworks files

You can work with a variety of file types in Fireworks. For example, you can start with a PNG file and save it as a JPEG file or GIF file. You can create HTML files that contain JavaScript code. You can also export or save an image as a file type specific to another application, such as Photoshop or Macromedia Flash, if you want to continue working in the other application.

The following are the most common file types in Fireworks:

**PNG**, or Portable Network Graphic, is the native file format for Fireworks. PNG is a versatile web graphic format that can support up to 32-bit color, contain transparency or an alpha channel, and be progressive.

**GIF**, or Graphics Interchange Format, is a popular web graphic format for cartoons, logos, graphics with transparent areas, and animations. GIFs contain a maximum of 256 colors.

**JPEG** was developed by the Joint Photographic Experts Group specifically for photographic or high-color images. The JPEG format is best for digital or scanned photographs, images using textures, images with gradient color transitions, and any images that require more than 256 colors.

For information on other file types in Fireworks, see “Choosing a file type” in Using Fireworks.
Getting to know the Fireworks workspace

When you open a document in Fireworks for the first time, Fireworks activates the work environment, including the Tools panel, Property inspector, menus, and other panels.

The Tools panel, on the left of the screen, contains labeled categories, including bitmap, vector, and web tool groups. The Property inspector appears along the bottom of the document and initially displays document properties; the properties change when you choose a new tool or an object in the document. The panels are initially docked in groups along the right side of the screen.
Using the Tools panel

The Tools panel is organized into six categories: Select, Bitmap, Vector, Web, Colors, and View.

About bitmap and vector graphics

Computers display graphics in either vector or bitmap format. Understanding the difference between the two formats helps you understand Fireworks, which contains both vector and bitmap tools and is capable of opening or importing both formats.

**Bitmap graphics** are composed of dots, called pixels, arranged in a grid. When you edit a bitmap graphic, you modify pixels rather than lines and curves. Bitmap graphics are resolution-dependent, which means that the data describing the image is fixed to a grid of a particular size. Enlarging a bitmap graphic redistributes the pixels in the grid, often making the edges of the image appear ragged.
Vector graphics render images using lines and curves, called vectors, that include color and position information. When you edit a vector graphic, you modify the properties of the lines and curves that describe its shape. Vector graphics are resolution-independent, which means you can move, resize, reshape, or change the color of a vector graphic, as well as display it on output devices of varying resolutions, without changing the quality of its appearance.

You can experiment with the bitmap and vector tools on a blank canvas in Fireworks to see the difference between the two formats.

Changing tool options
When you select a tool, the Property inspector displays tool options. Some options remain displayed as you work with the tool. For other tools, such as the basic shape, Pen, and Line tools, the Property inspector displays the properties of selected objects. For more information about the Property inspector, see “Using the Property inspector” in Fireworks Help.

To display tool options in the Property inspector for a tool that you’re already using:
■ Choose Select > Deselect to deselect all objects.

For information about specific tool options, see the sections that introduce the various tools in Using Fireworks.

Selecting a tool from a tool group
A small triangle in the lower right corner of a tool in the Tools panel indicates that it is part of a tool group. For example, the Rectangle tool is part of the basic shape tool group, which also includes the Rounded Rectangle, Ellipse, and Polygon basic tools, as well as all of the Smart Shape tools, which appear below the divider line.
To select an alternative tool from a tool group:

1. Click the tool icon and hold down the mouse button.
   A pop-up menu appears with tool icons, tool names, and shortcut keys.
   The currently selected tool has a check mark to the left of the tool name.

2. Drag the pointer to highlight the tool you want, and release the mouse button.
   The tool appears in the Tools panel, and the tool options appear in the Property inspector.

Using the Property inspector

The Property inspector lets you edit the properties of the current selection, tool, or document. By default, the Property inspector is docked at the bottom of the workspace.

The Property inspector can be open at half height, displaying two rows of properties, or at full height, displaying four rows. You can also fully collapse the Property inspector while leaving it in the workspace.

NOTE Most procedures in Using Fireworks assume that the Property inspector is displayed at full height.

To undock the Property inspector:

- Drag the gripper at the upper-left corner to another part of the workspace.

To dock the Property inspector at the bottom of the workspace (Windows only):

- Drag the side bar on the Property inspector to the bottom of the screen.
To expand a half-height Property inspector to full height, revealing additional options:

- Click the expander arrow in the lower right corner of the Property inspector.
- Click the icon in the upper-right of the Property inspector and select Full Height from the Property inspector Options menu.

**NOTE**
In Windows, the Options menu is available only when the Property inspector is docked.

To reduce the Property inspector to half height:

- Click the expander arrow in the lower-right corner of the Property inspector.
- Select Half Height from the Property inspector Options menu.

**NOTE**
In Windows, the Options menu is available only when the Property inspector is docked.

To collapse the Property inspector when it is docked:

- Click the expander arrow or the title of the Property inspector.
- Select Collapse Panel Group from the docked Property inspector's Options menu.

For more information about specific Property inspector options, see the appropriate sections in *Using Fireworks*.

Using panels

Panels help you edit aspects of a selected object or elements of the document. Panels let you work on frames, layers, symbols, and more. Each panel is draggable, so you can group panels together in custom arrangements.

Some panels are not displayed by default, but you can display them if you want. Some panels are not grouped with other panels by default, but you can group them if you want. When you group panels together, all panel group names appear in the panel group title bar. You can, however, assign any name you like to panel groups.

**The Optimize panel** lets you manage the settings that control a file's size and file type and work with the color palette of the file or slice to be exported.
The **Layers panel** organizes a document’s structure and contain options for creating, deleting, and manipulating layers.

The **Frames panel** includes options for creating animations.

The **History panel** lists commands you recently used so that you can quickly undo and redo them. In addition, you can select multiple actions, and then save and reuse them as commands. For more information, see “Using the History panel to undo and repeat multiple actions” in *Using Fireworks*.

The **Shapes panel** contains Auto Shapes that are not displayed in the Tools panel.

The **Styles panel** lets you store and reuse combinations of object characteristics or choose a stock style.

The **Library panel** contains graphic symbols, button symbols, and animation symbols. You can easily drag instances of these symbols from the Library panel to your document. You can make global changes to all instances by modifying only the symbol.

The **URL panel** lets you create libraries containing frequently used URLs.

The **Color Mixer panel** (Window > Color Mixer) lets you create new colors to add to the current document’s color palette or to apply to selected objects.

The **Swatches panel** (Window > Swatches) manages the current document’s color palette.

The **Info panel** (Window > Info) provides information about the dimensions of selected objects and the exact coordinates of the pointer as you move it across the canvas.

The **Behaviors panel** (Window > Behaviors) manages behaviors, which determine what hotspots and slices do in response to mouse movement.

The **Find panel** (Window > Find) lets you search for and replace elements such as text, URLs, fonts, and colors in a document or multiple documents.

The **Align panel** (Window > Align) contains controls for aligning and distributing objects on the canvas.
The Auto Shape Properties panel (Window > Auto Shape Properties) lets you set the properties of Auto Shapes.

The Image Editing panel (Window > Image Editing) assembles the most commonly used tools for photo editing in one place.

The Special Characters panel (Window > Special Character) lets you insert special characters into your text directly from within Fireworks, rather than having to copy and paste the characters from another source.

Organizing panels and panel groups
By default, some Fireworks panels are docked on the right side of the workspace. Some panels are organized in panel groups. Other panels are not displayed initially but can be opened from the Window menu. You can undock panel groups, add panels to a group, undock individual panels, rearrange the order of docked panel groups, and collapse and close panel groups. You can also open and close individual panels.

To open a closed panel:
■ Select the panel from the Window menu.

To close a panel, do one of the following:
■ Select the panel name from the Window menu.
■ Click the Close button in the panel title bar when the panel is undocked.

To undock or move a panel group:
■ Drag the panel gripper on the upper left corner away from the panel docking area on the right side of the screen.

To dock a panel group:
■ Drag the panel gripper onto the panel docking area.

As you drag a panel or panel group over the panel docking area, a placement preview line or rectangle shows where it would be placed among the groups.
To collapse or expand a panel group or panel, do one of the following:

- Click the title of the panel group or panel.
- Click the expander arrow in the upper left corner of the panel group or panel.

**NOTE**
The title bar is still visible when the panel group or panel is collapsed.

To undock a panel from a panel group:

- Select Group With > New Panel Group from the Options menu in the panel group's title bar. (The Group With command's name changes depending on the name of the active panel.) The panel appears in a new panel group of its own.

To dock a panel in a panel group:

- Select the name of a panel group from the Group With submenu of the panel group's Options menu. (The Group With command's name changes depending on the name of the active panel.)

To rename a panel group:

1. Click the icon in the upper right of the panel group and select Rename Panel Group from the Options menu.
2. Enter the new name.

To return panels to their default positions for your screen resolution, do one of the following:

- Select Window > Workspace Layouts > 1024 x 768.
- Select Window > Workspace Layouts > 1280 x 1024.

To hide all panels and the Property inspector:

- Select Window > Hide Panels. To view hidden panels, select Window > Hide Panels again.

**NOTE**
Panels that are hidden when you select Hide Panels remain hidden when you deselect this command.
About the Quick Export button

The Quick Export button lets you export your Fireworks files to a number of Macromedia applications, including Dreamweaver, Flash, Director, and Macromedia FreeHand MX. In addition, you can export your files to Photoshop, FrontPage, Adobe GoLive, and Illustrator, or you can preview your files in the browser of your choice.

Navigating and viewing a document

You can control your document’s magnification, its number of views, and its display mode. In addition, you can easily pan the view of a document, which is helpful if you zoom in and can no longer see the entire canvas.
When your document is maximized in Windows, you can easily choose among multiple open documents by using the document tabs that appear at the top of the document window. Each open document displays its filename on a tab.

Contribute basics

To get the most out of your Contribute experience, you should understand the basic elements of the Contribute workspace. This section introduces you to the most important and commonly used workspace elements.

Getting to know the Contribute workspace

The Contribute workspace has three main areas. The largest area is the Contribute browser/editor. You can switch between browsing and editing as you work in Contribute.
Identifying parts of the Contribute workspace

The three main areas of the Contribute workspace are the Contribute browser/editor, the toolbar, and the sidebar.

The Contribute browser/editor

You use the main window in Contribute for browsing and editing. If you are not sure whether you are browsing or editing in Contribute, look at the toolbar. The toolbars are different when you are browsing and when you are editing a draft (see “The Contribute toolbars” on page 114).

When you use the Contribute browser, you can browse to any web page—not just to pages on your website. The Contribute browser functions as a true web browser: you can click links in web pages to browse to the page you want to edit. You can also create bookmarks to pages that you visit frequently.

When you use the Contribute editor, you can edit pages in websites you have connected to. You can edit text, images, tables, links, and even pages with frames. You can then publish your changes to make the updated web page appear on your website.

You can browse and edit in Contribute, and switch between browsing and editing. For more information, see “Switching between browsing and editing” on page 117.
The Contribute toolbars

The Contribute toolbar changes according to whether you are browsing or editing a page. When you are editing, the editor toolbar enables you to edit text or images, depending on the content you’ve selected.

Depending on the role the Contribute administrator assigned you, some buttons in the toolbars might not be enabled for you.

The browser toolbar contains buttons for navigating your website or creating a new page.

The editor toolbar contains buttons for common operations from the File, Insert, Format, and Table menus.

The text formatting toolbar contains buttons for formatting text.

NOTE

If your Contribute administrator has restricted editing to text only, some formatting options are not available. Also, options might be disabled if a cascading style sheet was applied to a text selection.
The image editing toolbar contains buttons for editing images.

The Contribute sidebar
You can use the Contribute sidebar to switch between editing and browsing, and obtain quick access to your drafts. You can also use the sidebar to get instructions for performing tasks in Contribute.

The sidebar has two parts:

- **The Pages panel** gives you access to the web browser and all drafts you’re currently editing. The Draft Console, which shows the status of your drafts, also has a link on the Pages panel.

  **NOTE**
  The Draft Console is not available if your website doesn’t have an administrator assigned to it.

- **The How Do I panel** provides quick step-by-step instructions to help you complete some common Contribute tasks. The panel shows a list of browsing tasks while you are browsing, and a list of editing tasks while you are editing.
You can click any link in the How Do I panel in the sidebar to get more information on that task. If the task you’re looking for is not in the list, see Using Contribute (Help > Macromedia Contribute Help) for detailed information.

You can expand, collapse, or resize the panels and the sidebar.

**To expand or collapse the sidebar, do one of the following:**
- Select View > Sidebar.
- In Windows, click the arrow on the splitter bar between the sidebar and the Contribute browser/editor.
- On the Macintosh, double-click the grabber on the splitter bar between the sidebar and the Contribute browser/editor.

**To resize the sidebar:**
- Drag the splitter bar between the sidebar and the Contribute browser/editor.

**To expand or collapse a panel in the sidebar:**
- Double-click the panel title bar.

**To resize panels vertically in the sidebar:**
- Drag the title bar in the How Do I panel.
Switching between browsing and editing

You can use Contribute to browse or edit web pages. You can switch between browsing and editing at any time. When you leave a draft that you're editing, Contribute saves your changes so that you can return to the draft later and continue editing where you left off.

When you switch to browsing, Contribute does not publish your draft. While you are browsing the page, the message area advises you that you have an unpublished draft of the page.

If you are not sure if you are browsing or editing in Contribute, look at the toolbar. When you are browsing, you'll see the browser toolbar, with the Edit Page (or Create Connection) button, and when you are editing, the editor toolbar appears (see “The Contribute toolbars” on page 114).

To switch from browsing to editing, do one of the following:
- Click the Edit Page button in the toolbar.
- Click a draft title in the Pages panel in the sidebar.

**NOTE**
Edit Page is enabled only for pages in a website that you are connected to and that you have permission to edit.

To switch from editing to browsing, do one of the following:
- Click Browser in the Pages panel in the sidebar.
- Click the Save for Later button in the toolbar.
- Select View > Browser.
FlashPaper basics

To get the most out of your FlashPaper experience, you should understand the basic elements of the FlashPaper workspace. This section gives you an overview of FlashPaper files and introduces you to the most important and commonly used workspace elements.

This section contains the following topics:

- “About FlashPaper files” on page 118
- “Getting to know the FlashPaper workspace” on page 118

About FlashPaper files

FlashPaper lets you create Flash documents (SWF files or PDF files) from any type of printable document, such as Microsoft Project, Microsoft Visio, and even QuarkXPress and AutoCAD. Flash documents are typically much smaller than other document types.

The SWF files that FlashPaper generates are in the same format as those generated by Macromedia Flash.

When you embed Flash documents in a web page, you can view them across platforms in any browser that supports Flash. You can view SWF files directly in Macromedia Flash Player, and you can view PDF files directly in Adobe Acrobat Reader.

Getting to know the FlashPaper workspace

When you create a FlashPaper document, you use the FlashPaper application and work in the application environment. When you view a FlashPaper document, you use Flash Player or a web browser and work in the viewing environment.
The FlashPaper workspace consists of the FlashPaper toolbar, which is the same in both the application and the viewing environments. The FlashPaper toolbar enables you to resize a document for viewing, navigate through the document pages, select text, search the document, and print the document.

**NOTE**
The File menu and Help menu are visible in the application environment only.

To print a document:
- Click the Printer icon.

To select text in the document:
1. Click the Select button.
2. Drag to select text in the document window.
   - You can Shift-click to select multiple words or lines of text.
3. Click the Pan button to return to viewing the document.

To search the document:
1. Type words that you want to search for in the search text field, and then click the Search button.
   - FlashPaper selects the first instance of the matching words.
2. To find the next instance of the matching words, click the Search button again.

**NOTE**
The search feature requires that you have Flash Player 7 installed on your computer. If you have Flash Player 6 or earlier, you cannot use the search feature.
To resize the document, do one of the following:

- Use the Zoom slider to dynamically resize the document.
  
  You can adjust the document magnification range from 25% to 250%.
  
  The Zoom text box updates as you use the slider.
- Enter a number in the Zoom text box to resize the document to a specific magnification.
- Click the Fit in Viewer button to see the entire page in the viewer.
- Click the Fit Width button to resize the document so that the width of the page fills the viewer.

To navigate or page through the document, do one of the following:

- Enter a number in the Page Navigation text box to view a specific page.
- Click the Previous arrow or the Next arrow to page backward or forward through a document.
- Drag the page scroll box, located to the right of the document, to scroll through multiple-page documents.

To open a document in a new browser window:

- Click the Open in New Browser button.

**NOTE**

The Open in New Browser button only appears in the FlashPaper viewing environment (saved SWF files).
CHAPTER 3
Web Development Workflow

This chapter demonstrates how the individual components of Macromedia Studio 8—Macromedia Dreamweaver 8, Macromedia Flash 8, Macromedia Fireworks 8, Macromedia Contribute 3, and Macromedia FlashPaper 2—make up a comprehensive suite for designing, developing, and maintaining interactive online experiences, as part of a typical web development workflow.

This chapter contains the following sections:

About the web development workflow ......................... 121
Planning your website ............................................. 122
Setting up the development environment ................... 123
Planning page design and layout .............................. 125
Creating content assets ........................................ 128
Assembling, testing, and deploying .......................... 130
Maintaining and updating your site .......................... 133

About the web development workflow

A typical web development workflow involves the following stages:

- Planning the site, which includes defining the site’s strategy or goals, targeting an audience, and determining your site’s data requirements
- Setting up the development environment, which includes selecting your web and application servers, defining a site with Dreamweaver, and defining data sources
- Planning page design and layout, which includes mocking up your pages and interfaces with a drawing tool such as Fireworks, and laying out the pages in HTML with Dreamweaver
Creating content assets, which includes creating images, video, and so on with Fireworks and Flash

• Building application assets, which includes creating dynamic pages and Rich Internet Applications with Dreamweaver and Flash

• Assembling, testing, and deploying your site, which includes formatting text, compiling your assets, ensuring that you have met accessibility requirements, testing your code, and publishing your site to a server with Dreamweaver

• Maintaining and updating your site, which includes keeping your content fresh and current with Dreamweaver and Contribute

Studio 8 gives you all the tools you need to work through this process from start to finish. The combination of Dreamweaver, Flash, Fireworks, Contribute, and FlashPaper enables you to easily design, develop, and maintain websites and applications in both coding and design environments.

This chapter introduces a sample web development workflow; it does not provide the only workflow possible. The workflow that you and your team members adopt will depend on your resources, your personal working habits, and the needs of your website.

For more information about the web development workflow for dynamic pages, see “The Workflow for Dynamic Page Design” in Using Dreamweaver.

Planning your website

To plan and organize your site effectively, you must do much more than determine what the site will look like and where the files will go. You need to examine the site goals and audience profiles. Additionally, you should consider your site’s navigation scheme. Careful planning before you begin site development will save you a great deal of time later.
Determine your site goals  Ask yourself or your client questions about the site, and write down your goals so that you remember them as you go through the design process. A list of goals helps you focus and target your website to your particular needs. The complexity of your goals affects the navigation, the media that you use, and even the appearance of your site. For example, the look and navigation of a website devoted to archeology news should be very different from that of a website devoted to selling appliances.

Decide who your audience is  This step may seem unnecessary, because most people want everyone to visit their website. Still, it is difficult to create a website that every person in the world can use. People around the world use various browsers, connect at various speeds, may or may not have media plug-ins, and use various types of devices to view Internet content. Because all these factors affect who uses your site, determining your target audience is a crucial step during the initial planning phase.

Conceptualize the site’s navigation scheme  The site navigation scheme is a map that shows how your web pages relate to one another. Specifically, it shows how users travel through your site as they click links and interact with application interfaces. After sketching your site navigation, you can present the preliminary plan to your client or to members of your group.

Setting up the development environment

Whether you are developing your project single-handedly or collaborating with a team of people, you need to set up a development environment before you begin using Studio to build your website.

At the most basic level, a development environment consists of a web server and a Dreamweaver site. You might also need an application server.
Choose a web server and install it on your local or networked computer
A web server is software that serves files in response to requests from web browsers. When the web server receives a request for a static HTML page, the server reads the request, finds the page, and sends it to the requesting browser. Common web servers include Microsoft Internet Information Server (IIS), Netscape Enterprise Server, Sun ONE Web Server, and Apache HTTP Server. ColdFusion also comes with its own web server, which is recommended for development purposes only.
After your web server is working correctly, create a root folder for your application on the computer that’s running the web server. Make sure that the folder is published by the web server—in other words, that the web server can serve any file in this folder or in any of its subfolders in response to an HTTP request from a web browser.
For example, on a computer running Personal Web Server (PWS) or IIS, any file in the Inetpub/wwwroot folder or in any of its subfolders can be served to a web browser. If you are using the ColdFusion web server for development, any file in the CFusionMX/wwwroot folder or in any of its subfolders can be served to a web browser.

To run web applications, you must also install an application server to work with your web server. An application server is software that helps the web server process dynamic pages before the web server sends those pages to requesting browsers. For more information, see “Setting up an application server” in Using Dreamweaver.

Define your site in Dreamweaver
In Dreamweaver, the term site can refer either to a website or to a local storage location for the documents belonging to a website. The latter is what you need to establish before you begin building your website.
A Dreamweaver site organizes all the documents associated with your website and allows you to track and maintain links, manage files, share files, and copy your site files to a web server. The preferred approach to creating a website by using Dreamweaver is to create and edit pages on your local disk and then upload copies of the site’s files to a remote web server to make them publicly available.
When you set up your site, if you’re working in a collaborative environment, consider using the Check In/Check Out feature so you can check files into and out of local and remote servers.
Related tutorial

- Chapter 4, “Tutorial: Setting Up Your Site and Project Files,” on page 137

Planning page design and layout

A web design project usually begins with storyboards or flowcharts that the designers and developers then turn into sample pages. You can use Studio 8 to create sample pages as you work toward a final design. After you have a visual guideline of how you’d like your pages to look, you can begin planning page layouts in Dreamweaver.

Create page mock-ups to determine your site’s appearance

Planning your page design and layout before you actually begin building your web pages saves you a great deal of time during the development process. It is important to maintain consistency in your page design and layout. Give your site pages a similar look, color scheme, navigation, and so forth. This consistent approach helps to orient your users, thereby providing a better user experience.

You can use Fireworks or Flash to create a mock-up for the main pages of your website. Page mock-ups typically show design layout, technical components, themes and color, graphic images, and other media elements.
For example, consider the following sketch:

A mock-up in Fireworks might look like this:
When you finish creating a mock-up in Fireworks, you can export it as a Flash SWF file. Any computer running Flash Player can then display your work.

Related tutorial
■ Chapter 5, “Tutorial: Creating Page Mock-ups,” on page 143

Creating page layouts in Dreamweaver

Page layout is one of the most important aspects of web design. A page layout determines how a page will look in the browser, showing, for example, the placement of menus, images, and Flash content. Dreamweaver gives you several ways to create and control your web page layout.

One common method of creating a page layout is to position elements using HTML tables. A table consists of one or more rows, with each row containing one or more cells. Tables are powerful tools for presenting tabular data and for laying out text and graphics on a web page.

A page layout created in Dreamweaver using tables might look like this:

Another way of laying out pages in Dreamweaver is to position elements by using Cascading Style Sheets (CSS). CSS positioning is quickly becoming a popular way to lay out pages because it allows for greater control and flexibility than tables do. Users who are familiar with CSS can use <div> tags to create CSS layout blocks, and then use CSS styles to position those blocks on the page.

Related tutorial
■ Chapter 6, “Tutorial: Creating a Table-based Page Layout,” on page 163
Creating content assets

After you know what your design and layout will look like, you can create and gather the assets that you will need for your website. Assets can be items such as images (including buttons, banner graphics, logos, photographs, and so on), text, Flash content, or other media.

Working with graphics and photos

You can use Fireworks to create graphics and process photos for your website. In Fireworks, everything is editable, all the time.

Fireworks has bitmap-editing tools as well as vector-editing tools. Fireworks enables you to enhance graphics by applying bevels, embossing, drop shadows, glows, and other effects to vector objects, bitmaps, and text. Fireworks also generates JavaScript, which makes rollovers, buttons, and pop-up menus easy to create, and its optimization features shrink the file size of web graphics without sacrificing quality. Fireworks makes it easy for you to work with images by including batch process and photo retouching tools, including red eye removal.

For example, you might create the following banner graphic in Fireworks:

Fireworks integrates with other Studio products to help you optimize your workflow. After you include images in your site, you can start, edit, and work in Fireworks without ever leaving the Dreamweaver or Flash workspace.

Related tutorials

- Chapter 7, “Tutorial: Handling Photographs,” on page 183
- Chapter 8, “Tutorial: Creating a Page Banner,” on page 195
Creating Flash content and video

Your Flash content can include graphics, text, animation, and applications for websites. Flash content consists primarily of vector graphics, but it can also include video, bitmap graphics, and sounds. Because Flash content uses compact vector graphics, it downloads rapidly and scales to the viewer’s screen size.

Using Flash, you can animate objects to make them appear to move across the Stage, and to change their shape, size, color, opacity, rotation, and other properties. You can create frame-by-frame animation, in which you designate a separate image for each frame, or tweened animation, in which you set the first and last frames of an animation and direct Flash to create the frames in between.

You can use Flash to include video on a web page in a format that almost anyone can view. In Flash you can seamlessly integrate video into your website, and you can create a custom skin with unique controls for your video. You can set the size and aspect ratio of your video, and the video can dynamically change based on a data source.

For example, this is how a video player created in Flash might look in a web page:
Flash treats Flash Video as simply another media type, so you can layer, script, and control video just as you would any other object in a SWF file.

Related tutorials
- Chapter 9, “Tutorial: Building Your First Flash Application,” on page 215
- Chapter 10, “Tutorial: Building a Video Player (Flash Professional only),” on page 255

Assembling, testing, and deploying

The last phase of the web development process consists of assembling your pages, testing them, and deploying your site to a server so that the world can see it.

Assembling your web page in Dreamweaver

Using Dreamweaver, you can easily add many types of content to web pages. You can add text, assets, and design elements, such as images, colors, movies, sound, and other forms of media.

You can simply drag saved assets to the page, or you can do any of the following to create your web page in Dreamweaver:

- Type directly in a Dreamweaver document, or import text from other documents, and then format the text with CSS styles.
- Insert images, including rollover images, image maps, and Fireworks sliced images.
- Insert other types of media in a web page, such as Flash content, Shockwave content, QuickTime movies, sound, applets, and video.
- Write your own HTML, JavaScript, CFML, PHP, Visual Basic, C#, and CSS code.
- Create standard HTML links, including anchor links and e-mail links, or easily set up graphical navigation systems, such as jump menus and navigation bars.
- Apply reusable content throughout your site by using Dreamweaver templates and library items.
After assembling your page, you can edit the assets directly in the Dreamweaver workspace. You can perform a number of simple image-editing tasks—including cropping, adjusting contrast, optimizing, and sharpening—without the assistance of an image-editing application. For more complex editing, you can start Fireworks to edit images inserted into a Dreamweaver document.

You can also edit Flash files by selecting the Flash content placeholder in the Dreamweaver document and clicking the Flash Edit button in the Property inspector. Dreamweaver opens the Flash file (FLA) and saves any changes you make in it to the SWF file.

Related tutorials
- Chapter 9, “Tutorial: Creating a CSS-based Page Layout,” on page 153
- Chapter 11, “Tutorial: Adding Content to Pages,” on page 269

Testing your site in Dreamweaver

Before you upload your site to a server and declare it ready for viewing, it’s a good idea to test it locally. In fact, it’s a good idea to test and troubleshoot your site frequently throughout its construction so that you can catch problems early and avoid repeating them.

It’s important to make sure that your pages look and work as expected in the browsers that you’re targeting, that all links are working, and that the pages don’t take too long to download. You can also test and troubleshoot your entire site by running a site report before you publish your site.

The following guidelines can help you create the best possible experiences for visitors to your site:

- Preview your pages in as many different browsers and on as many different platforms as possible.
- Make sure that your pages function as expected in the browsers that you’re targeting and that they “fail gracefully” in other browsers. This means that your pages should be legible and functional in browsers that do not support styles, layers, plug-ins, or JavaScript.
- Check your site for broken links (links that don’t work), and then fix them. Other sites undergo redesign and reorganization, too, and the page that you’re linking to may have been moved or deleted.
Monitor the size of your pages and the time that they take to
download. Keep in mind that for pages that consist of one large table,
visitors will see nothing until the entire table is downloaded. Consider
breaking up large tables; if this is not possible, consider putting a small
amount of content, such as a welcome message or an advertising
banner, outside the table at the top of the page so that users can view
this material while the table downloads.

- Check your entire site for problems, such as untitled documents,
empty tags, and redundant nested tags, by running site reports
in Dreamweaver.
- Check your code for tag or syntax errors using Dreamweaver Validator.
- Check your Flash content for errors while it’s running in Flash Player.
You can use the Flash debugger in test mode with local files, or you can
use the debugger to test files on a web server in a remote location.

Related topics
- Chapter 4, “Testing your site,” in Using Dreamweaver
- Chapter 21, “Optimizing and Debugging Your Code,” in
  Using Dreamweaver

Deploying your site files to a server with
Dreamweaver

Once you’ve created a functional website, you can use Dreamweaver to
publish it by uploading the files to a remote web server.

Before you can proceed, you must have access to a remote web server (such
as your ISP’s server, a server owned by the client you’re working for, or an
intranet server within your company). If you don’t already have access to
such a server, contact your ISP or client.

Related tutorial
- Chapter 13, “Tutorial: Publishing Your Site,” on page 325
Maintaining and updating your site

When the bulk of the site has been published, you need to continue to update and maintain it. Publishing your site—that is, deploying the site to a server and making it live—is an ongoing process.

Dreamweaver has many tools to help you manage your site, transfer files to and from a remote server, set up a check-in/check-out process to prevent files from being overwritten, and synchronize the files on your local and remote sites.

You can also use Contribute to maintain your website. Using Contribute, you can allow others to update content on the website so that content stays current. Contribute has controls that enable you to limit the edits users can make on the website to ensure the integrity of the website. Contribute is integrated with Dreamweaver so that each application respects the file check-in/check-out process of the other application. You can also launch and administer Contribute from within Dreamweaver.

Related tutorial

- Chapter 14, “Tutorial: Setting Up Your Website for Contribute Users,” on page 333
In this part, you'll begin building the Cafe Townsend sample website.

Before you begin, you must copy the sample files and set up your project.

Then you'll use Macromedia Fireworks 8 and Macromedia Dreamweaver 8 to create a web page design for the Cafe Townsend home page.

This part contains the following sections:

- Tutorial: Setting Up Your Site and Project Files .................. 137
- Tutorial: Creating Page Mock-ups ................................. .143
- Tutorial: Creating a Table-based Page Layout .................. 163
CHAPTER 4

Tutorial: Setting Up Your Site and Project Files

This tutorial introduces you to the concept of a Macromedia Dreamweaver 8 site and shows you how to set up the project files for the Cafe Townsend sample website. In Dreamweaver, a site generally consists of two parts: a collection of files on a local computer (the local site), and a location on a remote web server that you upload the files to when you’re ready to make them publicly available (the remote site). You use the Dreamweaver Files panel to manage the files for your site.

The most common approach to creating a website with Dreamweaver is to create and edit pages on your local disk, and then upload copies of those pages to a remote web server for viewing on the web. In this tutorial you’ll only learn how to set up the local site so that you can begin building web pages right away. Later, after you’ve completed the website, you’ll learn how to create a remote site so that you can upload your files to a web server.

In this tutorial, you will complete the following tasks:

- Learn about Dreamweaver sites
- Set up your project files
- Define a local folder

Learn about Dreamweaver sites

In Dreamweaver, the term “site” can refer either to a website or to a local storage location for the documents that belong to a website. The latter is what you need to establish before you begin building your website. A Dreamweaver site organizes all of the documents associated with your website and lets you track and maintain links, manage files, share files, and transfer your site files to a web server.

NOTE

Macromedia HomeSite and ColdFusion Studio users can think of a Dreamweaver site as being like a HomeSite or Studio project.
A Dreamweaver site consists of as many as three parts, depending on your computing environment and the type of website you are developing:

**Local folder** is your working directory. Dreamweaver refers to this folder as your *local site*. The local folder is usually a folder on your hard disk.

**Remote folder** is where you store your files, depending on your environment, for testing, production, collaboration, and publication. Dreamweaver refers to this folder as your *remote site*. The remote folder is a folder on the computer that’s running your web server. The computer running the web server is often (but not always) the computer that makes your site publicly available on the web.

**Folder for dynamic pages (Testing Server folder)** is the folder where Dreamweaver processes dynamic pages. This folder is often the same folder as the remote folder. You do not need to worry about this folder unless you are developing a web application. For more information about the Testing Server folder, see “Specifying where dynamic pages can be processed” in *Using Dreamweaver*.

You can set up a Dreamweaver site by using the Site Definition Wizard, which guides you through the setup process, or by using the Site Definition Advanced settings, which let you set up local, remote, and testing folders individually, as necessary. In this tutorial you’ll use the Site Definition Advanced settings to set up a local folder for your project files. Later in this book, you’ll learn how to set up a remote folder so that you can publish your pages to a web server and make them publicly available.

For more information about how to use the Site Definition Wizard to set up a Dreamweaver site, see “Setting up a new Dreamweaver site” in *Using Dreamweaver*.

For more information about how to set up a remote site, see Chapter 13, “Tutorial: Publishing Your Site”.

For more information about Dreamweaver sites in general, see “Setting Up a Dreamweaver Site” in *Using Dreamweaver*. 
Set up your project files

When you create a local site, you can place any existing assets (images or other pieces of content) in the local site's root folder (the main folder for the site). Then when you're ready to add content to your pages, the assets are there and ready for you to use.

The sample files included with Dreamweaver contain assets for the sample website you'll build using these Getting Started with Dreamweaver tutorials. The first step in creating the site is to copy the sample files from the Dreamweaver application folder to an appropriate folder on your hard disk.

1. Create a new folder called local_sites on your hard disk.

   For example, create a folder called local_sites in either of the following two locations:
   ■ In Windows: C:\Documents and Settings\your_user_name\My Documents\local_sites
   ■ On the Macintosh: Macintosh HD/Users/your_user_name/Documents/local_sites

   **NOTE**

   On the Macintosh, there's a folder called Sites already in your user folder. Don't use that Sites folder as your local folder; the Sites folder is where you place your pages to make them publicly accessible when you're using the Macintosh as a web server.

2. Locate the cafe_townsend folder on Studio 8 disc 2 or download it from www.macromedia.com/go/st_documentation.

   **ABOUT...**

   **About local and remote “root” folders** The local “root” folder of your Dreamweaver site is often the main or top-level folder for your website. It usually corresponds to an identical folder on the remote site (web server). The root folder also usually defines the first part of your website’s URL, following the domain name. For example, if your local root folder is called mywebsite, and you have an identical root folder defined on the remote site, the URL for your website would be something like http://www.yahoo.com/mywebsite.

   In some cases, the local root folder may not have an exact name equivalent on the remote site. For example, if you own the domain name www.mywebsite.com, with a remote root directory of public_html, your local root folder could still be called mywebsite. The files in both the local and remote root directories would be identical; only the folder names (public_html on the remote site, and mywebsite on the local computer) would be different.
3. Copy the cafe_townsend folder into the local_sites folder.
   The cafe_townsend folder is the folder that you will use as the root folder (main folder) for your Dreamweaver site.

Define a local folder

You must define a Dreamweaver local folder for each new website you create. The local folder is the folder that you use to store working copies of site files on your hard disk. If you don't define a local folder, certain features in Dreamweaver cannot work properly.

Defining a local folder also allows you to manage your files and to transfer files to and from your web server by using a number of file-transfer methods.

Now you'll define the cafe_townsend folder that you copied into the local_sites folder as your local folder.

1. Start Dreamweaver and select Site > Manage Sites.
   The Manage Sites dialog box appears.

2. Click the New button and select Site.
   The Site Definition dialog box appears.

3. If the wizard (Basic tab) appears, click the Advanced tab and select Local Info from the Category list (it should be the default).

4. In the Site Name text box, enter Cafe Townsend as the name of the site.

5. In the Local Root Folder text box, specify the cafe_townsend folder that you copied to the local_sites folder in the previous section.
   You can click the folder icon to browse to and select the folder, or enter a path in the Local Root Folder text box.
6. In the Default Images Folder text box, specify the images folder that already exists in the cafe_townsend folder.

You can click the folder icon to browse to and select the folder, or enter a path in the Default Images Folder text box.

The Site Definition dialog box should now look as follows:

![Site Definition for Cafe Townsend](image)

7. Click OK.

The Manage Sites dialog box appears, showing your new site.

8. Click Done to close the Manage Sites dialog box.
The Files panel now shows the new local root folder for your current site. The file list in the Files panel acts as a file manager, allowing you to copy, paste, delete, move, and open files just as you would on a computer desktop.

For more information about how the Files panel works, see “The Files panel” on page 55.

You've now defined a local root folder for your site. The local root folder is the place on your local computer where you keep the working copies of your web pages. Later, if you want to publish your pages and make them publicly available, you'll need to define a remote folder—a place on a remote computer, running a web server, that will hold published copies of your local files.

You can follow the rest of the tutorials in this guide to create the Cafe Townsend sample site, or you can work on your own web pages. When you're finished creating and editing pages, proceed to define a remote folder on a server and publish your pages. For more information, see Chapter 13, “Tutorial: Publishing Your Site”.
CHAPTER 5

Tutorial: Creating Page Mock-ups

This tutorial will guide you through the basic tasks of creating a mock-up of a web page with Macromedia Fireworks 8. Page mock-ups are typically used to show proposed page designs to colleagues or clients. Once a design is approved, the mock-up is used by web designers as a blueprint to create the page.

In this tutorial, you’ll complete the following tasks:

- Review your task .......................................................... 143
- Create and save a new document .................................. 145
- Import and place images ............................................. 146
- Create a composite of the content area ....................... 148
- Place text and images .................................................. 153
- Export the image for the web ...................................... 160

Review your task

Café Townsend, a fictional restaurant, hired your team to design and build their website. During the early planning stages of the project, members of your team met with Café Townsend representatives to brainstorm ideas for the website. During the meeting, your team sketched several possible designs on napkins (the meeting was held in a Café Townsend restaurant).
When the team returned to the office, they told you the clients particularly liked two designs, which were captured in the following napkin sketches:
You’re given the task of creating a page mock-up of the second design to show to the clients. The mock-up will look like a real web page but it won’t work like one.

Create and save a new document

After previewing the completed page mock-up, you’re ready to begin your project.

If you haven’t already set up a working folder, you must do so before you begin. For instructions, see “Setting Up Your Site and Project Files.”

1. In Fireworks, select File > New.
2. In the New Document dialog box, enter 700 for the width and 600 for the height. Ensure that both measurements are in pixels.
3. Set the Canvas color to Custom and select black from the custom color menu.

The New Document dialog box should look as follows:

4. Click OK to create the document.

A Document window appears with a title bar that reads Untitled-1.png (Windows) or Untitled-1 (Macintosh).

If the Document window isn't maximized, that is, if it doesn't fill the center of the screen, maximize it by clicking the Maximize button (Windows) or the zoom box (Macintosh) at the top of the Document window. This step will give you plenty of room to work.
5. Select File > Save, and then browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/

6. Name the file homepage-mockup.

   NOTE
   On the Macintosh, select the Add Filename Extension option if it’s not already selected.

7. Click Save.
   The title bar displays the new filename with a .png extension. PNG is the native file format for Fireworks. The PNG file is your source file. It’s where you’ll do all of your work in Fireworks. At the end of this tutorial, you’ll learn how to export your document to another format for the web.

### Import and place images

Next you import images and position them on the Fireworks canvas to see how they’ll fit on the final web page.

#### Import the banner graphic

The banner graphic you have is a mock-up of the banner you’ll use on the actual page. You’ll produce the final version of the banner in “Tutorial: Creating a Page Banner” on page 195”.

1. Select File > Import and browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/

2. Select banner-mockup.jpg and click Open.
   An insertion pointer appears indicating where the upper-left corner of the graphic will be positioned.

3. Align the pointer with the upper-left corner of the canvas and click to insert the banner graphic.
   The banner graphic appears surrounded by a blue frame indicating that it’s the currently selected object.
4. Use the arrow keys on your keyboard to precisely align the banner graphic with the top of the canvas.
   The banner is correctly aligned if the values of its X and Y coordinates in the Property inspector are both 0. The Property inspector is located at the bottom of the Document window. If it’s not visible, select Window > Properties.
5. Click anywhere outside the selected banner graphic to deselect it.
6. Save your work.

Import the slideshow placeholder image

Next, you import a placeholder image representing the size and position of a Flash-based photo slideshow that will be on the final web page. Placeholder images are valuable for representing how a composition element will look without having to accommodate the large file size or having to build the complex element in its final form.

1. Select File > Import and browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/
2. Double-click slideshow-placeholder.jpg.
3. Position the insertion pointer about 6 pixels below the banner graphic you imported earlier, and then click to insert the slideshow placeholder.
4. With the placeholder image still selected, use the arrow keys on your keyboard to adjust its position on the canvas.
   The placeholder image is correctly aligned if the values of its X and Y coordinates in the Property inspector are 0 and 98 respectively.
5. Click anywhere outside the selected image to deselect it.
6. Save your work.
Create a composite of the content area

Now you’re ready to create a mock-up of the content area of the web page. You’ll draw Fireworks vector objects to graphically represent areas of the web page.

Before you begin, you review the napkin sketch to refresh your memory of the design.

Create and edit a rounded rectangle

The first object to create is a rounded rectangle that represents the top and bottom bars of the content area. You decide to create a large rounded rectangle that defines the total extent of the content area.
1. Select the Rounded Rectangle tool in the Vector section of the Tools panel.

The Rounded Rectangle tool is a shape tool. Click the expander icon on the shape icon to select it.

2. In the Document window, position the cross-hair pointer over the canvas, and drag downward and to the right to create the shape.

You can draw the rounded rectangle anywhere on the canvas. Don't worry about size and position at this point; you'll resize and position it later in this procedure.

3. When you release the mouse button, a rounded rectangle appears, selected, in the area you defined.

You can see when an object is selected because it displays blue corner points. Most objects also have a blue highlight around their outer edges, but rectangles are an exception. A rounded rectangle shape also has control points that appear as yellow diamonds. These control points let you change the size and corner roundness of the rounded rectangle.
4. With the rounded rectangle still selected, in the Property inspector, click the Fill Color box next to the bucket icon.
   The Fill Color pop-up window opens.

5. Type 6B1101 in the text box at the top of the window, and then press Enter.

6. Click the Stroke Color box next to the pencil icon, and then click the Transparent button at the top of the Stroke Color pop-up window. (It should be selected by default.)
   The rounded rectangle now has a dark red fill and no stroke.

Next, you need to resize and position the rounded rectangle. You decide to do this precisely with the Property inspector.

1. With the rounded rectangle still selected, in the Property inspector, type 700 in the width box (W), type 340 in the height box (H), type 0 for the X position, type 255 for the Y position, and then press Enter to apply the last value.

After resizing the rounded rectangle, you notice that the rounded edges are distorted. You want to adjust these to create appropriately rounded corners.

The rounded rectangle is a Fireworks Auto Shape, so you can use the Auto Shape Properties panel to adjust the roundness of the corners.
1. With the rounded rectangle still selected, open the Auto Shape Properties panel by selecting Window > Auto Shape Properties (not Window > Auto Shapes).

2. Enter 20 for the roundness of the first corner, and then press Enter. Because the values are locked, changing one roundness value changes all the other values.

   ![Auto Shape Properties Panel](image)

   At the same time, Fireworks adjusts the corners of the shape on the canvas.

3. Close the Auto Shapes Properties panel, and then click anywhere outside the canvas to deselect the rounded rectangle.

4. Save your work.

Create a navigation sidebar area

Next, you decide to create a rectangle to define the navigation sidebar for the web page.

1. Select the Rectangle tool in the Vector section of the Tools panel.

2. Position the cross-hair pointer in the rounded rectangle you drew earlier and drag downward and to the right to create a vertical rectangle for the sidebar.

   You can draw the rectangle anywhere on the canvas. You'll resize and position it later.

   When you release the mouse button, a rectangle appears, selected, in the area you defined.
Next, you need to give the rectangle an orange fill.

1. With the rectangle still selected, in the Property inspector, click the Fill Color box next to the bucket icon.
   
   The Fill Color pop-up window appears.

2. Type A3210A in the text box at the top of the window, and then press Enter.

3. Click the Stroke Color box next to the pencil icon, and then click the Transparent button at the top of the Stroke Color pop-up window.
   
   The rectangle now has an orange fill and no stroke.

Next, you need to resize and position the rounded rectangle. You decide to do this precisely with the Property inspector.

1. With the rectangle still selected, in the Property inspector, type 140 in the width box (W), type 295 in the height box (H), type 0 for the X position, type 278 for the Y position, and then press Enter to apply the last value.

2. Save your work.

Create the copy area

Finally, you need to create an off-white rectangle to represent the area where the web page's text will appear.

1. Select the Rectangle tool in the Vector section of the Tools panel.

2. Position the cross-hair pointer in the rounded rectangle you created earlier and drag downward and to the right to create a horizontal rectangle for the copy area.
   
   You can draw the rectangle anywhere on the canvas. You'll resize and position it later.

   When you release the mouse button, a rectangle appears, selected, in the area you defined.

   The Y position is only an approximation. You can use the arrow keys to nudge the rounded rectangle up or down until it is centered vertically with the rounded rectangle you drew earlier. The difference in height between the two objects is 45 pixels, so the top of the orange rectangle should be 22 or 23 pixels below the top of the dark red rounded rectangle.
Now you need to give the rectangle an off-white fill.
1. With the rectangle still selected, in the Property inspector, click the Fill Color box next to the bucket icon.
   The Fill Color pop-up window appears.
2. Type F7EEDF in the text box at the top of the window, and then press Enter.
3. Click the Stroke Color box next to the pencil icon, and then click the Transparent button at the top of the Stroke Color pop-up window.
   The rectangle now has an off-white fill and no stroke.

Next, you need to resize and position the rounded rectangle. You decide to do this precisely with the Property inspector.

   ■ With the rectangle still selected, in the Property inspector, type 560 in the width box (W), type 295 in the height box (H), type 140 for the X position, and type 278 for the Y position, and then press Enter to apply the last value.

**NOTE**
The Y position should be identical to the Y position of the sidebar rectangle.

**Place text and images**

After creating the mock-up of the content area, you decide to create some text boxes to represent the content and navigation links, and import images to represent other features of the content area.
Place placeholder text for the links

The first element to create is the text representing the navigation links.

1. Select the Text tool in the Vector section of the Tools panel, and move the pointer over the Document window.

The pointer changes to an I-beam, and the Property inspector displays text properties.

2. In the Property inspector, set the following tool properties:
   - From the Font pop-up menu, select TrebuchetMS.
   - Click the Bold button.
   - Enter 14 as the font size.
   - Select Smooth Anti-Alias as the anti-aliasing level.
   - Click the Color icon next to the font size menu and select the white swatch.
   - Click the Left Alignment button.
   - Enter 200 as the leading percentage next to the vertical, two-headed arrow icon.

3. With the I-beam pointer, click once near the upper-left corner of the sidebar rectangle.

This step creates an empty text block.

4. Type Cuisine in the text block, and then press Enter to start a new line.

The width of the text block expands as you type.

NOTE: If you don’t have TrebuchetMS, select Verdana or a similar font instead.
5. Type the following items, pressing Enter after each to start a new line:
   ■ Chef Ipsum
   ■ Articles
   ■ Special Events
   ■ Location
   ■ Menu
   ■ Contact Us

When you complete this step, you have a text block representing the navigation links.

6. Click the Pointer tool in the Tools panel to deselect the text box.

7. Save your work.

Place a placeholder image for the video

Next, you add a placeholder image in the main content area to represent a video that will run on the final web page. See “Review your task” on page 143.

1. Select File > Import and browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/

2. Select video-placeholder.jpg and click Open.
3. Position the insertion pointer about 6 pixels below and to the right of the upper-left corner of the off-white copy area, and then click to insert the image.

4. With the placeholder image still selected, use the arrow keys on your keyboard to adjust its position.

5. Click anywhere outside the selected image to deselect it.

6. Save your work.

**Place a placeholder image for the featured item**

Next, you add a placeholder image in the main content area to represent a featured menu item to be displayed on the final web page. See “Review your task” on page 143.

1. Select File > Import and browse to the following folder on your hard disk:
   
   `local_sites/cafe_townsend/fireworks_assets/

2. Select feature-placeholder.jpg and click Open.

3. Position the insertion pointer about 6 pixels below the video-placeholder image, and then click to insert the image.
4. With the placeholder image still selected, use the arrow keys on your keyboard to adjust its position.
   You want to position the image so that its left edge aligns with the left edge of the video placeholder image.

5. Click anywhere outside the selected image to deselect it.

6. Save your work.

Add placeholder text for the page copy

Finally, you will draw an empty text box and import some placeholder text into it to represent the page copy.

1. In the Vector section of the Tools panel, select the Text tool.

2. In the Property inspector, set the following tool properties:
   - From the Font pop-up menu, select Verdana.
   - Enter 11 as the font size.
   - Make sure the Bold button is not selected.
   - Click the Color box, type 240E0A in the text box at the top of the Color window, and then press Enter.
   - Enter 200 as the leading percentage next to the vertical, two-headed arrow icon.
3. Position the I-beam pointer about 6 pixels from the upper-right corner of the video-placeholder image, and then drag down and to the right to draw a text box.

Ensure that there is about a 6-pixel margin on all sides.

4. Type or paste about two paragraphs of placeholder text in the text box. Because the text represents where text would be for the web page, it doesn’t need to say anything. You can paste the text in the loremipsum.txt file located in the following folder:

   local_sites/cafe_townsend/fireworks_assets/

Now that you’ve created the basic text blocks, you decide to modify some of the text so that the paragraphs begin with highlighted text and have text at the end of each paragraph that simulate links.

1. Select the Text tool in the Vector section of the Tools panel, and then select the first three words of the first paragraph.

2. In the Property inspector, do the following:
   ■ Click the Bold button.
   ■ Click the Color box, type 6B1101 in the text box at the top of the Color window, and then press Enter.

3. Repeat these steps for the first three words in the second paragraph.
Now you add a line of text at the end of each paragraph and make it look like a web link.

1. Click the I-beam pointer at the end of the first paragraph and press the spacebar on your keyboard.
2. Type Learn more, and then select the text you just typed.
3. In the Property inspector, do the following:
   - Click the Underline button.
   - Click the Color box, type \textcolor{#32596E}{32596E} in the text box at the top of the Color window, and then press Enter.
4. Click the I-beam pointer at the end of the second paragraph and press the spacebar on your keyboard.
5. Type Make a reservation, and then select the text you just typed.
6. In the Property inspector, do the following:
   - Click the Underline button.
   - Click the Color box, type \textcolor{#32596E}{32596E} in the text box at the top of the Color window, and then press Enter.
7. Click the Pointer tool in the Tools panel to deselect the text.
8. Save your work.
Export the image for the web

The mock-up of the Cafe Townsend homepage you created should look as follows:

Next, you decide to export the PNG file to a JPEG file that you can display on an internal website or e-mail to your colleagues or clients.

![Image Preview](image.png)

2. In the Format pop-up menu, select JPEG.

3. In the Quality text box, type 90, or use the Quality slider.

   Because this image will not be used on a public web page, you don't need to be concerned about file size and download time. Otherwise, a quality setting of 90 might be too high.

   In the area above the preview image, you can see how your settings affect the file size and download time.

4. Click Export.

   The Export dialog box appears.

5. Browse to the following folder:

   `local_sites/cafe_townsend/fireworks_assets/`

6. Click Export.

   Fireworks creates a JPEG version of your page mock-up in the `fireworks_assets` folder. Your PNG file still exists and you should use it to edit the mockup in response to feedback. After you complete each revision, export it again.

In this tutorial, you completed a page mock-up. You learned to create and save Fireworks files, import and place images, draw vector shapes, place text and images, and export images.

For detailed information about any of the features covered in this tutorial, and for information on additional Fireworks features, see *Using Fireworks.*
CHAPTER 6
Tutorial: Creating a Table-based Page Layout

This tutorial explains how to create a table-based page layout in Macromedia Dreamweaver 8. A page layout determines how your page will appear in the browser, showing, for example, the placement of menus, images, and Macromedia Flash content.

Tables are a powerful tool for presenting tabular data and for laying out text and graphics on an HTML page. You can use tables to create your layout quickly and easily. In this tutorial you’ll create a number of tables in a new Dreamweaver document. The rows and cells of the tables effectively act as container boxes for the content you’ll add later.

In this tutorial, you will complete the following tasks:
- Examine the design comp ........................................ 163
- Create and save a new page .............................. 165
- Insert tables ......................................................... 166
- Set table properties ........................................ 170
- Insert an image placeholder .............................. 175
- Add color to the page ....................................... 177

Examine the design comp

Typically, you don’t begin building a website by opening Dreamweaver and laying out pages right away. The first steps to creating a website begin on a piece of paper, or in a graphics-editing application like Macromedia Fireworks. Graphic designers usually sketch out a piece of comprehensive artwork (also known as a “comp”) for the website in order to show it to the client and make sure that the initial ideas for the site meet with their client’s approval.
A comp consists of any number of page elements that the client has requested for their website. For example, the client might say, “I want to have a logo at the top of the page, a navigation that links to these other pages, a section for an online store, and a place where I can insert video clips.” Based on that discussion, the designer begins planning the layout of the site, and makes sketches of sample pages that fulfill the client’s requirements.

This tutorial provides you with the completed and approved comp for Cafe Townsend, a fictional restaurant that has requested a website. As the web designer, it’s your job to transform the comp into a working web page (most likely with the help of other graphics designers and Flash developers).
You’ll notice that the graphic designer has provided you with a web page comp that includes a number of content areas, as well as some graphic ideas. In the next sections, you’ll use Dreamweaver to lay out this design.

You can also open the original comp file that you created in Chapter 5, “Tutorial: Creating Page Mock-ups” if you want to see it on the computer screen. If you haven’t created the comp, you can go back and complete the tutorial, or you can look at a finished version of the tutorial in the cafe_townsend/completed_files/fireworks folder.

Create and save a new page

After you set up a site and examine any comps, you are ready to begin building web pages. You’ll start by creating a new page, and saving it in the cafe_townsend local root folder of your website. The page eventually becomes the home page for Cafe Townsend, a fictional restaurant.

If you haven’t created the cafe_townsend local root folder, you must do so before you proceed. For instructions, see Chapter 4, “Tutorial: Setting Up Your Site and Project Files.”

1. In Dreamweaver, select File > New.
2. On the General tab of the New Document dialog box, select Basic Page from the Category list, select HTML from the Basic Page list, and click Create.
3. Select File > Save As.
4. In the Save As dialog box, browse to and open the cafe_townsend folder that you defined as the site’s local root folder.
   In Chapter 4, “Tutorial: Setting Up Your Site and Project Files”, you created this folder within a folder called local_sites.
5. Enter index.html in the File Name text box and click Save.
   The filename now appears in the title bar at the top of the application window.
6. In the Document Title text box at the top of your new document, type *Cafe Townsend.*

![Image](index.html)

This is the title of your page (different from the filename). Your site visitors will see this title in the browser window title bar when they view the page in a web browser.

7. Select File > Save to save your page.

## Insert tables

Next you’ll add a table that will hold text, graphics, and Macromedia Flash assets.

1. Click once on the page to place the insertion point in the upper-left corner of the page.

![Image](index.html)

2. Select Insert > Table.

3. In the Insert Table dialog box, do the following:

   - Enter 3 in the Rows text box.
   - Enter 1 in the Columns text box.
   - Enter 700 in the Table Width text box.
   - Select Pixels from the Table Width pop-up menu.
   - Enter 0 in the Border Thickness text box.
   - Enter 0 in the Cell Padding text box.
Enter 0 in the Cell Spacing text box.

4. Click OK.

A table with three rows and one column appears in your document. The table is 700 pixels wide with no border, cell padding, or cell spacing.
5. Click once to the right of the table to deselect it.

6. Select Insert > Table to insert another table.

7. In the Insert Table dialog box, do the following for the second table:
   - Enter 1 in the Rows text box.
   - Enter 3 in the Columns text box.
   - Enter 700 in the Table Width text box.
   - Select Pixels from the Table Width pop-up menu.
   - Enter 0 in the Border Thickness text box.
   - Enter 0 in the Cell Padding text box.
   - Enter 0 in the Cell Spacing text box.
8. Click OK.
   A second table with one row and three columns appears below your first table.

9. Click to the right of the table to deselect it.
10. Insert a third table by selecting Insert > Table and entering the following values in the Insert Table dialog box:
    - Enter 1 in the Rows text box.
    - Enter 1 in the Columns text box.
    - Enter 700 in the Table Width text box.
    - Select Pixels from the Table Width pop-up menu.
    - Enter 0 in the Border Thickness text box.
    - Enter 0 in the Cell Padding text box.
    - Enter 0 in the Cell Spacing text box.
11. Click OK.
    A third table, with one row and one column, appears below your second table.

Click to the right of the table to deselect it. Your page should now look as follows:
170 Tutorial: Creating a Table-based Page Layout

You may see the Table selector (indicated by green lines) after you insert a table. You can always make the Table selector disappear by clicking outside the table. You can also disable the Table selector by selecting View > Visual Aids > Table Widths.

Set table properties

Now you’ll set precise table properties, using Expanded Tables mode, a feature that temporarily adds cell padding and spacing to tables and increases the borders of the tables to simplify editing. Specifically, it lets you position the insertion point precisely without accidentally selecting the wrong table or other table content.

1. Select View > Table Mode > Expanded Table Mode.

   ![Expanded Table Mode](image)

   **NOTE**
   You may see the Getting Started with Expanded Tables Mode dialog box, click OK.

   **NOTE**
   After you finish setting table properties in Expanded Tables mode, always return to Standard mode. Expanded Tables mode is not a WYSIWYG (what you see is what you get) environment, so some operations, such as resizing, do not display the expected results.

   **NOTE**
   You can always make the Table selector disappear by clicking outside the table. You can also disable the Table selector by selecting View > Visual Aids > Table Widths.
2. Click once inside the first row of the first table.

3. In the Property inspector (Window > Properties), enter **90** in the Cell Height (H) text box and press Enter (Windows) or Return (Macintosh).

   **NOTE** If you cannot see the Cell Height text box, click the expander arrow in the lower-right corner of the Property inspector.

4. Click once inside the second row of the first table.

5. In the Property inspector, enter **166** in the Cell Height text box and press Enter (Windows) or Return (Macintosh).

6. Click once inside the third row of the first table.
7. In the Property inspector, enter 24 in the Cell Height text box and press Enter (Windows) or Return (Macintosh).

You should now have three rows of differing heights in the first table.

Next you’ll set properties for the second table (the table that contains three columns).

8. Click once inside the first column of the second table.
9. In the Property inspector, enter 140 in the Cell Width (W) text box and press Enter (Windows) or Return (Macintosh).

10. Click once inside the second column of the second table.

11. In the Property inspector, enter 230 in the Cell Width text box and press Enter (Windows) or Return (Macintosh).

12. Set the width of the third column to 330 pixels.

   If you have the Table selector enabled (View > Visual Aids > Table Widths), you’ll see all three of the pixel values you just entered above the respective table columns.

   You won’t enter any height values for the cells in this table because the height of those cells will vary depending on the content you add later.

13. Finally, click once inside the last table (the table with one row and one column).
14. In the Property inspector, enter 24 in the Cell Height text box and press Enter (Windows) or Return (Macintosh). Your layout should now look as follows:

![Table Layout Example]

15. Click the Exit Expanded Tables Mode link at the top of the Document window to return to Standard mode.

16. Save your page.
Insert an image placeholder

An image placeholder is a graphic that you use until final artwork is ready to be added to a web page. An image placeholder is useful when you lay out web pages because it allows you to position an image on a page before you actually create the image.

1. In the Document window, click once inside the first row of the first table.
2. Select Insert > Image Objects > Image Placeholder.
3. In the Image Placeholder dialog box, do the following:
   - Type bannergraphic in the Name text box.
   - Enter 700 in the Width text box.
   - Enter 90 in the Height text box.
   - Click the color box and select a color from the color picker. For this tutorial, select a reddish brown (#993300).
   - Leave the Alternate Text text box blank.

A note on alternative text  Alternative text is a textual description of an image on a web page. It is part of the HTML code and does not appear on the page. It's important to provide alternative text for most of your images so that people who use screen readers or text-only browsers can receive the information provided by the image. In the case of a banner graphic, which merely displays a logo for a website, it is not essential to provide alternative text. When you leave the Alternate Text text box blank in the Image Placeholder dialog box, Dreamweaver adds an alt="" attribute to the img tag. Later, if you want to add alternative text to an image, you can select the image and enter the alternative text in the Property inspector. For example, if you later change the logo to include a phone number or address, you would want to provide that information as alternative text.
About image placeholders  An image placeholder is a graphic you use until final artwork is ready to be added to a web page; it is not a graphic image that displays in a browser. Before you publish your site, replace any image placeholders you’ve added with web-friendly graphic files such as GIFs or JPEGs. If you have Macromedia Fireworks, you can create a new graphic from a Dreamweaver image placeholder. When you select the image placeholder and click the Create button in the Property inspector, Fireworks opens and presents you with a new canvas. The new image dimensions are set to the same size as the placeholder image. You can then create and edit the image as you like, and replace the placeholder image in Dreamweaver. For information about creating an image in Fireworks from an image placeholder, see “Using Fireworks to modify Dreamweaver image placeholders” in Using Dreamweaver.

4. Click OK.

The image placeholder appears inside the first table. The image placeholder displays a label and the size attributes of the image that you’ll eventually place there.

5. Save your page.
Add color to the page

Now you'll add more color to the page by setting colors for some of the table cells and for the background of the page.

1. Click once inside the first cell of the three-columned table.
2. Click the `<td>` tag (cell tag) in the tag selector to select the cell.

3. In the Property inspector (Window > Properties), click once inside the Background Color text box.
   The text box is located directly next to the Background Color (Bg) color box.

   **NOTE**
   If you cannot see the Background Color text box, click the expander arrow in the lower-right corner of the Property inspector.
4. In the Background Color text box, enter the hexadecimal value #993300 and press Enter (Windows) or Return (Macintosh).

5. Click once inside the second cell of the three-columned table.

6. Click the `<td>` tag (cell tag) in the tag selector to select the cell.

7. In the Property inspector, click once inside the Background Color text box, enter the hexadecimal value #F7EEDF, and press Enter (Windows) or Return (Macintosh).

   The color of the table cell turns to light tan.

8. Repeat steps 5 through 7 to change the color of the third table cell to light tan as well.

9. After you have all three cell colors set, click once outside the table to deselect it.
Next you'll change the background color for the entire page by modifying page properties. The Page Properties dialog box lets you set a number of page properties, including the size and color of page fonts, the colors of visited links, page margins, and much more.

1. Select Modify > Page Properties.

2. In the Appearance category of the Page Properties dialog box, click the Background Color color box and select black (#000000) from the color picker.
3. Click OK.
   Your page background turns to black.

4. Save your work.
   Your page layout is now complete. The layout contains a number of tables that can hold assets such as images, text, and Flash Video (FLV) files.
PART 3
Creating Content Assets

In this part, you’ll build assets for the Cafe Townsend sample website.
You’ll use Macromedia Fireworks 8 to process images and design a banner
graphic for the Cafe Townsend website. You’ll use Macromedia Flash 8 to
build a flexible messaging area and a video player for the Cafe Townsend
website.

This part contains the following sections:

Tutorial: Handling Photographs ................................. 183
Tutorial: Creating a Page Banner ............................... 195
Tutorial: Building Your First Flash Application ............. 215
Tutorial: Building a Video Player (Flash Professional only) .... 255
CHAPTER 7

Tutorial: Handling Photographs

This tutorial will guide you through the basic tasks of optimizing photographs with Macromedia Fireworks 8. You will learn how to batch process the files, and to compose and export a group of images.

In this tutorial, you'll complete the following tasks:

- Review your task .......................................................... 183
- Batch process large image files ..................................... 184
- Compose the images ...................................................... 186
- Preview and export the images ...................................... 191
- View the final optimized images .................................... 192

Review your task

According to the page mock-up you created previously, the Cafe Townsend website will include a Flash-based photo slideshow.

You are provided with six digital photographs of dishes from the restaurant menu. Your task is to prepare the images for the slideshow. They need to be of good quality yet small enough to download quickly. Also, the size of each image must be 700 pixels by 150 pixels to fit the dimensions of the slideshow.

NOTE

For a tutorial on creating the slideshow in Flash, see the Macromedia Flash 8 tutorials.
Batch process large image files

When the source of your image files is a digital camera, you probably won't be able to use the images directly as web graphics. The size and resolution are much too great. You may also want to alter the composition so that only parts of the photographs are used.

When all the image files require the same adjustments, you can eliminate the time-consuming process of opening and modifying each file by batch processing the image files.

For the Cafe Townsend project, you decide to batch process the six JPEG files downloaded from a digital camera. You want to perform the following actions to all the files:
  - Because the images have different dimensions, you want to resize them so they are all the same width.
  - Because the filenames are not very informative, you want to add a “dish_” prefix to the filenames to better describe the images.

The first step is to select the files you want to process.

If you haven't already set up a working folder, you must do so before you begin. For instructions, see “Setting Up Your Site and Project Files.”

1. In Fireworks, select File > Batch Process.
   The Batch dialog box appears.
2. Browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/camera_files
   The folder contains six JPEG images downloaded from a digital camera.
3. To quickly select all the files for the batch, click Add All, and then click Next.
   The Batch Process dialog box appears. This dialog box lets you specify the actions you want to perform on a batch of files. In this case, you want to scale and rename your files.
4. Under Batch Options, select Scale, and then click Add to include the action in the batch process.
5. In the Scale box at the bottom of the dialog box, select Scale to Size from the list, and then set the size dimensions as follows:
   - Type 750 in the width box.
   - For the height, select Variable from the list.

6. Under Batch Options, select Rename, and then click Add to include the action in the batch process.

7. In the Rename box at the bottom of the dialog box, select the Add Prefix option and enter dish_ in the text box.

8. Click Next to move to the next screen.

9. Make sure the Same Location As Original File option is selected, and then click Batch to start the batch process.

   Fireworks scales all the images and adds a dish_ prefix to each filename. When prompted, click OK to finish the process.

   When you look at the files in the camera_files folder, you notice that Fireworks has placed the original image files in a folder called Original Files. You also notice that the scaling operation has significantly reduced the size of the files.
Compose the images

The next step is to compose the images to appear in the slideshow. Each image must be 700 pixels by 150 pixels to fit the dimensions of the slideshow. However, because each image you batch processed is larger than the slideshow dimensions, you must choose, or compose, an interesting 700 x 150 image from each larger image.

One option is to open each image, crop it, and export it. However, you decide to take a more efficient approach: create a single image file that holds all six images while still letting you compose and export the images at any time.

You begin by creating the image source file. In the next section, you’ll add frames to the file, place an image in each frame, and compose the images. You’ll then be able to export all six images in one operation.

1. In Fireworks, select File > New.
2. In the New Document dialog box, enter 700 for the width and 150 for the height.
   Make sure that both measurements are in pixels.
3. Set the canvas color to White, and then click OK to create the image source file.
4. If the Document window isn’t maximized, that is, if it doesn’t fill the center of the screen, maximize it by clicking the Maximize button (Windows) or the zoom box (Macintosh) at the top of the Document window. This step will give you plenty of room to work.

5. Select File > Save.

6. Browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/

7. Name the file ImageSource.png and click Save.

As you complete the tutorial, remember to save your work often by selecting File > Save.

Create and name frames

Next, you create several frames in the ImageSource.png file to hold the image files that you processed earlier.

Frames are a Fireworks feature that are typically used to create animations and rollovers. In this case, you use frames to hold the individual photos before you export them to separate files all at once.

1. Make sure the ImageSource.png file is open in Fireworks.

2. Select Window > Frames to open the Frames panel.

3. Click the context menu on the upper right corner of the panel, and then select Add Frames.
4. In the Add Frames dialog box, enter 5 as the number of new frames, make sure the After the Current Frame option is selected, and click OK.

![Add Frames dialog box]

Fireworks adds five new frames to the existing one, giving you a total of six.

![Frames panel]

By default, Fireworks names the new frames Frame 2, Frame 3, and so on. You want to rename the frames to reflect the filenames for the images you'll export later in this tutorial.

5. In the Frames panel, double-click Frame 1.

6. Type Image0 in the textbox that appears, and then press Enter to accept the new name.

![Frame renaming dialog box]

The Flash developer in charge of creating the slideshow has asked you to start the numbering at 0 for coding reasons.

7. Continue renaming the frames Image 1, Image 2, and so on.

When you export the images later in this tutorial, Fireworks will automatically name the exported files with the frame names.

8. Save your work.
Place and compose an image in each frame

Now that you created six frames, you want to import the files you processed earlier into each of the frames. Once imported, you can easily compose each image by dragging it around the canvas. Using frames to store and manipulate the images also allows you to export them all at once with the file settings you want.

1. In the Frames panel, select the first frame.
2. Select File > Import and browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/camera_files
3. Select dish_1013.jpg and click Open.
4. Align the insertion pointer just outside the upper-left corner of the canvas as shown in the following illustration, and then click to insert the image.

The image appears, selected, on the canvas.

The image is larger than the canvas, as indicated by its blue outline. Instead of cropping the image, you’ll move it until the part of the image you want appears in the “window” created by the canvas. When you export the image later in the tutorial, it’ll be cropped so that its height and width match the canvas size (700 x 150 pixels).
5. To compose the image, drag it until the part you want appears in the window created by the canvas.

6. Click anywhere outside the selected image to deselect it.

7. Repeat steps 1 through 6 for the remaining five images, making sure to select a new, empty frame before importing each image.

8. Save your work.
Preview and export the images

Your image source file now contains six frames with six images. Holding the images in frames lets you export them all at once with the file settings you want, as follows.


2. In the Image Preview dialog box, do the following:
   - In the Format pop-up menu, select JPEG.
     The JPEG format is best for digital or scanned photographs, images using textures, images with gradient color transitions, and any images that require more than 256 colors.
   - In the Quality text box, type 75, or use the Quality slider.
   - Select the Sharpen Color Edges option.
   - Click Export.
3. In the Export dialog box that appears, browse to the following folder on your hard disk:
   local_sites/cafe_townsend/images/

4. Select Frames to Files in the Export pop-up menu.

5. Make sure that Trim Images is not selected.

6. Click Export.
   Fireworks exports each frame as a separate image file to the images folder using the name of the frame for the filename.

**View the final optimized images**

After exporting the images, you can see how they look by opening them in Fireworks.

You’ll notice the following:

- All images are cropped to display the composition you created when you positioned the images on the canvas.

- All images are uniformly 700 pixels wide and 150 pixels high, and have a resolution of 72 pixels per inch.
The following tables indicate how the final images differ from the original JPEG files that the digital camera created:

### Original digital camera files

<table>
<thead>
<tr>
<th>Filename</th>
<th>File dimensions</th>
<th>File size</th>
</tr>
</thead>
<tbody>
<tr>
<td>1013.jpg</td>
<td>1679 x 1170 pixels</td>
<td>402K</td>
</tr>
<tr>
<td>1088.jpg</td>
<td>2920 x 1876 pixels</td>
<td>1732K</td>
</tr>
<tr>
<td>1095.jpg</td>
<td>2063 x 1444 pixels</td>
<td>753K</td>
</tr>
<tr>
<td>1111.jpg</td>
<td>3040 x 1840 pixels</td>
<td>2831K</td>
</tr>
<tr>
<td>1320.jpg</td>
<td>3284 x 1855 pixels</td>
<td>1364K</td>
</tr>
<tr>
<td>1396.jpg</td>
<td>3346 x 2000 pixels</td>
<td>1435K</td>
</tr>
</tbody>
</table>

### Final images

<table>
<thead>
<tr>
<th>Filename</th>
<th>File dimensions</th>
<th>File size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image0</td>
<td>700 x 150 pixels</td>
<td>12K</td>
</tr>
<tr>
<td>Image1</td>
<td>700 x 150 pixels</td>
<td>16K</td>
</tr>
<tr>
<td>Image2</td>
<td>700 x 150 pixels</td>
<td>23K</td>
</tr>
<tr>
<td>Image3</td>
<td>700 x 150 pixels</td>
<td>19K</td>
</tr>
<tr>
<td>Image4</td>
<td>700 x 150 pixels</td>
<td>21K</td>
</tr>
<tr>
<td>Image5</td>
<td>700 x 150 pixels</td>
<td>14K</td>
</tr>
</tbody>
</table>

The final images have the uniform dimensions you need and have much smaller file sizes, which is critical for public websites.

In this tutorial, you learned to batch process large images files, create and name frames, place images on frames, and to preview and export files. For detailed information about any of the features covered in this tutorial, and for information on additional Fireworks features, see *Using Fireworks*. 
This tutorial will guide you through the task of designing a page banner with Macromedia Fireworks 8. You’ll learn to import image assets, work with layers, shapes, masks, and text, and optimize and export the finished banner graphic.

In this tutorial, you’ll complete the following tasks:

- Review your task ..................................................... 195
- Add a background and place the logo ......................... 196
- Organize your objects with layers ............................. 201
- Create a contrasting background for the logo ............. 203
- Create an outline around the banner ......................... 207
- Create a slanted edge effect .................................... 209
- Add a tag line to the banner .................................... 210
- Export an optimized image file ................................. 211

**Review your task**

During the planning stages of the Café Townsend project, several possible designs for a banner graphic were discussed. The following is a sketch of the design approved by the Café Townsend representatives:

You are provided with a set of assets. Your task is to create the final banner for the website based on the design sketch.
Add a background and place the logo

After you create a new PNG file for the banner, you want to import a photo to serve as the background image for the graphic. You also want to import the Cafe Townsend logo.

You start by creating a new PNG file for the banner.

If you haven't already set up a working folder, you must do so before you begin. For instructions, see “Setting Up Your Site and Project Files.”

1. In Fireworks, select File > New.

2. In the New Document dialog box, do the following:
   - Enter 700 for the width and 92 for the height. Ensure that both measurements are in pixels.
   - Set the canvas color to Custom and select black from the custom color menu.

3. Click OK to create the document.

   If the Document window isn't maximized, that is, if it doesn't fill the center of the screen, maximize it by clicking the Maximize button (Windows) or the zoom box (Macintosh) at the top of the Document window. This step will give you plenty of room to work.

4. Select File > Save and browse to the following folder on your hard disk:
   local_sites/cafe_townsend/images/

5. Name the file banner_graphic.png.

   On the Macintosh, select the Add Filename Extension option if it’s not already selected.

6. Click Save.
Import the background image

The background of the banner graphic consists of a photograph of the interior of a Cafe Townsend restaurant. You want to import the photograph in your document, and then adjust it to fit the dimensions of the banner.

1. With the banner_graphic.png file open in Fireworks, select File > Import and browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/
2. Select cafePhoto.jpg and click Open.
3. Align the insertion pointer with the upper-left corner of the canvas as shown in the following illustration, and then click to insert the image.

The image appears, selected, on the canvas. The image is larger than the canvas, as indicated by its blue outline. To make it fit the way you want, you scale and position the photo.

4. With the image still selected, select the Scale tool in the Tools panel (or press Q).
5. Zoom out to view the entire photo by using the magnification pop-up menu in the lower right corner of the Document window.

6. With the Scale tool, reduce the size of the photo by about 25 percent by clicking the selection point in the lower right corner of the photo and dragging the mouse towards the upper-left corner.

Moving a corner selection point with the Scale tool scales the photo proportionately.
7. Click the photo and drag it so that the canvas displays the part of the photo that you want to be visible in the banner. Move the photo to compose an interesting image for the banner graphic's background.

8. Once you’re satisfied with the image, save your work.

**Import the logo**

Next you import a vector-based graphic of the Cafe Townsend logo. Vector graphics are one of two types of graphics you can create, import, or modify in Fireworks.

The file you import was created as a vector graphic in Fireworks and saved in the Adobe Illustrator format (an AI file), a common format for graphic design work.

1. With the banner_graphic.png file open in Fireworks, zoom in to full size by selecting 100% from the magnification pop-up menu if you haven’t done so already.

2. Select File > Import and browse to the following folder on your hard disk:
   local_sites/cafe_townsend/fireworks_assets/
3. Select cafeLogo.ai and click Open.

The Vector File Options dialog box appears. This is where you can adjust how a vector file is imported.

4. Click OK to accept the default options.

5. Position the insertion pointer inside the upper-left corner of the banner and click to insert the graphic.

At this point the logo is not clearly visible because it’s black and transparent against the dark background image. You’ll highlight it later so that it better stands out.

6. Save your work.
Organize your objects with layers

Now that you imported two graphics into your document, you want to arrange them in layers so that you can more easily organize the banner's composition and manipulate its elements.

Specifically, you want to organize the elements on three layers—one layer for the background, a second layer for the logo, and a third layer for other graphics. To better identify the elements on each layer, you also want to give each layer a name that clearly indicates what’s on the layer.

1. Make sure the banner_graphic.png file is open in Fireworks.

2. If the Layers panel is not already open, select Window > Layers.

   So far the banner graphic contains a single layer called Layer 1.

3. At the bottom of the panel, click the New/Duplicate Layer button twice to create two more layers.

4. Rename the layers by double-clicking each one and entering the following names in the Layer Name textbox that appears:
   - For Layer 3, Graphics
   - For Layer 2, Logo
   - For Layer 1, Background

5. Change the layer stacking order by clicking the Graphics layer and dragging it below the Logo layer.

   A dark line indicates where the object will be dropped if you release the mouse button at that time. To place an element on a layer, release the mouse button when the dark line appears at the bottom of the layer.

   It's always a good idea to name your layers so that you can easily identify them later. When a document gets large and contains many layers and objects, it can be difficult to manage them if your layers and objects don’t have unique names.
202 Tutorial: Creating a Page Banner

6. Drag the logo image (called “Group: 3 objects”) from the Background layer to the Logo layer.

The Layers panel should look as follows:

![Layers panel](image)

7. Save your work.
Create a contrasting background for the logo

The Cafe Townsend logo is not clearly visible because it's black and transparent against a dark background. You decide to place a lighter colored rectangle behind the logo to make it stand out more.

1. In the Layers panel, select the Logo layer.
2. In the Tools panel, select the Rectangle tool.
3. In the Property inspector, set the following properties for the tool:
   
a. Click the Fill Category box and select Gradient > Linear.

b. Click the Fill Color box next to the bucket icon and then click the button just above the Preset label in the dialog box that appears.
A pop-up window appears to let you pick the first gradient color.

c. Type **F7EFE3** in the text box at the top of the window, and then press Enter.
   The beginning color of the gradient changes to reflect your color choice.

d. Click the second gradient color button (on the right side of the dialog box) and click the white swatch with the eyedropper pointer.
   The ending color of the gradient changes to reflect your color choice.

e. Click the Opacity button for the second gradient color, in the upper-right corner of the dialog box:

   The Opacity pop-up window appears.
f. Use the slider to set the opacity of the second gradient color to 50%.

4. Press Enter to accept the settings, and then draw a rectangle over the Cafe Townsend logo in the banner. When you release the mouse button, a semi-transparent rectangle appears over the logo.

5. Select the Pointer tool (or press V) and drag the blue corner points of the rectangle to position and resize the rectangle so that it is within and slightly smaller than the logo. The rectangle obscures the logo beneath it. You want to change the stacking order of the two objects so that the rectangle is beneath the logo.

6. In the Logo layer of the Layers panel, drag the rectangle object so that it is below the logo object (called “Group: 3 objects”). The logo is now properly displayed, with the rectangle highlighting rather than obscuring the logo.

7. Save your work.
Create an outline around the banner

You want to create a black outline around the banner. To create this effect, you decide to use a rounded rectangle as a vector mask.

A vector mask crops or clips the underlying object to the shape of its path, creating a cookie-cutter effect.

1. Select the Background layer in the Layers panel.

2. Select the Rounded Rectangle tool in the Vector section of the Tools panel.

3. In the Property inspector, set the following properties for the tool:
   - Select None from the Fill Category pop-up menu.
   - Click the Color box next to the pencil icon and set the stroke color to a light gray such as #666666.
   - Set the stroke tip size to 1 and the stroke category to 1-Pixel Soft.
4. On the canvas, draw and position the rounded rectangle inside the banner.
   The area that falls outside the rounded rectangle will be black, forming the banner's outline.
   Use the blue selection points to adjust the size of the shape. Use the yellow diamond-shaped control points to adjust the roundness of the corners.

5. With the rounded rectangle still selected, select Edit > Cut.
6. In the Layers panel, select the background photo (called “Bitmap”) on the Background layer.
   You want to apply the mask to this object.
7. Select Edit > Paste As Mask to apply the mask to the photo.
   On the canvas, the area covered by the rounded rectangle is visible. The area outside it is masked.
   In the Layers panel, a mask thumbnail appears next to the background photo. The green highlight around the mask thumbnail indicates that it is selected.

8. Save your work.
Create a slanted edge effect

You want to create a slanted edge effect in the banner, as shown in the banner sketch (see “Review your task” on page 195). To produce this effect, you decide to create a shape and use it as a mask.

1. In the Layers panel, select the Graphics layer.
2. In the Tools panel, select the Pen tool.

3. In the Property inspector, set the following properties for the Pen tool:
   - Click the Stroke Color box next to the pencil icon and click the Transparent button.
   - In the Fill Category pop-up menu, select Solid.
   - Click the Fill Color box next to the bucket icon and select the black swatch with the eyedropper pointer.
4. In the Document window outside the canvas, click four times to draw a rectangular shape, and then click on the first point to close the shape. Your rectangle should be a little taller than the banner graphic and about a third of its length.
5. Select the Pointer tool (or press V) and move the shape so that it covers the left side of the banner.

NOTE
Because the shape is on the Graphics layer, it obscures the background image but not the logo. According to the stacking order shown in the Layers panel, the Logo layer is above the Graphics layer while the Background layer is below it.
6. Select the Subselection tool (or press A) and click the shape’s anchor points to adjust its shape so that its right side is slanted, as follows.

![Banner with slanted text](image)

7. Save your work.

**Add a tag line to the banner**

Next, you need to add the company’s tag line, Nouveau World Cuisine, to the banner.

1. In the Layers panel, select the Graphics layer.
2. Select the Text tool in the Tools panel.
3. In the Property inspector, set the following properties for the tool:
   - Select Arial from the Font pop-up menu.
   - Enter 14 as the font size.
   - Click the Bold button.
   - Click the Color box, type F7EFE3 as the text color, and then press Enter.
   - Click the Left Alignment button.
4. Click below the logo graphic and type *Nouveau World Cuisine*.

![Banner with tag line](image)

5. Click once outside the text block to apply your text entry.

   Fireworks creates a new text object on the Graphics layer whose default name matches the text you typed. This feature gives you the ability to quickly identify the text objects you use in your composition.

6. Save your work.
Export an optimized image file

Now that you completed the banner graphic, you’re ready to optimize and export the image as an JPEG file.

Optimize and preview the image

Before you export any document from Fireworks, you should always optimize it. Optimizing ensures that an image is exported with the best possible balance of compression and quality.

1. If the Optimize panel isn’t already open, select Window > Optimize to open it.

2. From the Settings pop-up menu, select JPEG – Better Quality.

The options in the panel change to reflect the new setting.

These settings can be changed, but for this tutorial you use the default settings.

The ultimate goal in web graphic design is to create great-looking images that download as fast as possible. To do that, you must reduce the file size of your image while maintaining its quality as much as possible. This balancing act is optimization—finding the right mix of color, compression, and quality.
3. Click the Preview button near the top left of the Document window. Fireworks displays your document as it will appear when exported with the current settings.

At the lower left of the window, Fireworks displays the size of the exported file and the estimated time it will take to display the image when viewed on the web.

**NOTE**

While previewing the image, you can try different quality settings in the Optimize panel and see their effects on the image.
Export the image

After choosing your optimization settings, export the image as a JPEG file. Select File > Export.

The filename listed has a .jpg extension. Fireworks chose this file format because you selected it in the Optimize panel.

1. Browse to the following folder on your hard disk:
   local_sites/cafe_townsend/images/

2. Ensure that the Save As Type (Windows) or Save As (Macintosh) pop-up menu reads Images Only, and click Export.
   The JPEG file is exported to the images folder.
   Remember that the PNG file is your source file, or working file.
   Although you exported your document in JPEG format, you also must save the PNG file so that any changes you made will be reflected in the source file too.

3. Select File > Save to save the changes to the PNG file.

View the exported image

Your banner graphic is done. Compare the JPEG file created during the export process to the PNG file you worked on.

- In Fireworks, select File > Open, browse to the images folder, and double-click the banner_graphic.jpg file.

   \[\text{ NOTE: If the file doesn't appear in the images folder, select JPEG from the Files of Type pop-up menu.}\]
The JPEG image opens in Fireworks. Because JPEG images are bitmaps, all your objects and layers are flattened in the Layers panel.

Also, the Property inspector displays only a few properties. All the properties available in the PNG file are no longer available in a JPEG file. You still have your source PNG file, so if you need to do more work on the design, you can edit the PNG file and export it again. A PNG file always remains fully editable even if you export the image to another format, such as JPEG.

In this tutorial, you accomplished the work required to create a banner graphic in Fireworks. You learned how to create a new document and import images. You also worked with layers, shapes, masks, and text. Finally, you optimized and exported the completed image.

For detailed information about any of the features covered in this tutorial, and for information on additional Fireworks features, see Using Fireworks.
CHAPTER 9

Tutorial: Building Your First Flash Application

This tutorial guides you through the process of creating a simple application using some of the authoring features in Macromedia Flash Basic 8 and Flash Professional 8. A Flash application, broadly defined, can be as simple as content that offers interactivity, or as elaborate as a robust application that interacts with a variety of data sources.

If you have not already done so, Macromedia recommends that before you take this tutorial you read “Flash basics” on page 57.

In this tutorial, you will complete the following tasks:

- Review your task ......................................................... 216
- Examine the completed application ............................ 216
- Create a new document ................................................ 218
- Create symbols .......................................................... 221
- Edit a symbol Timeline .............................................. 225
- Add actions to frames .................................................. 227
- Add labels to frames .................................................... 228
- Add motion tweens ...................................................... 229
- Edit the main Timeline ............................................... 231
- Create the border ....................................................... 232
- Add a symbol ........................................................... 238
- Add a text box .......................................................... 239
- Add the movie clip to the Stage .................................. 242
- Add a button component .......................................... 243
- Add ActionScript code ............................................... 244
- Publish your document ............................................... 250
Review your task

In this tutorial, you will create a type of application known as a flexible messaging area, or FMA for the website of a fictional restaurant called Cafe Townsend. An FMA is a common type of Flash application used for displaying content that conveys some kind of informational or marketing message to the audience. In this case, the FMA displays photographs of items from a restaurant menu. At Macromedia's website, an FMA is used to display information about new software products and other advertising messages. These are called flexible messaging areas because they usually occupy an area of the web page that is set aside for content that can change depending on the needs of the business or website. For example, if the fictional restaurant Cafe Townsend has a special event planned, its FMA could change to display the details of that event instead of the restaurant’s menu items.

In this tutorial, after examining a finished version of the FMA, you’ll begin by creating a new Flash document and end by publishing the application for web playback. The tutorial should take approximately 30 minutes to complete.

The completed FMA

Examine the completed application

As you examine the finished version of the application you'll create, you will also gain some familiarity with the Flash workspace.

In subsequent sections of this tutorial, you'll follow the steps to create the application yourself.
Run the completed application

To better understand the type of application you’ll create as you work through this tutorial, you can look at a completed FLA file version of the application in the Flash authoring tool. FLA files are the type of files you work on in Flash. You can also play the SWF version of the file in Flash Player. The SWF version is the version of the file that you would publish in a web page.

To play the SWF version of the file in Flash Player:
1. In Flash, select File > Open.
2. Browse to the completed file using one of the following paths:
   - Browse to the local_sites\cafe_townsend\completed files\flash folder that you copied to your local disk in Chapter 4, “Tutorial: Setting Up Your Site and Project Files” and double-click flash_fma_finished.swf.
   The completed application runs in Flash Player. Click Next to watch the images of food change with the animation.
3. After viewing the application, close the Flash Player window.

Open the authoring document

It’s helpful to look at the completed authoring FLA file to see how the author designed the application.

To view the authoring version of the file in Flash:
1. In Flash, select File > Open.
2. Browse to the authoring document using one of the following paths:
   - Browse to the local_sites\cafe_townsend\completed files\flash folder that you copied to your local disk in Chapter 4, “Tutorial: Setting Up Your Site and Project Files” and double-click flash_fma_finished.fla.
   You now see the completed tutorial application in the Flash authoring environment.
3. After you have the file open, you can explore the Stage, the Library panel, and the Timeline.

- On the Stage you will see a variety of graphic shapes, which you will learn to create later in this tutorial.
- In the Library panel, you will see a list of symbols, or reusable assets, that the document uses.
- In the Timeline, you will see a representation of how and when those symbols appear on the Stage.
- In the Actions panel, you will see ActionScript code that controls navigation in the Flash document and imports image files for display when the Flash document plays.

You will learn more about the role of each of these parts of Flash as you complete the tutorial.

4. When you are finished viewing the finished document, close it and be sure not to save any changes to the file.

Create a new document

Now that you have seen the finished application you will create, it is time to create your own Flash document.

If you haven’t already set up a working folder, you must do so before you begin. For instructions, see “Setting Up Your Site and Project Files.”

To learn how to create an application in Flash, you’ll start with the very first step in the process: creating a new file.

Open a new document

Now you’re ready to create your own version of the FMA.

**To create a new document:**

1. Select File > New.
2. In the New Document dialog box, select Flash Document and then click OK.
3. Select File > Save.
4. Name the file **flash_fma.fla** and save the file in the cafe_townsend folder you copied to the local_sites folder on your hard disk.

**NOTE**  
As you complete the tutorial, remember to save your work frequently.

**Define document properties**

Configuring document properties is a common first step in Flash authoring. You can change the document properties at any time, but it is helpful to make certain decisions, such as the Stage size and background color, at the beginning of the process.

Document properties are properties that affect the entire Flash document, such as the size of the Stage or the background color. You can use the Property inspector to specify these settings.

**To define document properties:**

1. If the Property inspector isn’t open, select Window > Properties > Properties. (The default location of the Property inspector is at the bottom of the Flash application window.)

![Property inspector](image)

**NOTE**  
If the Property inspector is not fully expanded, click the white triangle in the lower-right corner.

2. In the Property inspector, enter **60** in the Frame Rate text box.  
The application will play at 60 frames per second, an optimal frame rate for playing animations smoothly.

3. Click Size to set the Stage size.

**ABOUT...**  
The Property inspector lets you view and change the specifications for selected objects. The specifications depend on the type of object selected. If you select a text object, for example, the Property inspector displays settings for viewing and modifying text attributes. Because you just opened a new document, the Property inspector shows the document settings.
4. In the Document Properties dialog box, enter 700 in the width text box and 150 in the height text box, and then click OK. Flash automatically inserts the px (for pixel) after the number.

5. In the Timeline, click the value in the Zoom menu and enter 75%. This makes it easier to see your entire document in the Document window.

   Press Enter (Windows) or Return (Macintosh).

6. Save your work.

   For more information about setting document properties, see “Creating or opening a document and setting properties” in Using Flash.
Create symbols

Next, you will create some symbols or reusable assets. Symbols allow you to use the same asset more than once without storing multiple copies of it in your FLA file. You store the symbol in the Library panel, and drag instances of the symbol to the Stage when you need them.

To create the symbol:
1. Select Insert > New Symbol.
2. In the Create New Symbol dialog box, type imageHolder in the Name text box.
   The default value for Behavior is Movie Clip. Leave this unchanged.
3. Click OK.
   The new symbol is added to the Library panel (Window > Library) and Flash enters symbol-editing mode.

NOTE
In symbol-editing mode, the Stage disappears and the main portion of the Flash application window becomes a drawing area where you can draw and edit the symbol.

4. In symbol-editing mode, Select the Rectangle tool from the Tools panel (Window > Tools).
5. Select white (#FFFFFF) from the Stroke Color Picker on the Tools panel.
6. Select light gray (#CCCCCC) from the Fill Color Picker in the Tools panel.

About Symbols and the Library panel
Symbols are reusable assets that allow you to use a single asset more than once in your Flash document without duplicating the asset in the file. By keeping only one copy of the symbol in the Flash document, you keep the document file size low. A symbol can be as simple as a button or a graphic, or as complex as a movie clip. After you create a symbol, you store it in the Library panel. The Library panel stores and organizes all the symbols in your document. To reuse a symbol, you drag it from the Library panel to the Stage. When you do this, Flash creates a new instance of the symbol on the Stage. An instance is really just a reference to the original symbol; it tells Flash to “Draw a copy of the specified symbol here”. By using symbols and instances, you can keep your assets well-organized and your Flash file size low. In addition, you can update the appearance or behavior of all the instances of a specific symbol by editing the symbol. These changes are then reflected in all the instances of the symbol throughout your document.
7. Drag in the drawing area to draw a wide, flat rectangle.

8. Select the Selection tool from the Tools panel.

9. Double-click the rectangle you drew to select both its fill and its stroke.

10. In the Property inspector, enter 0 in both the X and Y text boxes.
    This locates the upper-left corner of the symbol in the upper-left corner of the Stage.

11. Enter 700 in the Width (W) text box and 150 in the Height (H) text box and press Enter (Windows) or Return (Macintosh).

   ![The Property inspector with the correct width, height, X, and Y values]

   The Property inspector with the correct width, height, X, and Y values

   **NOTE** When you enter values into the text boxes in a panel, you must press Tab, Enter (Windows), or Return (Macintosh) in order for Flash to acknowledge the value.

Individual instances of this first symbol that you created become the container for individual images your FMA will display. This is why you named it imageHolder. Next, you create another symbol that becomes a container for a stack of five instances of the imageHolder symbol. Later, you will animate this new symbol vertically to change the image that appears on the visible part of the Stage.

**To create the second symbol with five imageHolder instances:**
1. Select Insert > New Symbol.

2. In the Create New Symbol dialog box, enter slides in the Name text box and click OK.
   You remain in symbol-editing mode.

3. Select 25% from the Zoom menu in the Timeline.
4. In the Library panel (Window > Library), drag the imageHolder symbol to the drawing area.

You have now created an instance of the imageHolder symbol. This instance is part of the new slides symbol you are creating.

5. With the new instance still selected on the Stage, in the Property inspector, enter holder0 in the Instance Name text box.

This gives the instance its own name that is separate from the symbol name.

6. Also in the Property inspector, enter 0 in both the X and Y text boxes and press Enter (Windows) or Return (Macintosh).

This locates the upper-left corner of the holder0 instance at the upper-left corner of the slides symbol.

7. Drag the imageHolder symbol from the Library panel to the drawing area and place it just below the holder0 instance.

8. In the Property inspector, enter holder1 in the Instance Name text box.

9. Enter 0 in the X text box and 150 in the Y text box and press Enter or Return.

10. Repeat the process for a third, fourth, and fifth instance of the imageHolder symbol.

In the Property inspector, give the new instances the following properties:

Third instance:
- Instance Name = holder2
- X = 0
- Y = 300

Fourth instance:
- Instance Name = holder3
- X = 0
- Y = 450

Fifth instance:
- Instance Name = holder4
- X = 0
- Y = 600
You have now finished creating the symbol called slides. Next, you will create a third symbol that will contain an instance of the slides symbol. As you can see, nesting symbol instances inside other symbols is a common technique of Flash authoring.

The completed slides symbol

To create the third symbol:

1. Select Insert > New Symbol.
2. In the Create New Symbol dialog box, enter slideShow in the Name text box and click OK.
3. Drag the slides symbol you created in the previous section from the Library panel to the drawing area of the new slideShow symbol. This creates an instance of the slides symbol within the new slideShow symbol.

The Library panel with the slides and slideShow symbols
4. With the symbol instance still selected, in the Property inspector, enter 0 in the X and Y text boxes.

5. Still in the Property inspector, enter `slides_mc` in the instanceName text box.

**Edit a symbol Timeline**

Now that you have created the three symbols, you will edit the slideShow symbol by adding animation to its Timeline. This animation causes the images of food in the completed document to slide upward when the user clicks a button that you will add later.

**To edit the slideShow symbol:**

1. Without leaving symbol-editing mode, click Insert Layer in the Timeline.

   ![The Insert Layer button in the slideShow symbol's Timeline](image)

   This adds a layer to the slideShow symbol's Timeline.

**About movie clips and nested Timelines**  
Each movie clip symbol can have its own timeline that allows the movie clip to contain animation or ActionScript of its own. This is why you see the name of the symbol you are editing at the top of the Timeline when you are in symbol-editing mode.

Using symbols and nested timelines gives you great flexibility in how you build your Flash document and organize its functionality. A typical example of this is a car moving across the Stage with spinning wheels. The animation of the car moving across the Stage could be in the main Timeline of the Flash document. Each of the spinning wheels could be an instance of a movie clip symbol with its own timeline. The spinning animation of the wheels would be implemented in the movie clip timeline. This approach is much simpler to implement than creating an animation in the main timeline of the wheels, which are both spinning and moving across the Stage.
2. In the Timeline, select Frame 20 of Layers 1 and 2.

3. Select Modify > Timeline > Convert to Keyframes.
   This adds frames to the Timeline and adds keyframes to the selected frames (Frame 20).

4. Repeat the process by selecting Layers 1 and 2 in Frame 40 and selecting Modify > Timeline > Convert to Keyframes.

5. Repeat the process in Frames 60 and 80.
   You may need to use the scroll bar at the bottom of the Timeline to see these frames.
Add actions to frames

In this section, you will add a small amount of ActionScript to control how the playhead moves through the Timeline of the slideShow movie clip. By adding `stop()` methods, you cause the playhead to stop and wait at certain frames. Later you will add ActionScript code to make the playhead move again.

**To add the ActionScript code:**

1. In the Timeline, select Frame 1 of Layer 2.
2. Select Modify > Timeline > Convert to Keyframes.
   
   This adds a keyframe to the frame, so now there are keyframes in Frames 1 and 2 of Layer 2.
3. Select Frame 1 of Layer 2.
4. Open the Actions panel (Window > Actions).
   If the Actions panel is in Script Assist mode (you will see the text “To add an item, double-click or drag the item to the Script window” and will be unable to type in the Script window), click the Script Assist button in the Actions panel to exit Script Assist mode.
5. In the Actions panel, type the following ActionScript:
   ```javascript
   stop();
   ```
   
   This code causes the playhead to stop playing the slideShow movie clip whenever it reaches Frame 1. A small 'a' appears in Frame 1 of Layer 1 of the Timeline. This indicates that ActionScript is present in that frame.
6. In the Timeline, select Frame 20 of Layer 2.
7. Select Modify > Timeline > Convert to Keyframes.
8. Select Frame 20 of Layer 2.
9. In the Actions panel, type the `stop();` ActionScript.
10. In the Timeline, select frame 40 of Layer 2.
11. Select Modify > Timeline > Convert to Keyframes.
12. Select frame 40 of Layer 2.
13. In the Actions panel, type the `stop();` ActionScript.
15. Select Modify > Timeline > Convert to Keyframes.
16. Select frame 60 of Layer 2.
17. In the Actions panel, type the `stop();` ActionScript.
18. In the Timeline, select frame 80 of Layer 2.
19. In the Actions panel, type the `stop();` ActionScript.

Add labels to frames

Now you will add labels to specific frames. By labeling a frame, you make it possible to refer to that frame in ActionScript. This allows you to write ActionScript code that performs actions on those frames. Later, you will add ActionScript code that makes the playhead jump to these labeled frames.

**To add the frame labels:**

1. In the Timeline, select Frame 2 of Layer 2.
2. In the Property inspector, enter `slide0` in the Frame Label text box.
   A small flag icon and the frame label appear in Frame 2 of Layer 2 in the Timeline.
3. In the Timeline, select Frame 21 of Layer 2.
4. In the Property inspector, enter `slide1` in the Frame Label text box.
5. In the Timeline, select Frame 41 of Layer 2.
6. In the Property inspector, enter `slide2` in the Frame Label text box.
7. In the Timeline, select Frame 61 of Layer 2.
8. In the Property inspector, enter `slide3` in the Frame Label text box.

*The Timeline with the completed frame labels*
Add motion tweens

A motion tween is a type of animation in which an object moves from one position to another. In this project, you will make the images of food animate upward when the user clicks on a button, which you will add later.

To add the motion tweens:
1. In the Timeline, select Frame 1 of Layer 1.
2. In the Property inspector, select Motion from the Tween menu.
   Frames 1 to 19 in Layer 1 become a motion tween. An arrow appears in those frames in the Timeline.
3. In the Property inspector, drag the slider next to the Ease text box until the value in the text box is 100.
   This number causes the tween to be eased at the end of the motion.
   This means the motion starts suddenly and ends more slowly
4. In the Timeline, select Frame 20 in Layer 1.
5. In the Property inspector, select Motion from the Tween menu.
6. Drag the Ease slider up until the Ease value is 100.
7. Click the slides_mc movie clip instance on the Stage to select it.

About motion tweens
The name motion tween comes from the fact that the animation includes motion, and from the way that motion is created. The term tween is short for in between. You define motion-tweened animations by defining starting and ending positions for the object being animated, and then letting Flash calculate all of the in-between positions for the object. In this way, you can create smooth motion animations simply by setting the start and end positions of the object you are animating.

About easing animations
The default behavior of motion tweens is for the animation to proceed at the same speed throughout its entire duration. Often however, this doesn’t look very good to the eye. Just as a car doesn’t go from 0 to 50 mph instantly, your animations shouldn’t either. Easing an animation is the same as accelerating a car slowly. The term easing comes from the idea that you ease a car into motion, or ease it to a stop. By adding an easing value, you cause your motion tweens to begin or end more gradually.
8. In the Property inspector, enter -150 in the Y text box. This moves the slideShow movie clip instance upward 150 pixels in the keyframe in Frame 20. The motion tween from Frame 1 to Frame 20 slides the movie clip upward smoothly instead of causing the movie clip to jump from one position to the next.

9. In the Timeline, select Frame 40 in Layer 1.

10. In the Property inspector, select Motion from the Tween menu.

11. Drag the Ease slider up until the Ease value is 100.

12. Click the slides_mc movie clip instance on the Stage to select it.

13. In the Property inspector, enter -300 in the Y text box.

14. In the Timeline, select Frame 60 in Layer 1.

15. In the Property inspector, select Motion from the Tween menu.

16. Drag the Ease slider up until the Ease value is 100.

17. Click the slides_mc movie clip instance on the Stage to select it.

18. In the Property inspector, enter -450 in the Y text box.

19. In the Timeline, select Frame 80 in Layer 1.

20. Click the slides_mc movie clip instance on the Stage to select it.

21. In the Property inspector, enter -600 in the Y text box.

22. In the Timeline, click the number 1 in the Frame Number bar.

23. Press Enter (Windows) or Return (Macintosh).

A preview of the animation plays on the Stage. The `stop();` ActionScript you entered previously is ignored in preview mode.

You have now finished creating the slideShow symbol, which contains its own complex internal timeline. Next, you will edit the main Timeline of your FLA file.

![The Timeline with the completed motion tweens](image_url)
Edit the main Timeline

Now you will return to the main Timeline of your Flash document to add details that affect the entire document.

To add layers to the main Timeline:

1. Click the Scene 1 icon at the top of the Timeline.
   You exit symbol-editing mode and return to the main Timeline of your FLA file.
2. Click the Insert Layer button at the bottom of the Timeline.
   A new layer appears above the existing layer in the Timeline.
3. Click Insert Layer three more times to insert three more layers.
   You now have four layers in the main Timeline.
4. Double-click the layer name Layer 5 to make the name editable.
5. Enter the name actions as the new layer name and press Enter (Windows) or Return (Macintosh).
6. Double-click the layer name Layer 4 and rename the layer nextButton.
7. Double-click the layer name Layer 3 and rename the layer border.
8. Double-click the layer name Layer 2 and rename the layer blueArea.
9. Double-click the layer name Layer 1 and rename the layer slideShow.

The 5 properly named layers in the Timeline

Now that you have added layers to the main Timeline, you are ready to add the slideShow movie clip to the Stage.
To add the slideShow movieClip to the Stage:
1. Click the slideShow layer name to make that layer active.
2. Drag the slideShow symbol from the Library panel to the Stage and align its upper-left corner with the upper left corner of the Stage.
3. With the new movie clip instance still selected on the Stage, go to the Property inspector and set the X and Y values to 0 to align the upper-left corner of the movie clip exactly with the corner of the Stage.
4. Still in the Property inspector, enter slideShow_mc as the instance name for the movie clip
5. Save your work.

Create the border

Next, you will create a border for the Stage that will make the FMA look more visually appealing when you view it in a web page.

To create the border:
1. In the Timeline, select 100% from the Zoom menu.
2. In the Timeline, select the border layer by clicking the layer name.
3. Select the Rectangle tool in the Tools panel.
4. In the Tools panel, select no color from the Stroke Color Picker.

Selecting No Stroke from the Stroke Color Picker
5. Select the color black (#000000) from the Fill Color Picker.

![Selecting black from the Fill Color Picker](image)

6. Draw a rectangle on the Stage that is approximately the same shape as the Stage.

![Drawing a black rectangle the shape of the Stage](image)

7. In the Tools panel, select the Selection tool.
8. On the Stage, click the rectangle you just drew to select it.
9. Select Window > Align to open the Align panel.
10. In the Align panel, click the To Stage option so it is selected. This allows the Align panel to align the selected rectangle with the Stage area.

![The Align panel with the To Stage option selected](image)

11. In the Align panel, find the Match-size area and click the Match Width and Height button. Your rectangle becomes the same size as the Stage area.

![Clicking the Match Width and Height button](image)

**TIP**

When the To Stage option is off, the Align panel aligns multiple selected objects with each other.

12. With the rectangle still selected, click the Align Vertical Center button in the Align panel. Use the tooltips to find the correct button in the Align panel.

![Clicking the Align Vertical Center button](image)
13. Still in the Align panel, click the Align Horizontal Center button.

![Clicking the Align Horizontal Center button](image)

The rectangle is now precisely centered on the Stage.

![The black rectangle centered on the Stage](image)

14. Click outside the Stage to deselect the black rectangle.

15. In the Tools panel, select the Rectangle tool.
16. Still in the Tools panel, select the color blue with the hexadecimal value #0000FF from the Fill Color Picker.

17. In the Tools panel, double-click the Rectangle tool.
18. In the Rectangle Settings dialog box, enter 16 in the Corner Radius text box and click OK.

19. Select View > Snapping > Snap to Pixels to turn on pixel snapping. This causes the edges of shapes that you draw to snap to the nearest pixel as you draw.
20. With the Rectangle tool still selected in the Tools panel, draw a rectangle on the Stage as close to the same size as the Stage as possible.

The blue rounded-corner rectangle on the Stage
21. In the Tools panel, click the Selection tool.
22. Click the blue rectangle to select it.
23. With the blue rectangle selected, go to the Property inspector panel and enter the following values in the text boxes:
   - W: 700
   - H: 150
   - X: 0
   - Y: 0

![The properly sized blue rectangle on the Stage](image)

24. Double-click the blue rectangle again to select it.
25. Press Delete to delete the blue rectangle.

A white rectangle appears in the middle of the black rectangle you drew earlier. The blue rectangle functioned as a mask in this step. You now have a black border at the top and bottom of the Stage.

![The Stage with only the black corners remaining](image)
Add a symbol

In this section, you will add a blue-colored area to the right side of the Stage. This is where the text that describes each menu item and the button for switching menu items will appear.

**To add a new symbol with a blue shape:**
1. Click the blueArea layer name in the Timeline.
2. Select Insert > New Symbol.
3. In the Create New Symbol dialog box, enter menu in the Name text box and click OK.
   You enter symbol-editing mode and the Timeline panel switches to displaying the Timeline of the new blueArea movie clip.
4. In the Tools panel, select the Rectangle tool.
5. Select No Stroke from the Stroke Color Picker.
6. Click the Fill Color swatch to display the Fill Color Picker.
7. In the Fill Color Picker, enter 80% in the Alpha text box.
8. Still in the Fill Color Picker, enter 343469 in the Color text box and press Enter (Windows) or Return (Macintosh).
   This creates a grayish-blue color.
9. In the Tools panel, double-click the Rectangle tool.
10. In the Rectangle Settings dialog box, enter 0 in the Corner Radius text box and click OK.
11. With the Rectangle tool, draw a flat, wide rectangle on the Stage.
12. In the Tools panel, click the Selection tool.
13. Double-click the rectangle you drew on the Stage to select it.
14. In the Property inspector panel, enter the following values for the rectangle shape:
   - W: 415
   - H: 150
   - X: 0
   - Y: 0
15. Press Enter or Return.
16. In the Tools panel, click the Subselection tool.

17. Move the mouse over the lower-left corner of the rectangle until a tiny white box appears next to the arrow pointer.

The pointer indicating that the corner of the rectangle can be dragged

18. Drag the corner of the rectangle to the right so that the left side of the rectangle becomes a diagonal line at approximately a 30º angle.

19. In the Tools panel, click the Selection tool.
    This deselects the control points on the rectangle.

Add a text box

Now that you have added the blue background to the menu movie clip, you are ready to add the text that describes each menu item. You will add two text boxes. The ActionScript code you add later will insert the text into these text boxes.
To add the text box for the menu item title:

1. In the Tools panel, click the Text tool.

2. In the Property inspector, select Dynamic Text from the Text Type menu.

3. Still in the Property inspector, enter 14 in the Font Size text box.

4. With the Text tool, draw a wide flat text rectangle in the top part of the gray-blue shape you just created.
   The rectangle should be almost as wide as the blue shape. Don’t worry about the exact placement of the rectangle. You will adjust that later.

5. In the Tools panel, click the Selection tool.

6. Click the text box you just drew to select it.

7. In the Property inspector panel, enter the following values:
   - Text Type: Dynamic Text
   - InstanceName: title_txt
   - X: 60
   - Y: 10
   - Font: Verdana
   - Font Size: 14
   - Text (fill) color: White
   - Style: Bold
   - Line Type: Single line

8. Save your document.
Add the second text box

Now you will add the second text box, which will hold the description text for each menu item.

To add a text box for the descriptions:
1. Click outside the Stage to deselect the text box you created in the previous section.
2. In the Tools panel, click the Text tool.
3. In the Property inspector, enter 12 in the Font Size text box.
4. Still in the Property inspector, deselect the bold icon.
5. Select Multiline from the Line Type menu.
6. With the Text tool, draw another text rectangle on the Stage, filling the lower part of the blue shape you created earlier, below the rectangle you drew in “To add the text box for the menu item title:” on page 240.
7. In the Tools panel, click the Selection tool.
8. With the second text rectangle still selected, go to the Property inspector panel and enter the following values:
   - Text Type: Dynamic Text
   - InstanceName: description_txt
   - X: 85
   - Y: 45
   - Font: Verdana
   - Font Size: 12
   - Color: White

The Property inspector with the correct values entered
9. In the Tools panel, click the Selection tool.
10. Click in the Stage area outside the shapes you have drawn to
deselect them.
11. In the Timeline, click the Scene 1 link to exit symbol-editing mode and
return to the main Timeline of the Flash document.
   You exit symbol-editing mode and the Stage with the black borders
   reappears.
12. Save your document.

**Add the movie clip to the Stage**

Now that you have completed the menu movie clip, you are ready to add it
to the Stage in the main Timeline.

To add the menu movie clip to the Stage:
1. In the Tools panel, click the Selection tool to ensure that the tool
   is active.
2. In the Library panel (Window > Library), drag the menu movie clip and
   place it on the right side of the Stage.
3. With the menu movie clip still selected on the Stage, go to the Property
   inspector and enter the following values:
   InstanceName: menu_mc
   W: 415
   H: 150
   X: 285
   Y: 0
4. With the menu movie clip still selected, go to the Property inspector and
   select Alpha from the Color menu.
5. Drag the Alpha Amount slider until the value is 90%.
Add a button component

Now you are ready to add the button that allows the user to switch from one slide to the next in the slide show.

To add the Next button:
1. In the Timeline, click the nextButton layer name to make that layer active.
   This is the layer that holds the button component you are about to add.
2. Open the Components panel if it is not already open by selecting Window > Components.
3. In the Components panel, open the User Interface category by clicking the plus sign (+) next to the User Interface category name.
4. Drag the Button component from the Components panel to the lower part of the blue rectangle on the Stage.
   The button stays selected on the Stage unless you click elsewhere.
5. With the button still selected, go to the Property inspector panel and enter the following values:
   InstanceName: next_btn
   X: 590
   Y: 120
6. In the Property inspector panel, click the Parameters tab.
7. In the Label text box, replace the name Button with the name Next and press Enter (Windows) or Return (Macintosh).
   The label on the button changes to Next.
8. Save your document.
Add ActionScript code

You have now added all the graphic and text elements that your FMA requires. The last step is to add the ActionScript code that displays the proper text and image for each slide in the slideshow movie clip.

To add the test ActionScript:
1. In the Timeline, click the layer name actions to activate that layer.
2. Select Window > Actions to open the Actions panel.
3. In the Actions panel, type the following ActionScript code. You can copy and paste the following code from the Flash Help panel:

   ```actionscript
   function testFunc(eventObj:Object) {
       menu_mc.title_txt.text = "Testing the title";
       menu_mc.description_txt.text = "Testing the description";
   }
   // add the event listener for the button
   next_btn.addEventListener("click", testFunc);
   ```

   This ActionScript code adds some text to the title and description text boxes that you added to the menu movie clip earlier.
4. Select Control > Test Movie.
   The Flash document opens and plays in a new window.
5. In the Test Movie window, click Next.
   The test title and test description text you entered as part of the ActionScript code appears in the blue rectangle on the right side of the document.

NOTE
If you did not complete Chapter 7, "Tutorial: Handling Photographs" you need get the images required for this tutorial. To do so, open the cafe_townsend/completed_files/flash/images folder that you copied to your hard disk in Chapter 4, "Tutorial: Setting Up Your Site and Project Files," and then copy the image0.jpg, image1.jpg, image2.jpg, and image3.jpg files to the cafe_townsend/images folder.

TIP
To add the text (in quotes), ActionScript refers to the text boxes by noting the name of the menu movie clip instance that is on the Stage (menu_mc), and then the name of the text box itself within the movie clip instance, as follows:

   menu_mc.description_txt

This syntax is called dot syntax. It is used throughout ActionScript to refer to objects that are nested within other objects.
Enter ActionScript code for the slide show

Now you will enter the ActionScript code that makes the slideshow animate each new slide into place when the Next button is clicked. After you add the code, your Flash document will be complete.

To add the ActionScript code to the Flash document:
1. In the Timeline, make sure Frame 1 of the actions layer is still selected.
2. In the Actions panel, delete all the code you entered in “Test an ActionScript sample” on page 244.
   The Actions panel should now be empty of code.
3. Copy the following code and paste it into the Actions panel.
   /*The following four sections contain the data for each menu item.*/
   /* */
   /* 0 */
   var image0title:String = "Summer salad";
   var image0desc:String = "Butter lettuce with apples, blood orange segments, gorgonzola, and raspberry vinaigrette.",
   var image0uri:String = "images/image0.jpg":
   /* */
   /* 1 */
   var image1title:String = "Turkey and Sun-dried Tomato Sandwich";
   var image1desc:String = "Fresh roasted turkey with sun-dried tomatoes, garlic aioli, and havarti.",
   var image1uri:String = "images/image1.jpg":
   /* */
   /* 2 */
   var image2title:String = "Seared Salmon";
   var image2desc:String = "Filet of wild salmon with caramelized onions, new potatoes, and caper and tomato salsa.",
   var image2uri:String = "images/image2.jpg":
   /* */
   /* 3 */
   var image3title:String = "New York Cheesecake";
   var image3desc:String = "Creamy traditional cheesecake served with chocolate sauce and strawberries.",
   var image3uri:String = "images/image3.jpg":
   var currImage:Number = 0;
   var totalImages:Number = 4;
   menu_mc.title_txt.text = this["image"+currImage+"title"];
menu_mc.description_txt.text =
this["image"+currImage+"desc"];  

for (var i:Number = 0; i<totalImages; i++) {
slideShow_mc.slides_mc["holder"+i].loadMovie(this["image"+(i)+"uri"],slideShow_mc.slides_mc.getNextHighestDepth());
}

slideShow_mc.slides_mc["holder4"].loadMovie(this["image0uri"],slideShow_mc.slides_mc.getNextHighestDepth());

// function for the Next button
function nextMenuItem(eventObj:Object) {
slideShow_mc.gotoAndPlay("slide"+(currImage));
if ((currImage+1)>=totalImages) {
currImage = 0;
} else {
currImage++;
}
menu_mc.title_txt.text =
this._parent["image"+currImage+"title"];
menu_mc.description_txt.text =
this._parent["image"+currImage+"desc"];  
}

// add the event listener for the button
next_btn.addEventListener("click", nextMenuItem);

"Review the ActionScript code" on page 246 explains this code in detail.

4. Save your document.
5. Select Control > Test Movie.
6. In the Test Movie window, click Next to watch the animated images of food and see the titles and descriptions update for each slide.
7. Close the Test Movie window.

Review the ActionScript code

This section explains what the ActionScript you just added to the Actions panel is doing. If you prefer, you can skip this section and move on to publishing your document for display in a web browser.

Complete information about working with ActionScript can be found in Learning ActionScript 2.0 in Flash.
The first section of code contains variables that store information about the images that will appear in each section of the `slideShow` movie clip.

/* 0 */
var image0title:String = "Summer salad";
var image0desc:String = "Butter lettuce with apples, blood orange segments, gorgonzola, and raspberry vinaigrette.";
var image0uri:String = "images/image0.jpg";

/* 1 */
var image1title:String = "Turkey and Sun-dried Tomato Sandwich";
var image1desc:String = "Fresh roasted turkey with sun-dried tomatoes, garlic aioli, and havarti.";
var image1uri:String = "images/image1.jpg";

/* 2 */
var image2title:String = "Seared Salmon";
var image2desc:String = "Filet of wild salmon with caramelized onions, new potatoes, and caper and tomato salsa.";
var image2uri:String = "images/image2.jpg";

/* 3 */
var image3title:String = "New York Cheesecake";
var image3desc:String = "Creamy traditional cheesecake served with chocolate sauce and strawberries.";
var image3uri:String = "images/image3.jpg";

This code declares four sets of three variables each. Each set of three variables represents one of the four images that your Flash document displays. The only difference between the variable names for the four different images is the number that is included in the variable names. The numbering starts with the number 0 instead of 1. This is because lists in ActionScript are zero-based. This means that the first item in the list is always referred to by the number 0 rather than the number 1.

The three variables that are declared for each image are as follows.
Remember that the number in the middle of each variable name changes for each image:

- `image0title` contains a string that is the name of the dish that appears in the `title_txt` text box in the `menu` movie clip.
- `image0desc` contains a string that is the description of the dish that appears in the `description_txt` text box in the `menu` movie clip.
imageOuri contains a string that is the Universal Resource Identifier for the image file that is loaded and displayed in each section of the slides movie clip.

The next two lines of code declare two more variables:
```
var currImage:Number = 0;
var totalImages:Number = 4;
```
The first variable, currImage, stores the number of the current image that is being displayed in the slides movie clip. The second variable, totalImages, stores the total number of images that are available to be displayed. By storing this last number in a variable, you make it easier to change the number if you want to add more images to the slide show later. You would also need to modify the slideShow movie clip in that case. The next line of code sets the text of the title text box to the text in the variable whose name corresponds to the current image number.
```
menu_mc.title_txt.text = this["image"+currImage+"title"];
```
This code uses dot syntax to set the text property of the title_txt text box in the menu_mc movie clip instance to the value of a variable. In this case the variable name is constructed from the word image plus the value of the currImage variable, plus the word title. The variable name becomes image0title or one of the other similar variable names, depending on the number contained in the currImage variable. The word this indicates to Flash that the variable was declared inside this same script.

The following line of code is similar to the previous one:
```
menu_mc.description_txt.text = this["image"+currImage+"desc"];
```
This line of code sets the text of the description text box in the menu_mc movie clip instance to the text in the desc variable that corresponds to the current image number.

The following lines of code set up a for loop to load external JPG image files into the holder movie clip instances, which are in the slides movie clip in the slideShow movie clip. The file paths to each external JPG file are stored in the image*uri variables declared in the beginning of this ActionScript code block, as follows:
```
for (var i:Number = 0; i<totalImages; i++) {
  slideShow_mc.slides_mc["holder"+i].loadMovie(this["image"+(i )+"uri"],slideShow_mc.slides_mc.getNextHighestDepth());
}
```
A for loop is a block of code surrounded by a set of braces {} that repeats for each increment of the i variable. In this case, i increments from 0 to 4 because the value of totalImages is 4. The loadMovie() method can be used to load a Flash file or an image file into the movie clip. In this case it is loading the external JPG files.

The next line of code loads the first image, stored in the image0uri variable, into the holder4 movie clip instance, as follows:

```
slideShow_mc.slides_mc["holder4"].loadMovie(this["image0uri"],slideShow_mc.slides_mc.getNextHighestDepth());
```

The following lines of code implement the functionality of the Next button:

```
function nextMenuItem(eventObj:Object) {
    slideShow_mc.gotoAndPlay("slide"+(currImage));
    if ((currImage+1)>=totalImages) {
        currImage = 0;
    } else {
        currImage++;
    }
    menu_mc.title_txt.text =
    this._parent["image"+currImage+"title"];  
    menu_mc.description_txt.text =
    this._parent["image"+currImage+"desc"];  
}
```

The code for the Next button is contained in the nextMenuItem function. A function is a block of code that is set up to execute when a particular event occurs. In this case, the function will run whenever the user releases the mouse button over the Next button on the Stage.

Inside the function is the gotoAndPlay() method, which directs the playhead to jump to a specific frame label in the Timeline. The Frame label specified in this case is constructed from the word slide and the current value of the currImage variable.

The next line contains an if statement that checks to see if the value of the currImage variable plus 1 is equal to the value of the totalImages variable. If this is true, the code sets the value of currImage to 0, otherwise the code increments the value of currImage by 1.

The last two lines in the function set the text of the title and description text boxes to the strings stored in the image*title and image*desc variables that correspond to the value of the currImage variable.
The line of code immediately after the function definition tells Flash to execute the `nextMenuItem` function when the `next_btn` instance receives a mouse click.

```javascript
next_btn.addEventListener("click", nextMenuItem);
```

Because the `nextMenuItem` function is now set up to listen for mouse clicks, it is called an *event listener*. This is why the `addEventListener()` method is used to tell flash to execute the function when the mouse click event occurs.

While the code described in this section is relatively simple, it still relies on a number of ActionScript concepts that are beyond the scope of this tutorial to describe. For a thorough introduction to these concepts and additional ActionScript tutorials, see *Learning ActionScript 2.0 in Flash* and *Flash Tutorials*.

**Publish your document**

Now that you have completed your Flash document, you are ready to publish it in a web page. The first step in this process is to save the FLA version of your document as a compressed SWF version of the file. This SWF version has a much smaller file size; because of this, it loads easily in a web browser.

**To publish your document as a SWF file:**

1. Select File > Publish Settings.
2. In the Publish Settings dialog box, select the Formats tab and verify that only the HTML and Flash check boxes are selected. This causes Flash to publish only the SWF file and an HTML file to display it in a web browser.
3. Still in the Publish Settings dialog box, select the Flash tab and verify that Flash Player 8 is selected in the Version menu. This causes Flash to export the SWF file in Flash 8 format.
4. Select the HTML tab and verify that Flash Only is selected from the Template menu. This causes Flash to generate only a simple HTML file to display the Flash document in a browser.
5. Click Publish.
   Flash saves a SWF file copy of your document and an HTML file in the folder that contains your working FLA file. This should be the cafe_townsend directory.

6. Click OK to close the Publish Settings dialog box.
Now that you have completed the Flash FMA that will be used in the cafe_townsend website, you can go on to Chapter 10, “Tutorial: Building a Video Player (Flash Professional only),” on page 255.

Resources
Macromedia has excellent resources to help you discover more about Flash, get support, and send feedback to the company.

Registration
Register to receive the latest news about upgrades and new products, technical support, and more. To register online, go to www.macromedia.com/software/register/ and select Help > Online Registration. You can also print the registration form from the Help menu.

Release Notes
For late-breaking information and known issues about Flash, check the Release Notes in the Flash Support Center at www.macromedia.com/support/flash/releasenotes.html.

Flash support
Get the answers you need, day or night, with high-quality Flash support from knowledgeable product support engineers. To learn more, go to the Flash Support Center at www.macromedia.com/support/flash/.
Flash training and certification

Boost your Flash skills with hands-on tasks and real-world scenarios. Flash training allows you to roll up your sleeves and get right to work. Choose between instructor-led and online training, or combine them to create a learning path that is most effective for you. To learn more, go to Macromedia Training at www.macromedia.com/go/flash_training.

Flash Developers Center

Stay up to date with the latest Macromedia Flash development trends and techniques. Tutorials, articles, and sample applications give you the information you need to stay competitive, innovative, and efficient. To learn more, go to the Flash Developers Center at www.macromedia.com/go/flash_devcenter.

On Demand seminars

Evaluating a new product can be difficult, and each version introduces new features to navigate. The Macromedia On Demand seminars help you get up to speed quickly. The Macromedia seminars feature multimedia presentations and demos designed to help you maximize your evaluation experience with Macromedia products. To learn more, go to Macromedia On Demand at www.macromedia.com/macromedia/events/online/ondemand/index.html.

Sample applications

Flash includes sample files that you can examine in order to learn various design and development concepts. To view FLA and SWF versions of the sample files, along with a description, see Flash Samples in Flash Help (with Flash open, select Help > Flash Help). Some of the samples are complete applications, while others are simple and intended to introduce a basic concept. To view the authoring version (FLA file) for a given sample, open the file from within Flash. You'll find the sample files in the Samples folder, which is in your Flash application directory. You can find additional samples in the Flash Developers Center at www.macromedia.com/go/flash_devcenter.
Additional resources

The following Macromedia web pages include reference materials and links to third-party Flash resources:

- Websites devoted to Macromedia Flash and Flash developers can be found at www.macromedia.com/go/tn_12046.
- Macromedia Press (Macromedia's publishing division) can be found at www.macromedia.com/support/mmpress/.
CHAPTER 10

Tutorial: Building a Video Player
(Flash Professional only)

This tutorial guides you through the process of creating a simple video player by using some of the authoring features in Macromedia Flash Basic 8 and Flash Professional 8. After it is created, you can deploy the video player in a web page.

If you have not already done so, Macromedia recommends that before you take this tutorial you read “Flash basics” on page 57.

In this tutorial, you will complete the following tasks:

Review your task . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 255
Examine the completed application . . . . . . . . . . . . . . . . . . . . . . . . . 256
Encode a video file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 258
Create a new Flash document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 259
Add a media component . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 261
Publish your document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 264

Review your task

In this tutorial, you will create a type of application known as a flexible messaging area, or FMA. An FMA is a common type of Flash application used for displaying content that conveys some kind of informational or marketing message to the audience. In this case, the FMA displays photographs of items from the restaurant menu. At Macromedia’s website, an FMA is used to display information about new software products and other advertising messages. These are called flexible messaging areas because they usually occupy an area of the web page that is set aside for content that can change depending on the needs of the business or website. For example, if Café Townsend has a special event planned, the FMA could change to display the details of that event instead of the restaurant’s menu items.
In this tutorial, after examining an existing Flash document, you’ll begin by creating a new Flash document and end by publishing the application for web playback. The tutorial should take approximately 20 to 30 minutes to complete.

Examine the completed application

As you examine the finished version of an application you’ll create, you will also look at the Flash workspace.

In subsequent sections you’ll follow the steps to create the application yourself.

Run the completed application

To better understand the type of application you’ll create as you work through this tutorial, you can look at a completed FLA file version of the application in the Flash authoring tool. FLA files are the files you work on in Flash. You can also play the SWF version of the file in Flash Player. The SWF version is the version of the file that you would publish in a web page.

To play the SWF version of the file in Flash Player:
1. In Flash, select File > Open.
2. Browse to the completed file in the local_sites\cafe_townsend\completed_files\flash folder that you copied to your local disk in Chapter 4, “Tutorial: Setting Up Your Site and Project Files” and double-click video_pod_finished.swf.
   The completed application runs in Flash Player. Click the playback controls at the bottom of the window to watch the video.
3. After viewing the application, close the Flash Player window.
Open the authoring document

It’s helpful to look at the completed authoring FLA file to see how the author designed the application.

To view the authoring version of the file in Flash:
1. In Flash, select File > Open.
2. Browse to the completed file in the local_sites\cafe_townsend\completed files\fash folder that you copied to your local disk in Chapter 4, “Tutorial: Setting Up Your Site and Project Files” and double-click video_pod_finished.swf.
   You now see the completed tutorial application in the Flash authoring environment.
3. After you have the file open, you can explore the Stage, Library panel, and the Timeline.
   ■ On the Stage you will see a FLVPlayback component, which you will learn more about later in this tutorial.
   ■ In the Library panel, you will see a list of symbols, or reusable assets, that the document uses.
   ■ In the Timeline, you will see a representation of how and when those symbols appear on the Stage.
You will learn more about the role of each of these parts of Flash as you complete the tutorial. For detailed information about each of these elements, see “Flash Basics” on page 49.
Encode a video file

The first thing you will do is convert a QuickTime video file (MOV) to a Flash video file (FLV).

To convert the video file:
1. Start the Flash Video Encoder application.
2. Drag the cafe_townsend_chef.mov file from the cafe_townsend folder onto the Flash Video Encoder application window.
3. Click Settings.
4. In the Flash Video Encoding Settings dialog box, select Flash 8 - Medium Quality (400kbps) from the Flash Video Encoding Profile menu. This setting is the default. This action applies only a small amount of compression to the file.

5. Click OK to close the Settings dialog box.

6. Click Start Queue.
   The Flash Video Encoder converts the file and saves it in the same folder as the original cafe_townsend_chef.mov file.
   You are now ready to use the FLV file in a Flash document.

7. Close the Flash Video Encoder application.

Create a new Flash document

Now that you have seen the finished application you will create, it is time to create your own Flash document.

If you haven’t already set up a working folder, you must do so before you begin. For instructions, see “Setting Up Your Site and Project Files.” To learn how to create an application in Flash, you’ll start with the very first step in the process: creating a new file.
Open a new document

Now you're ready to create your own version of the FMA.

To create a new document:
1. Start Flash.
2. Select File > New.
3. In the New Document dialog box, select Flash Document and then click OK.
4. Select File > Save.
5. Name the file video_pod.fla and save the file in the cafe_townsend folder you copied to your hard disk.

As you complete the tutorial, remember to save your work frequently.

Define document properties

Configuring document properties is a common first step in authoring. You can change the document properties at any time, but it is helpful to make certain decisions, such as the Stage size and background color, at the beginning of the process.

Document properties are properties that affect the entire Flash document. You can use the Property inspector to specify these settings.

To define document properties:
1. If the Property inspector isn’t open, select Window > Properties > Properties.

If the Property inspector is not fully expanded, click the white triangle in the lower-right corner.

2. In the Property inspector, click Size.
3. In the Document Properties dialog box, enter the following values:
   - Width: 360
   - Height: 240
4. Click OK.

5. Save your work.

For more information about setting document properties, see “Creating or opening a document and setting properties” in Using Flash.

Add a media component

Next, you will add a media playback component to the Stage. This component will contain the video display and provide playback controls.
To add a media component:
1. Select Window > Components to open the Components panel.
2. In the Components panel, click the plus sign (+) next to the FLV Playback - Player 8 category.
3. Drag an FLVPlayback component to the Stage.
   The new component remains selected on the Stage by default.
4. With the new component still selected on the Stage, enter the following values in the Property inspector:
   - W: 360
   - H: 240
   - X: 0
   - Y: 0
   This makes the component the same size as the Stage and centers it on the Stage.

5. With the new component still selected on the Stage, select Window > Component Inspector to open the Component inspector.

6. In the Component inspector’s Parameters tab, click the `contentPath` parameter.

7. Click the magnifying glass icon that appears next to it.

8. In the Content Path dialog box, enter `cafe_townsend_chef.flv` and click OK.

9. Still in the Component inspector, set the `autoRewind` parameter to `false`.
10. Save your work.

11. To test your document, select Control > Test Movie.

The document plays in the Test Movie window. You can control the playback of the video file with the controls at the bottom of the Stage.

Publish your document

The next step is to publish your FLA file as a SWF file that can be displayed in a web browser.

To publish your Flash document:

1. Select File > Publish.

Flash saves a SWF version of your file and a simple HTML file in the cafe_townsend folder where you saved the video_pod.fla file. Flash also saves a SWF file called ClearOverPlaySeekMute.swf that contains the graphics for the video controller overlay that appears on top of the video. This SWF file must be located in the same folder as the video_pod.swf file in order for the video controls to appear when you play the SWF file.

You can customize the look of these video controls. For more information see “About skinning components” in Using Components.

2. In your web browser, select File > Open.

3. Navigate to the cafe_townsend folder and open the video_pod.html file.

The HTML file opens in the web browser and displays your Flash document.
The next steps

Now that you have completed the Flash video player, you would normally insert the SWF file into a real-world web page.

This illustration demonstrates what a web page containing the video_pod.swf file might look like.

The video_pod.swf file inserted in a web page
In this part, you’ll assemble the Cafe Townsend sample website and add the finishing touches before you publish the website. Then you’ll learn how you can easily maintain a website.

You’ll use Macromedia Dreamweaver 8 to put all the pieces you’ve created together in the Cafe Townsend website and format the website with CSS. Then, you’ll learn how to use Dreamweaver to publish the Cafe Townsend website to a remote server. Finally, when the Cafe Townsend website is finished, you’ll see how you can use Macromedia Contribute for maintenance.

This part contains the following sections:

- Tutorial: Adding Content to Pages ........................................... 269
- Tutorial: Formatting Your Page with CSS .............................. 295
- Tutorial: Publishing Your Site .................................................. 325
- Tutorial: Setting Up Your Website for Contribute Users .......... 333
This tutorial shows you how to add content to web pages in Macromedia Dreamweaver 8. You can add many different kinds of content to web pages, including graphics, Macromedia Flash files, Macromedia Flash Video files, and text, to name a few. After you’ve added content to your pages, you can preview your work in a browser so that you can see what it will look like on the web.

In this tutorial, you will complete the following tasks:

Locate your files ................................................. 269
Review your task ............................................... 271
Insert images ...................................................... 272
Insert and play a Flash file ................................. 279
Insert Flash Video .............................................. 282
Insert text ......................................................... 285
Create links ....................................................... 290
Preview your page in a browser ......................... 292

Locate your files

In this tutorial, you’ll begin with the table-based page layout (index.html) that you created in Chapter 6, “Tutorial: Creating a Table-based Page Layout.” If you did not complete that tutorial, you can either complete it before proceeding, or you can open the finished version of the tutorial and begin with that.

The finished version of the tutorial, table_layout.html, is located in the completed_files/dreamweaver folder, within the cafe_townsend folder that you copied to your hard disk in Chapter 4, “Tutorial: Setting Up Your Site and Project Files.”
You’ll also need to use the assets that you created in Chapter 8, “Tutorial: Creating a Page Banner” and Chapter 9, “Tutorial: Building Your First Flash Application”. If you did not complete those tutorials, you can find the finished assets in the completed_files/flash and completed_files/fireworks folders, within the cafe_townsend folder. The file paths in the instructions that follow will differ slightly if you are using assets from the completed_files folder. For example, if you completed the Fireworks banner graphic tutorial, the finished asset, banner_graphic.jpg, will be in the cafe_townsend/images folder. If you did not complete that tutorial, however, you will need to browse to the completed asset in the cafe_townsend/completed_files/fireworks/ folder.

NOTE

If you begin this tutorial with the completed table_layout.html file, instead of the index.html file from Chapter 6, “Tutorial: Creating a Table-based Page Layout,” some steps and illustrations in the tutorial will not match what you see on your screen.
Review your task

In this tutorial you’ll add assets to the home page for Cafe Townsend, a fictional restaurant. You’ll learn how to add images, a Macromedia Flash file, a Macromedia Flash Video file, and text. When you’re finished, the page will look like this:

You’ll notice that the text on the page is not yet formatted. That’s because you’ll learn how to format the text by using Cascading Style Sheets (CSS) in the next tutorial.
If you've completed the previous tutorials in this book, the required assets for this tutorial are saved in your cafe_townsend root folder. If you haven't been doing the tutorials in order, see “Locate your files” on page 269 for how to locate the required files.

Insert images

After you create your page layout, you are ready to add assets to the page. You’ll start by adding images. You can use several methods to add images to a web page in Dreamweaver. In this section, you’ll add four different images to the index page for Cafe Townsend, using various methods.

Replace the image placeholder

1. In Dreamweaver, open the index.html file that you created in Chapter 6, “Tutorial: Creating a Table-based Page Layout.”

   **NOTE**
   
   If you did not complete Chapter 6, “Tutorial: Creating a Table-based Page Layout,” see “Locate your files” on page 269 for how to proceed.

2. Double-click the image placeholder, banner_graphic, at the top of the page.

3. In the Select Image Source dialog box, navigate to the images folder inside the cafe_townsend folder that you defined as your site root folder.
4. Select the banner_graphic.jpg file and click OK.

![Select Image Source](Image)

Dreamweaver replaces the image placeholder with the banner graphic for Cafe Townsend.

![Cafe Townsend](Image)

NOTE
If you didn’t complete “Creating a Page Banner,” open the banner_graphic.jpg file from the completed_files/fireworks folder in the cafe_townsend root folder.

5. Click once outside the table to deselect the image.

6. Save the page (File > Save).
Insert an image by using the Insert menu

1. Click once inside the third row of the first table (two rows below the banner graphic you just inserted, just above the colored table cells).

2. Select Insert > Image.

3. In the Select Image Source dialog box, navigate to the images folder inside the cafe_townsend folder, select the body_main_header.gif file, and click OK.

NOTE

If the Image Tag Accessibility Attributes dialog box appears, click OK.

A long colored graphic appears in the table row. This might look more like background color for the table cell than a graphic, but if you look closely, you’ll see that the graphic has rounded corners. The rounded corner effect gives the lower portion of your page an interesting appearance after you’ve finished adding all of the assets.
1. Click once inside the last row of the last table on the page (just below the colored table cells).

2. In the Files panel (Window > Files), locate the body_main_footer.gif file (it’s inside the images folder), and drag it to the insertion point in the last table. If the Image Tag Accessibility Attributes dialog box appears, click OK.

3. Click once outside the table and save the page (File > Save).
Insert an image from the Assets panel

1. Click once inside the center column of the three-columned table (the first table cell that is colored light tan).

2. In the Property inspector (Window > Properties), select Center from the Horz pop-up menu, and select Top from the Vert pop-up menu. This aligns the contents of the table cell in the middle of the cell, and pushes the cell’s contents to the top of the cell.

3. Press Enter (Windows) or Return (Macintosh) once to create more space.

NOTE: If you cannot see the Vert or Horz pop-up menus, click the expander arrow in the lower-right corner of the Property inspector.
4. Click the Assets tab in the Files panel, or select Window > Assets. Your site assets appear.

5. If Images view isn’t selected, click Images to view your image assets.

6. In the Assets panel, select the street_sign.jpg file.
7. Do one of the following:
   ■ Drag the street_sign.jpg file to the insertion point in the center table cell.
   ■ Click Insert at the bottom of the Assets panel.

   \[\text{NOTE}\]
   If the Image Tag Accessibility Attributes dialog box appears, click OK.

The street_sign.jpg graphic appears on the page.

8. Click once outside the table to deselect the image.

9. Save the page.
Insert and play a Flash file

Next, you'll insert a Flash file that plays a photographic slide show of Cafe Townsend's featured food items. The Flash file you'll insert is a flexible messaging area—or FMA—file. An FMA is a common type of Flash application that displays an informational message to the audience. The message can change based on the needs of the business. For example, if Cafe Townsend is holding a special event, the FMA could easily change (without affecting the rest of the web page) to display information about the event, instead of featured food items.

To insert the Flash FMA file, you need to insert HTML code that embeds the file in the Dreamweaver page. The easiest way to do this is to insert the SWF file (the exported Flash Movie file) into the page. When you insert a SWF file in Dreamweaver, Dreamweaver writes all of the necessary Flash HTML code for you.

1. With the index.html page open in the Dreamweaver Document window, click once inside the second row of the first table.
   
   This is the table row immediately below the banner graphic you inserted in the previous section.

2. In the Property inspector (Window > Properties), select Center from the Horz pop-up menu, and select Middle from the Vert pop-up menu.
   
   This places the contents of the table cell in the middle of the cell.

   **NOTE**

   If you cannot see the Vert or Horz pop-up menus, click the expander arrow in the lower-right corner of the Property inspector.

   ![Insert and play a Flash file 279](Image 122x263 to 345x354)
3. Select Insert > Media > Flash.

   In the Select File dialog box, browse to the flash_fma.swf file (it’s in the cafe_townsend root folder of your site), select the file, and click OK.

   If the Object Tag Accessibility Attributes dialog box appears, click OK.

   **NOTE**

   If you didn’t complete “Tutorial: Building Your First Flash Application” on page 215, browse to the flash_fma_finished.swf file in the completed_files/flash folder in the cafe_townsend root folder.

A Flash content placeholder, rather than a scene from the FMA itself, appears in the Document window. This is because the HTML code is “pointing” to the SWF file flash_fma.swf. When a user loads the index.html page, the browser plays the SWF file.
4. The Flash content placeholder should remain selected after you insert the SWF file, as long as you don’t click anywhere else on the page. If it’s not selected, select the Flash content placeholder by clicking it.

5. In the Property inspector (Window > Properties), click Play.

![Property inspector](image.png)

**NOTE**

If you cannot see the Flash Play button, click the expander arrow in the lower-right corner of the Property inspector.

Dreamweaver plays the Flash file in the Document window, showing you what site visitors will see when they view the page in a browser.

![Flash player](image.png)

6. In the Property inspector, click Stop to stop playing the Flash file.

7. Save the page.
Insert Flash Video

Next you’ll insert a Flash Video file, using the asset provided.

1. With the index.html page open in the Dreamweaver Document window, click once above the graphic that you placed in the center column of the three-columned table.
   In the previous section, you created some space before you inserted the graphic—this is where you should click.

2. Select Insert > Media > Flash Video.
3. In the Insert Flash Video dialog box, select Progressive Download Video from the Video type pop-up menu.

About Flash Video

The Insert Flash Video command in Dreamweaver lets you insert Flash Video content in your web pages without using the Flash authoring tool. The command inserts a Flash component, which displays the Flash Video content you select, as well as a set of playback controls, when viewed in a browser.

The Insert Flash Video command gives you the following options for delivering video content to your site visitors:

**Progressive Download Video** downloads the Flash Video (FLV) file to the site visitor’s hard disk and then plays it. Unlike traditional “download and play” methods of video delivery, however, progressive download allows the video file to start playing before the download is complete.

**Streaming Video** streams the Flash Video content and plays it on a web page immediately. To enable streaming video on your web pages, however, you must have access to Macromedia Flash Communication Server, the only server that can stream Flash Video content.

For more information about using Flash Video, see “Inserting Flash Video content” in *Using Dreamweaver*.
4. In the URL text box, specify a relative path to the cafe_townsend_home.flv file by clicking Browse, navigating to the cafe_townsend_home.flv file (located in cafe_townsend root folder of your site), and selecting the FLV file.

5. Select Halo Skin 2 from the Skin pop-up menu.
   A preview of the selected skin appears below the Skin pop-up menu. The Skin option specifies the look and feel for the Flash Video component that will contain the Flash Video content.
   For more information on how to select different skins for Flash Video components, see www.macromedia.com/go/flvTutorial.
6. In the Width and Height text boxes, do the following:
   - In the Width text box, type **180**.
   - In the Height text box, type **135** and press Enter (Windows) or Return (Macintosh).

   The value in the Width and Height text boxes specifies the width and height in pixels of the FLV file. You can adjust these values arbitrarily to change the size of the Flash Video on your web page. When you increase the dimensions of a video, the picture quality of the video usually decreases.

7. Leave the default selections for the remaining options:
   - **Constrain** maintains the same aspect ratio between the width and height of the Flash Video component. This option is selected by default.
   - **Auto play** specifies whether to play the video when the web page is opened. This option is deselected by default.
   - **Auto rewind** specifies whether the playback control returns to starting position after the video finishes playing. This option is deselected by default.

"Total with skin" is the width and height of the FLV file plus the width and height of the selected skin.
8. Click OK to close the dialog box and add the Flash Video content to your web page.

The Insert Flash Video command generates a video player SWF file and a skin SWF file that are used to display your Flash Video content on a web page. (You may need to click the Refresh button in the Files panel to see the new files.) These files are stored in the same directory as the HTML file to which you’re adding Flash Video content (in this case, the cafe_townsend root folder). When you upload the HTML page containing the Flash Video content, Dreamweaver uploads these files as dependent files (as long as you click Yes in the Put Dependent Files dialog box).

9. Save the page.

Insert text

Now you'll add some text to the page. You can type text directly in the Dreamweaver Document window, or you can copy and paste text from other sources (such as Microsoft Word or plain text files). Later, you'll use Cascading Style Sheets (CSS) to format the text.
Insert body text

1. In the Files panel, locate the sample_text.txt file (in the cafe_townsend root folder) and double-click the file’s icon to open it in Dreamweaver. You’ll notice that this window is in Code view, and cannot be switched to Design view (the view you’ve been working in until now) because the file is not an HTML file.

2. In the sample_text.txt Document window, press Control+A (Windows) or Command+A (Macintosh) to select all of the text, and then select Edit > Copy to copy the text.

3. Close the sample_text.txt file by clicking the X in the top-right corner of the document.

4. In the index.html Document window, click once inside the third table cell of the three-columned table (the cell to the right of the column that contains the graphic and the Flash video).

5. Select Edit > Paste.
The text from the text file appears in the selected table cell.

Depending on your monitor resolution, the three-columned table widens to accommodate the text. Don’t worry about how this looks right now. In the next tutorial, you’ll learn how to use CSS to format the text so that everything fits in the table appropriately.

6. Make sure the insertion point is still inside the table cell where you just pasted the text. If it isn’t, click inside the table cell.

7. In the Property inspector (Window > Properties), select Top from the Vert pop-up menu. This aligns the text you just pasted to the top of the table cell. If you cannot see the Vert pop-up menu, click the expander arrow in the lower-right corner of the Property inspector.

8. Save the page.
Insert text for a navigation bar

Next you'll insert text for a navigation bar. However, the text won't look like a navigation bar until you format it in the next tutorial.

1. Click once in the first column of the three-columned table (the column that is colored reddish-brown).

2. Type the word **Cuisine**.

3. Press the Spacebar and type **Chef Ipsum**.
4. Repeat the previous step until you’ve entered the following words with a space between each one: **Articles, Special Events, Location, Menu, Contact Us**.

Do not press Enter (Windows) or Return (Macintosh) when you type. Use only the Spacebar to separate words, and let the words wrap naturally. The fixed width of the table cell determines how many words fit on a line.

<table>
<thead>
<tr>
<th>Articles, Special Events, Location, Menu, Contact Us</th>
</tr>
</thead>
<tbody>
<tr>
<td>The name Café Toward's is a culinary haven. We've hired the best chef in the world, who cares deeply about seasonal flavors. We serve exquisite contemporary cuisine that is as delicious as it is beautiful. Café Toward's is located in the heart of San Francisco, where the best restaurants and food are found. If you're looking for extraordinary dining experiences, look no further. We've got it all.</td>
</tr>
</tbody>
</table>
6. In the Property inspector (Window > Properties), select Top from the Vert pop-up menu.
   
   This aligns the text you just typed to the top of the table cell.

   ![Property inspector screenshot]

   **NOTE** If you cannot see the Vert pop-up menu, click the expander arrow in the lower-right corner of the Property inspector.

7. Save your page.

**Create links**

A link is a reference, inserted in a web page, that points to another document. You can turn almost any kind of asset into a link, but the most common kind of link is a text link.

You can create links at any stage of the site-creation process. In this section, you'll create links for the navigation bar, even though you haven't formatted the text into the form of a navigation bar yet.

The cafe_townsend site root folder contains a finished HTML page that you can link to (a menu page for Cafe Townsend). You'll use this page for all of the links in the navigation, even though you would have distinct pages for each of these links if you were building a real site.
1. With the index.html page open in the Document window, select the word *Cuisine* that you typed in the first cell of the three-columned table. Be careful to select the word *Cuisine* only, and not the space after it.

2. In the Property inspector (Window > Properties), click the folder icon next to the Link text box.

3. In the Select File dialog box, browse to the menu.html file (which is in the same folder as the index.html file), and click OK (Windows) or Choose (Macintosh).

4. Click once on the page to deselect the word Cuisine. The Cuisine text is underlined and blue, indicating that it’s now a link.
5. Repeat the previous steps to link each word or set of words that you typed for the navigation. You want to create six more links: one for Chef Ipsum, Articles, Special Events, Location, Menu, and Contact Us.

Link each word or set of words to the menu.html page, and be careful to avoid the space before and after the words or set of words when you create your links. This is only a set of dummy links; in a real-world site, you would link each word in the navigation to its own distinct page.

6. Save your page.

**Preview your page in a browser**

The Design view gives you a rough idea of what your page will look like on the web, but you must preview the page in a browser to see the definitive end result. Though browsers in general produce the same results, each browser version can display HTML pages somewhat differently. Dreamweaver attempts to produce HTML that will look as similar as possible from one browser to another; but sometimes differences can't be avoided. Thus, previewing your work in a browser is the only way for you to see what your site visitors will see after you publish your pages.
1. Make sure the index.html file is open in the Document window.
2. Press the F12 key (Windows) or Option+F12 (Macintosh).

Your primary browser starts if it's not running already and displays the index page.

3. (Optional) Switch back to Dreamweaver to make any necessary changes.

Then save your work and press the F12 key again to make sure your changes took effect.

You now have a web page full of content. The next step is to format some of the content to make it more appealing. In the next tutorial, you'll learn how to use CSS to format the text that you added.
CHAPTER 12

Tutorial: Formatting Your Page with CSS

This tutorial shows you how to format text on your page using Cascading Style Sheets (CSS) in Dreamweaver. CSS provides you with greater control over the appearance of your page by letting you format and position text in ways that HTML cannot.

In this tutorial, you will complete the following tasks:

Locate your files ....................................................... 296
Review your task ....................................................... 297
Learn about CSS ....................................................... 298
Create a new style sheet ............................................. 300
Explore the CSS Styles panel ...................................... 305
Attach a style sheet ................................................... 302
Create a new CSS rule ............................................... 307
Apply a class style to text .......................................... 309
Format the navigation bar text .................................... 310
(Optional) Center the contents of the page ................. 321
Locate your files

In this tutorial, you'll begin with the Cafe Townsend index page to which you added content in Chapter 11, “Tutorial: Adding Content to Pages.” If you did not complete that tutorial, you can either complete it before proceeding, or you can open the finished version of the tutorial and begin with that. The finished version of the tutorial, add_content.html, is located in the completed_files/dreamweaver folder, within the cafe_townsend folder that you copied to your hard drive in Chapter 4, “Tutorial: Setting Up Your Site and Project Files.”

NOTE

If you begin this tutorial with the completed add_content.html file, instead of the index.html file from Chapter 11, “Tutorial: Adding Content to Pages,” certain steps and illustrations in the tutorial will not match what you see on your screen.
Review your task

In this tutorial, you'll use Cascading Style Sheets (CSS) to format the text on the home page for Cafe Townsend, a fictional restaurant. You'll create different kinds of CSS rules to format the body text. You'll also format the link text on the left side of the page to create a navigation bar. When you're finished, your page will look like the following example:
For more information about CSS, proceed to the next section. To start creating CSS right away, proceed to "Create a new style sheet" on page 300.

Learn about CSS

Cascading Style Sheets (CSS) are a collection of formatting rules that control the appearance of content on a web page. When you use CSS to format a page, you separate content from presentation. The content of your page—the HTML code—resides in the HTML file itself, while the CSS rules that define the presentation of the code reside in another file (an external style sheet) or in another part of the HTML document (usually the <head> section). With CSS you have flexibility and control over the exact appearance of your page, from precise positioning of layout to specific fonts and styles.

CSS lets you control many properties that cannot be controlled with HTML alone. For example, you can specify different font sizes and units (pixels, points, and so on) for selected text. By using CSS to set font sizes in pixels, you can also ensure a more consistent treatment of your page layout and appearance in multiple browsers.

A CSS formatting rule consists of two parts—the selector and the declaration. The selector is a term (such as \textit{P}, \textit{H1}, a class name, or an id) that identifies the formatted element, and the declaration defines what the style elements are. In the following example, \textit{H1} is the selector, and everything that falls between the braces ({}) is the declaration:

\begin{verbatim}
H1 {
  font-size: 16 pixels;
  font-family: Helvetica;
  font-weight: bold;
}
\end{verbatim}

The declaration consists of two parts, the property (such as \texttt{font-family}), and the value (such as \texttt{Helvetica}). The preceding example creates a style for \textit{H1} tags: The text for all \textit{H1} tags linked to this style is 16 pixels in size, and uses Helvetica font and bold.
The term *cascading* refers to your ability to apply multiple styles to the same element or web page. For example, you can create one CSS rule to apply color and another rule to apply margins, and apply them both to the same text on a page. The defined styles “cascade” to the elements on your web page, ultimately creating the design you want.

A major advantage of CSS is that it can be updated easily; when you update a CSS rule in one place, the formatting of all of the documents that use the defined style are automatically updated to the new style.

You can define the following types of rules in Dreamweaver:

- **Custom CSS rules**, also called *class styles*, let you apply style attributes to any range or block of text. All class styles begin with a period (.). For example, you could create a class style called `red`, set the `color` property of the rule to red, and apply the style to a portion of already-styled paragraph text.

- **HTML tag rules** redefine the formatting for a particular tag, such as `p` or `h1`. When you create or change a CSS rule for the `h1` tag, all text formatted with the `h1` tag is immediately updated.

- **CSS selector rules** (advanced styles) redefine the formatting for a particular combination of elements, or for other selector forms as allowed by CSS (for example, the selector `td h2` applies whenever an `h2` header appears inside a table cell.) Advanced styles can also redefine the formatting for tags that contain a specific `id` attribute (for example, the styles defined by `#myStyle` apply to all tags that contain the attribute-value pair `id="myStyle"`).

For more information, see “About text formatting in Dreamweaver” in *Using Dreamweaver*. 
Create a new style sheet

First, you’ll create an external style sheet that contains a CSS rule that defines a style for paragraph text. When you create styles in an external style sheet, you can control the appearance of multiple web pages from a central location, instead of setting styles on each individual web page.

1. Select File > New.
2. In the New Document dialog box, select Basic page in the Category column, select CSS in the Basic Page column, and click Create.

A blank style sheet appears in the Document window. The Design view and Code view buttons are disabled. CSS style sheets are text-only files—theyir contents are not meant to be viewed in a browser.
Create a new style sheet

3. Save the page (File > Save) as cafe_townsend.css.

   When you save the style sheet, make sure you save it in the cafe_townsend folder (the root folder of your website).

4. Type the following code in the style sheet:

   ```css
   p{
       font-family: Verdana, sans-serif;
       font-size: 11px;
       color: #000000;
       line-height: 18px;
       padding: 3px;
   }
   ```

   As you type, Dreamweaver uses code hints to suggest options for completing your entry. Press Enter (Windows) or Return (Macintosh) when you see the code you want to let Dreamweaver finish the typing for you.

---

More about CSS rules

CSS rules can reside in the following locations:

**External CSS style sheets** are collections of CSS rules stored in a separate, external .css file (not an HTML file). The .css file is linked to one or more pages in a website by using a link in the head section of a document.

**Internal (or embedded) CSS style sheets** are collections of CSS rules that are included in a style tag in the head portion of an HTML document. For example, the following example defines the font size for all text in the document formatted with the paragraph tag:

```html
<head>
    <style>
        p{
            font-size:80px
        }
    </style>
</head>
```

**Inline styles** are defined within specific instances of tags throughout an HTML document. For example,

```html
<p style="font-size: 9px"> defines the font size for only the paragraph formatted with the tag that contains the inline style.
```

Dreamweaver renders most style attributes that you apply and displays them in the Document window. You can also preview the document in a browser window to see styles applied. Some CSS style attributes render differently in Microsoft Internet Explorer, Netscape Navigator, Opera, and Apple Safari.
Don’t forget to include a semicolon at the end of each line, after the property values.

When you’re finished, the code should look like following example:

```
5. Save the style sheet.
Next you’ll attach the style sheet to the index.html page.

Attach a style sheet

When you attach a style sheet to a web page, the rules defined in the style sheet are applied to the corresponding elements on the page. For example, when you attach the cafe_townsend.css style sheet to the index.html page, all paragraph text (text formatted with the `<p>` tag in the HTML code) is formatted according to the CSS rule you defined.
```
1. In the Document window, open the Cafe Townsend index.html file. (You can click its tab if it’s already open.)

2. Select the text of the first paragraph that you pasted into the page in Chapter 11, “Tutorial: Adding Content to Pages”.

3. Look in the Property inspector and make sure that the paragraph is formatted with the paragraph tag.
If the Format pop-up menu in the Property inspector says “Paragraph,” the paragraph is formatted with the paragraph tag. If the Format pop-up menu in the Property inspector says “None,” or something else, select Paragraph to format the paragraph.

4. Repeat step 3 for the second paragraph.
5. In the CSS Styles panel (Window > CSS Styles), click the Attach Style Sheet button in the lower-right corner of the panel.

![CSS Styles panel](image)

6. In the Attach External Style Sheet dialog box, click Browse and browse to the cafe_townsend.css file that you created in the previous section.

7. Click OK.

The text in the Document window is formatted according to the CSS rule in the external style sheet.
Explore the CSS Styles panel

The CSS Styles panel lets you track the CSS rules and properties that affect a currently selected page element, or the rules and properties that affect an entire document. It also lets you modify CSS properties without opening an external style sheet.

1. Make sure the index.html page is open in the Document window.

2. In the CSS Styles panel (Window > CSS Styles), click All at the top of the panel and examine your CSS rules.

   In All mode, the CSS panel shows you all of the CSS rules that apply to the current document, whether those rules are in an external style sheet, or in the document itself. You should see two main categories in the All Rules pane: a <style> tag category and a cafe_townsend.css category.

3. Click plus (+) to expand the <style> tag category if it isn’t already expanded.

4. Click the body rule.

   The background-color property with a value of #000000 appears in the Properties pane below.

   ![CSS Styles panel](image)

   You may need to collapse another panel, such as the Files panel, to see the full length of the CSS Styles panel. You can also alter the length of the CSS Styles panel by dragging the borders between the panes.
You set the background color for the page in Chapter 6, “Tutorial: Creating a Table-based Page Layout” by using the Modify Page Properties dialog box. When you set page properties in this manner, Dreamweaver writes a CSS style that is internal to the document.

5. Click plus (+) to expand the cafe_townsend.css category.

6. Click the p rule.

All of the properties and values that you defined in the external style sheet for the p rule appear in the Properties pane below.

7. In the Document window, click once anywhere in either of the two paragraphs that you just formatted.

8. In the CSS Styles panel, click Current at the top of the panel and examine your CSS styles. In Current mode, the CSS panel shows you a summary of properties for the current selection. The properties shown correspond to the properties for the p rule in the external style sheet.

In the next section, you’ll use the CSS Styles panel to create a new rule. Using the CSS Styles panel to create a new rule is much easier than typing the rule out by hand, as you did when you initially created the external style sheet.
Create a new CSS rule

In this section you'll use the CSS Styles panel to create a custom CSS rule, or class style. Class styles let you set style attributes for any range or block of text, and can be applied to any HTML tag. For more information on different types of CSS rules, see “Learn about CSS” on page 298.

1. In the CSS Styles panel, click New CSS Rule in the lower-right corner of the panel.

2. In the New CSS Rule dialog box, select Class from the Selector Type options. It should be selected by default.

3. Enter .bold in the Name text box.

Make sure that you type the period (.) before the word “bold.” All class styles must start with a period.
4. Select cafe_townsend.css from the Define In pop-up menu. It should be selected by default.

5. Click OK.

   The CSS Rule Definition dialog box appears, indicating that you are creating a class style called .bold in the cafe_townsend.css file.

6. In the CSS Rule Definition dialog box, do the following:
   - In the Font text box, enter **Verdana, sans-serif**.
   - In the Size text box, enter 11 and select pixels from the pop-up menu immediately to the right.
   - In the Line Height text box, enter 18 and select pixels from the pop-up menu immediately to the right.
   - Select bold from the Weight pop-up menu.
   - Enter #990000 in the Color text box.
7. Click OK.
8. Click All at the top of the CSS Styles panel.
9. Click the plus (+) button next to the cafe_townsend.css category if the category isn’t already expanded.

You’ll see that Dreamweaver added the .bold class style to the list of rules defined in the external style sheet. If you click the .bold rule in the All Rules pane, the rule’s properties appear in the Properties pane. The new rule also appears in the Style pop-up menu in the Property inspector.

Apply a class style to text

Now that you’ve created a class rule, you’ll apply it to some paragraph text.
1. In the Document window, select the first four words of text in the first paragraph: Cafe Townsend’s visionary chef.
2. In the Property inspector (Window > Properties), select bold from the Styles pop-up menu.

The bold class style is applied to your text.
3. Repeat step 2 to apply the bold class style to the first four words of the second paragraph.

Café Townsend’s visionary chef and founder leads the way in a culinary revolution. Praised by many to be the best chef in the world today, Chef Isum blends earthy seasonal flavors and bold ingredients to create exquisite contemporary cuisine.

The name Café Townsend comes from our first restaurant, located in a historic building on Townsend Street in San Francisco, where we opened the doors in 1992. We’ve replicated the elegant interior, exceptional service, and world class cuisine in our restaurants around the country.

4. Save your page.

Format the navigation bar text

Next you’ll use CSS to apply styles to the link text for the navigation bar. Many web pages use images of colored rectangles with text inside them to create a navigation bar, but with CSS, all you need is linked text and some formatting. By using the display: block property and setting a width to the block, you can effectively create the rectangles without the use of separate images.
Create a new rule for the navigation

1. Open the cafe_townsend.css file if it isn’t already open, or click on its tab to see it.

2. Define a new rule by typing the following code in the file, after the .bold class style:

```css
.navigation {
}
```

This is an empty rule.
The code in the file should look something like the following example:

```css
/* CSS Document */

::selection {text-decoration:underline;}

:root {font-family: Verdana, sans-serif;
  font-size: 11px;
  line-height: 18px;
  padding: 0px;
}

.bold {
  font-family: Verdana, sans-serif;
  font-size: 11px;
  line-height: 18px;
  font-weight: bold;
  color: $999999;
}

.navigation {
}
```

3. Save the cafe_townsend.css file.
   Next you’ll use the CSS Styles panel to add properties to the rule.

4. Open the index.html file if it isn’t already open.
5. In the CSS Styles panel, make sure All mode is selected, select the new .navigation rule and click Edit Style in the lower-right corner of the panel.
6. In the CSS Rule Definition dialog box, do the following:
   - Enter **Verdana, sans-serif** in the Font text box.
   - Select 16 from the Size pop-up menu, and select pixels from the pop-up menu immediately to the right of the Size pop-up menu.
   - Select Normal from the Style pop-up menu.
   - Select None from the Decoration list.
   - Select Bold from the Weight pop-up menu.
   - Enter **#FFFFFF** in the Color text box.

![CSS Rule definition for .navigation](image)

7. Click OK.

Now you'll use the CSS Styles panel to add a few more properties to the .navigation rule.

---

**TIP**

For more information about any CSS property, check the O'Reilly reference guide included with Dreamweaver. To display the guide, select Help > Reference and select O'Reilly CSS Reference from the pop-up menu in the Reference panel.
8. In the CSS Styles panel, make sure the .navigation rule is selected and click Show List View.

   ![CSS Styles Panel]

List view reorganizes the Properties pane to display an alphabetical list of all available properties (in contrast to Set Properties view, the previous view, which shows only those properties you've already set).

9. Click in the column to the right of the background-color property.
   To see the full wording of a property, hold the mouse over the property.
10. Enter \#993300 as the hexadecimal value and press Enter (Windows) or Return (Macintosh).

11. Locate the display property (you might need to scroll down), click once in the column to the right, and select block from the pop-up menu.

12. Locate the padding property, click once in the column to the right, enter 8px as the value, and press Enter (Windows) or Return (Macintosh).

13. Locate the width property, click once in the column to the right, enter 140 in the first text box, select pixels from the pop-up menu, and press Enter (Windows) or Return (Macintosh).

TIP
To see how your work affects the external style sheet, keep the cafe_townsend.css file open in the Document window while you work. When you make a selection in the CSS Styles panel, you’ll see that Dreamweaver writes the CSS code in the style sheet at the same time.
14. Click Show Set Properties so that only your set properties appear in the Properties pane.

![CSS Styles Panel]

15. Click on the cafe_townsend.css file to display it. You’ll see that Dreamweaver has added all of the properties you specified to the file.

16. Save the cafe_townsend.css file and close it.

You’ve now created a rule to format the navigation bar text. Next you’ll apply the rule to the selected links.
Apply the rule

1. With the index.html page open in the Document window, click the word Cuisine so that the insertion point is somewhere in the word.

2. In the tag selector, click the rightmost <a> tag.
   This action selects all of the text for the specified <a> tag, or link.

3. In the Property inspector (Window > Properties), select navigation from the Style pop-up menu.
   In the Document window, the appearance of the Cuisine text changes entirely. The text is now formatted as a navigation bar button, according to the properties of the .navigation rule that you defined in the previous section.
4. Repeat step 1 through 3 for each of the individual links in the navigation bar.

You must assign a navigation class style to each <a> tag or link, so it's important that you use the tag selector to select each link individually, and then assign the class styles one at a time.

If you're having trouble formatting the link text, make sure that a space (not a return) is between each linked word or words. Also make sure that the space between two links is not itself linked. If it is, carefully select the linked space, clear the Link text box in the Property inspector, and press Enter (Windows) or Return (Macintosh).

5. When you've finished formatting all of the words for the navigation bar, save the page, and then preview your work in a browser (File > Preview in Browser).

You can click on the links to make sure they work.
Add a rollover effect

Now you’ll add a rollover effect so that the background color of the navigation bar blocks change whenever the mouse pointer passes over one of the links. To add a rollover effect, add a new rule that contains the :hover pseudo-class.

1. Open the cafe_townsend.css file.
2. Select the entire .navigation rule.

![CSS Code Example]

3. Copy the text (Edit > Copy).

---

**About the :hover pseudo-class** A pseudo-class is a means of affecting certain elements in an HTML document, based not on the HTML code of the document itself, but on other external conditions applied by the web browser. Pseudo-classes can be dynamic, in the sense that an element on the page may acquire or lose the pseudo-class while a user interacts with the document.

The :hover pseudo-class affects a change in a formatted page element when the user holds the mouse over the element. For example, when the :hover pseudo-class is added to the .navigation class style (.navigation:hover) to create a new rule, all text elements that the .navigation rule formats change according to the .navigation:hover rule’s properties.
4. Click once at the end of the rule and press Enter (Windows) or Return (Macintosh) a few times to create some space.

```css
}/*bold*/
  font-family: Verdana, sans-serif;
  font-size: 14px;
  line-height: 16px;
  font-weight: bold;
  color: #000000;
/*navigation*/
  font-family: Verdana, sans-serif;
  font-size: 16px;
  font-style: normal;
  font-weight: bold;
  color: #FFFFFF;
  text-decoration: none;
  background-color: #9933CC;
  display: block;
  padding: 0 px;
  width: 144px;
}/*navigation*/
```

5. Paste (Edit > Paste) the copied text in the space you just created.

6. Add the :hover pseudo-class to the pasted .navigation selector, as follows:

```css
/*navigation:hover*/
  font-family: Verdana, sans-serif;
  font-size: 16px;
  font-style: normal;
  font-weight: bold;
  color: #FFFFFF;
  text-decoration: none;
  background-color: #9933CC;
  display: block;
  padding: 0 px;
  width: 144px;
```
7. In the new .navigation:hover rule, replace the current background-color (#993300) with #D03D03.

```css
.navigation:hover {
  font-family: Verdana, sans-serif;
  font-size: 16px;
  font-style: normal;
  font-weight: bold;
  color: #FFFFF;
  text-decoration: none;
  background-color: #D03D03;
  display: block;
  padding: 8 px;
  width: 140px;
}
```

8. Save the file and close it.

9. Open the index.html file in the Document window and preview the page in a browser (File > Preview in Browser).

   When you hold the mouse over any of the links, you can see the new rollover effect.

**(Optional) Center the contents of the page**

Lastly, you'll use the tag selector to select all of the HTML in the document, and center the document's contents.

**NOTE**

Some browsers (such as Internet Explorer 6), center the page’s text within the context of the table cells when you use the method described in this section. If you don’t like how this looks when you preview the page in the browser, you might want to skip this section, and leave the contents of your page aligned left.
1. With the index.html page open in the Document window, click the \( <\text{body}> \) tag in the tag selector.

Clicking the \( <\text{body}> \) tag selects everything between the open and close \( <\text{body}> \) tags in the Document window. To see the selection, click Code view at the top of the Document window.
2. In the Property inspector (Window > Properties), click the Align Center button.

Dreamweaver inserts CSS <div> tags that center the body content of the page. In Design view, a dotted line borders the area that the <div> tags center.

3. Save the page.

Your page is now finished. The last task of building your website is to publish the page. To publish the page, you must define a folder on a remote site and upload your files to that folder. For instructions, continue to the next tutorial.
CHAPTER 13

Tutorial: Publishing Your Site

This tutorial shows you how to set up a remote site with Macromedia Dreamweaver 8 and publish your web pages. A remote site is usually a place on a remote computer, running a web server, that holds copies of your local files. Users access the remote site running on the web server when they view your pages in a browser.

In this tutorial, you will complete the following tasks:

Learn about remote sites .................................................. 325
Define a remote folder .................................................... 326
Upload your local files ..................................................... 329
Troubleshoot the remote folder setup (optional) .............. 330

Learn about remote sites

After you create a website, the next step is to publish it by uploading the files to a remote folder. A remote folder is where you store your files for testing, production, collaboration, and publication (depending on your environment). Dreamweaver refers to this folder as your \textit{remote site}.

Before you can proceed, you must have access to a remote web server—such as your ISP's server, a server owned by the client you're working for, an intranet server within your company, or an Internet Information Services (IIS) server on a Windows computer. If you don't already have access to such a server, contact your ISP, your client, or your system administrator.

Alternatively, you can run a web server such as IIS (Windows) or Apache (Macintosh) on your local computer. For more information about setting up a web server on your local computer, see "Installing a Web Server" in the extended Getting Started with Dreamweaver Help or PDF. The PDF is available on the Macromedia website at \url{www.macromedia.com/go/dw_documentation}. 
The procedures described in this tutorial work best if your remote root folder is empty. If your remote site already contains files, create an empty folder in your remote site (on the server), and use that empty folder as your remote root folder.

You also need to have a local site defined before you proceed. For more information, see “Tutorial: Setting Up Your Site and Project Files” on page 137.

For more information about Dreamweaver sites, see Chapter 2, “Setting Up a Dreamweaver Site” in Using Dreamweaver.

Define a remote folder

Now you’ll set up a remote folder so that you can publish your web pages. The remote folder often has the same name as the local folder because your remote site is usually an exact duplicate of your local site. That is, the files and subfolders that you post to your remote folder are copies of the files and subfolders that you create locally.

1. On your remote server, create an empty folder inside the web root folder for the server.

   Name the new empty folder cafe_townsend (the same name as your local root folder).
Creating a remote folder with Dreamweaver  

If Dreamweaver is your only means of access to the remote server, you won’t be able to create an empty folder on the remote server until you’ve completed the remote settings in Dreamweaver and established a connection. If that’s the case, you can either define your host directory as your remote folder, or you can create a remote folder after you’ve established a connection with the server. In either case, continue with the instructions in this tutorial until you’re connected to a remote server. After you’ve established a connection, you can use the Dreamweaver Files panel to create a new remote folder.

When you establish a connection with a remote server, the Files panel displays all of the files on the remote server in Remote view (just as it displays all of the local files on your computer in Local view). To display Remote view, select Remote view from the pop-up menu at the top of the Files panel, or click Expand/Collapse in the Files panel toolbar. When you click Expand/Collapse, the Files panel displays both Local view and Remote view simultaneously.

To add an empty folder in Remote view, first display Remote view using one of the methods described earlier. (If you don’t see your connection initially, click Refresh in the Files panel toolbar.) After you see that you’re connected to your web server, right-click (Windows) or Control-click (Macintosh) in Remote view and select New Folder.

About...

For more information, see Chapter 4, “Managing Your Files” in Using Dreamweaver.

2. In Dreamweaver, select Site > Manage Sites.
3. In the Manage Sites dialog box, select the Cafe Townsend site.
   If you did not define the Cafe Townsend site, create a local folder for the site before you proceed. For more information, see “Tutorial: Setting Up Your Site and Project Files” on page 137.
4. Click Edit.
5. In the Site Definition dialog box, click the Advanced tab if the Advanced settings aren’t showing.
6. Select Remote Info from the Category list on the left.
7. Select an Access option.

The most common methods for connecting to a server on the Internet are FTP and SFTP; the most common method for connecting to a server on your intranet, or to your local computer if you're using that as a web server, is Local/Network. If you aren't sure what to select, ask the server's system administrator.

For more information, click Help in the dialog box.

8. If you selected FTP, enter the following options:
   - Enter the host name of the server (such as ftp.macromedia.com).
   - In the Host directory text box, enter the path on the server from the FTP root folder to the remote site's root folder (cafe_townsend). If you're not sure of the path, consult your system administrator. In many cases, this text box should be left blank.
   - Enter your user name and password in the appropriate text boxes.
   - If your server supports SFTP, select the Use Secure FTP (SFTP) option.
   - Click Test to test your connection.
   - If the connection is unsuccessful, consult your system administrator.

For more information, click Help in the dialog box.

9. If you selected Local/Network, click the folder icon next to the text box and browse to the remote site's root folder.

For more information, click Help in the dialog box.

10. Click OK.

   Dreamweaver creates a connection to the remote folder.

11. Click Done to close the Manage Sites dialog box.
Upload your local files

After you set up your local and remote folders, you can upload your files from your local folder to the web server. To make your pages publicly accessible, you must upload them even if the web server is running on your local computer.

1. In the Files panel (Window > Files), select the site’s local root folder (cafe_townsend).

2. Click the blue Put Files arrow icon in the Files panel toolbar.

3. When Dreamweaver asks if you want to put the entire site, click OK.

   Dreamweaver copies all of the files to the remote folder you defined in “Define a remote folder” on page 326. This operation may take some time, as Dreamweaver must upload all of the files in the site.

4. Open your remote site in a browser to make sure all of the files uploaded correctly.
Troubleshoot the remote folder setup (optional)

A web server can be configured in many ways. The following list provides information about some common issues you may encounter in setting up a remote folder, and how to resolve them:

- The Dreamweaver FTP implementation may not work properly with certain proxy servers, multilevel firewalls, and other forms of indirect server access.
  
  If you encounter problems with FTP access, ask your local system administrator for help.

- For the Dreamweaver FTP implementation, you must connect to the remote system's root folder. (In many applications, you can connect to any remote directory, and then navigate through the remote file system to find the directory you want.)
  
  Be sure that you indicate the remote system's root folder as the host directory.

  If you have problems connecting, and you've specified the host directory using a single slash (/), you might need to specify a relative path from the directory you are connecting to and the remote root folder.

  For example, if the remote root folder is a higher-level directory, you may need to use ../../../ to specify the host directory.

- File and folder names that contain spaces and special characters often cause problems when transferred to a remote site.

  Use underscores in place of spaces, and avoid special characters in file and folder names wherever possible. In particular, colons (:), slashes (/), periods (.), and apostrophes (') in file or folder names can cause problems. Special characters in file or folder names may also sometimes prevent Dreamweaver from creating a site map.

- If you encounter problems with long filenames, rename them with shorter names. On Macintosh, filenames cannot be more than 31 characters long.
Many servers use symbolic links (UNIX), shortcuts (Windows), or aliases (Macintosh) to connect a folder on one part of the server's disk with another folder elsewhere. For example, the public_html subdirectory of your home directory on the server may really be a link to another part of the server entirely. In most cases, such aliases have no effect on your ability to connect to the appropriate folder or directory; however, if you can connect to one part of the server but not to another, there may be an alias discrepancy.

- If you encounter an error message such as “cannot put file,” your remote folder may be out of space. For more detailed information, look at the FTP log.

**NOTE**

In general, when you encounter a problem with an FTP transfer, examine the FTP log by selecting Site > Advanced > FTP Log.
CHAPTER 14
Tutorial: Setting Up Your Website for Contribute Users

Macromedia Contribute enables you and your users to maintain, distribute, and control content on the web. You can easily connect to your website with Contribute, and send connection keys to set up your users so that they can edit the website. And by establishing user roles, you can give your users as much or as little editing power as you want.

In this tutorial, you will complete the following tasks:

- Review your task .................................................. 334
- Learn about website connections and administration ...... 334
- Connect to a website as an administrator ..................... 335
- Create a user role ................................................. 337
- Edit a role’s settings .............................................. 338
- Set administrative settings ....................................... 336
- Create a connection key and send it to users ............... 340
Review your task

In this tutorial you’ll use Contribute to connect to your website and send connection keys so that others can edit the website. You’ll also set up user roles and edit role settings to control the level of editing that users can do on the website.

If you haven’t already set up a remote site in Dreamweaver and uploaded your local files, you must do so before you begin. The remote site you define must be on a web server. For instructions, see “Define a remote folder” on page 326 and “Upload your local files” on page 329.

Learn about website connections and administration

A Contribute website connection is defined when you provide the web address and path to point Contribute to the folder that contains your website. A Contribute website is made up of the folder you connect to and all the folders and files within it. You can make multiple connections to different websites or within the same physical website. Each connection you create is treated as a separate website in Contribute.

When you manually establish a website connection, you can become the website’s administrator. As a Contribute administrator, you set up Contribute users and help them use Contribute to maintain the website. You can set folder and user permissions, which determine who can edit website content and what they can edit.

Contribute users maintain the website using a browse-edit-publish workflow. You can embed your website connection settings in a connection key file to send to users so that they can easily connect to the website without knowing any technical information about the physical location of the website.
Connect to a website as an administrator

After you create the Cafe Townsend website, you can use Contribute to connect to the website.

1. In Contribute, select Edit > My Connections (Windows) or Contribute > My Connections (Macintosh).
   The My Connections dialog box enables you to create and manage your Contribute connections.

2. In the My Connections dialog box, click the Create button.

3. In the Connection Wizard (Windows) or Connection Assistant (Macintosh), click Next.
   This wizard or assistant guides you through setting up a new website connection.

4. Enter the web address for the Cafe Townsend website, and then click Next.
   This is the URL you enter in a browser to view the website—for example, www.mysite.com.

5. Select an access method for connecting to the website.

6. Enter the path for the server where you created the remote site for the Cafe Townsend website, and then click Next.

7. Enter your name and e-mail address, and then click Next.

8. On the Summary screen, review the connection settings to verify that they’re correct, and click Done (Windows) or Finish (Macintosh) to complete the connection.
   Contribute creates a connection to the Cafe Townsend website.
   After Contribute has successfully created a connection to the website, the Connection Wizard or Connection Assistant closes, and the main page of the website appears in the Contribute browser.
Set administrative settings

Now that you’ve connected to the Cafe Townsend website and established yourself as an administrator, you can set some administrative settings. Contribute administrative settings are a collection of settings that apply to all users of your website, not just specific roles.

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the Cafe Townsend website from the submenu.

2. Click Yes in the dialog box that asks whether you want to become the website administrator, enter and confirm an administrator password for the website, and click OK.

3. In the Administer Website dialog box, select the Rollbacks category on the left.

4. Select Enable Rollbacks to activate rollbacks. Rollback pages are backup versions of each web page published with Contribute.

5. Increase the number of versions you want to keep of each page from 3 to 5.

In this tutorial you’re only changing Rollbacks settings, but there are several other categories with more administrative settings. Leave the Administer Website dialog box open. Next, you’ll create a user role.
Create a user role

When Contribute users connect to a website, they are prompted to indicate which role they belong to. You’ll create a role for chefs who need to update the menu on the Cafe Townsend sample website.

1. Select Edit > Administer Websites (Windows) or Contribute > Administer Websites (Macintosh), and then select the Cafe Townsend website from the submenu.

2. Click Yes in the dialog box that asks whether you want to become the website administrator, enter and confirm an administrator password for the website, and click OK.

In the Administer Website dialog box, you see that Contribute has three roles by default: Administrator, Publisher, and Writer.

You’re going to create a new role for the Cafe Townsend chefs.

3. Click the Create New Role button.

4. In the Create New Role dialog box, select the Publisher role from the list under Create New Role from Copy Of.

Selecting an existing role as a basis for a new role lets you reuse the selected role’s settings. You can modify the new role’s settings as needed.

5. In the text field, type Chef as the name of your new role, and then click OK.

Now the Chef role appears in the list of role names in the Administer Website dialog box.

Leave this dialog box open. Next, you’ll modify settings for the Chef role.
Edit a role’s settings

Now you’re ready to determine which folders the users who have the Chef role can access and what kind of modifications those users can make to the Cafe Townsend website.

1. In the Administer Website dialog box, select the Chef role in the list of role names.

2. Click the Edit Role Settings button.

3. In the Edit “Chef” Settings dialog box, in the General category, do the following:
   a. Select Allow Users to Publish Files to enable the chef to publish the menu after making changes.
   b. In the Role Description text box, type Users in this role can edit and publish the menu.

4. Select the Folder/File Access category from the list on the left.

5. Select Only Allow Editing Within These Folders. If a warning dialog box appears, click OK to continue.

6. Click the Add Folder button.

7. In the Choose Folder dialog box, double-click the Cafe Townsend folder in the window, double-click the images folder, and then double-click the menu_images folder.
8. Click the Select menu_images button at the bottom.

9. In the Edit “Chef” Settings dialog box, select the Editing category from the list on the left.

10. In the Other Editing Options section, select Require ALT Text for Images.

11. Select the Shared Assets category from the list on the left.

   Shared assets are commonly used images, Macromedia Flash content, or Macromedia Dreamweaver library items. Making these items shared assets allows users in the Chef role to easily find and insert them in the menu.

12. Click the Add button, and then select Image from the pop-up menu.

13. In the Choose Image dialog box, double-click the Cafe Townsend folder in the window; double-click the images folder, and then double-click the menu_images folder.

14. Click the Select All Files in This Folder button.

15. Click OK.

16. In the Shared Asset Properties dialog box, do the following:

   a. Click in the ALT text column beside the special_pasta image.

   b. Type Image of Friday pasta special.
c. Next, click in the ALT text column beside the special_salmon image.

d. Type Image of Saturday salmon special.

e. Next, click in the ALT text column beside the special_vegetarian image.

f. Type Image of Sunday vegetarian special.

g. Click OK.

17. In the Edit “Chef” Settings dialog box, click OK to save your changes for the Chef role.

   The dialog box closes, returning you to the Administer Website dialog box.

Leave this dialog box open. Next, you’ll create a connection key so that users in the Chef role can connect to and edit the website.

**Create a connection key and send it to users**

Contribute enables you to embed your website connection information in a connection key that you can send to other users. The users simply double-click the connection key file to connect to the website and begin editing.

1. In the Administer Website dialog box, click the Send Connection Key button.

2. In the Connection Wizard, select Yes to create a connection key with the same connection information as your current connection.

3. Click Next.

4. Select the Chef role, and then click Next.

5. Select Save to Local Machine.

   For the purposes of this tutorial, you will save the connection key and not actually send it to any users. If you select the e-mail option, Contribute opens your e-mail application so that you can send the key to users.
6. Enter a password that you can remember, and then enter the
   password again.
   If you were actually going to make this key available to users, you
   would need to inform them of this password.

7. Click Next.

8. Review the Summary screen, and then click Done.

9. In the Export Connection Key dialog box, navigate to your desktop.

10. Click Save.

11. In the Administer Website dialog box, click Close to exit the dialog box
    and save your changes.

Now you've set up Contribute to edit the Cafe Townsend website and
created a user role. And you've seen how easy it is to create connection keys
to send to users so that they can help you maintain your website.
Index

A
accessibility in the Flash authoring environment 95
accessing documentation
  Contribute 29
  Contribute and FlashPaper 29
  Dreamweaver 18
  Fireworks 27
  Flash 21
Actions panel (in Flash) 83
activating Studio products 16
alternative text 175
animation, frame-by-frame and tweened 129
applications, sample 252
arranging the Help panel 40
Assets panel 277
assets, adding to a site 139
authoring environment accessibility 95

B
background color, setting 177
bitmap images, anti-aliasing 90
Bitmaps on Clipboard preference (Windows only) 90
Blank Keyframe command (in Flash) 67
browsing
  pages 117
  switching to editing from 117
building an application, tutorial 255

C
Cascading Style Sheets (CSS)
  about 298
  attaching 302
  creating 300
  CSS Styles panel 56
  formatting with 295–323
  Center Frame button 65
certification and training 252
Clear Keyframe command (in Flash) 69
Clipboard preferences (in Flash) 90
Code view
  Design view and changing between 49
  displaying text files 286
Coding toolbar (in Dreamweaver) 53
color picker 179
column header menu 168
context menus 95
context-sensitive help 38
Contribute
  browser toolbar 114
  editor toolbar 114
  How Do I panel 115
  image-editing toolbar 115
  Pages panel 115
  sidebar 115
  text-formatting toolbar 114
toolbars 114
tutorial 333
workspace 112
Contribute sidebar
  expanding and collapsing 115
  How Do I panel in 116
  Pages panel 115
  panels 115
  resizing 115
Copy Frames command (in Flash) 68
copying
  layer folder contents 73
  layers 73
CSS Styles panel 56, 305
CSS. See Cascading Style Sheets
Customize Shortcuts dialog box 93
Customize Toolbar command (in Flash) 77
Index

D
Default Layout command, for panels 86
deleting
  frames or keyframes 68
  layers and layer folders 74
Design view 49
discussing help in LiveDocs 39
Document toolbar (in Dreamweaver) 49
Document window
  basics 48
  page size and download time 51
  status bar 50
  tag selector 50
  title bar 48
  Window Size pop-up menu 51
document, creating new 218, 259
document-editing mode 78
documents
  saving 165
downloading, setting the time 51
Dreamweaver
  Assets panel 130
  assets, assembling 130
  Cascading Style Sheets (CSS) 127
  deploying files 132
  editing Fireworks images in
    files 44
    page layouts 127
    site testing 131
    workspace 45
Dreamweaver
  Assets panel 130
  assets, assembling 130
  Cascading Style Sheets (CSS) 127
  deploying files 132
  editing Fireworks images in
    files 44
    page layouts 127
    site testing 131
    workspace 45
Flash
  animation 129
  inserting SWF files 279
  playing content in Dreamweaver 281
  Property inspector 81
  rich media, creating 129
  Timeline 62–69
  workspace 59
Flash documentation, accessing 21
Flash online resources, accessing 26
Flash Video, inserting 282
FlashPaper
  features 118
  files, about 118
  workspace 118
FlashPaper SWF files
  navigating 120
  opening in new browser 120
  printing 119
  resizing 120
  searching 119
  selecting text 119
See also SWF files
FMA (flexible messaging area) 11
Font Mapping Default preference 91
fonts, changing size in help 34
Frame command (in Flash) 67
Frame View button (in Flash) 66
Frame View menu (in Flash) 66
frames
  centering the playhead in 65
  changing the view 65
  converting keyframes into 69
  copying and pasting 68
  copying by dragging 68
  displayed in Timeline 62
  displaying 64
  displaying contents 61
  displaying thumbnails 65, 66
  dragging in Timeline 68
  editing in Timeline 66
  inserting 67
  removing 68
FreeHand assets, creating 128
FreeHand Text on Clipboard preference 90

D
Default Layout command, for panels 86
deleting
  frames or keyframes 68
  layers and layer folders 74
Design view 49
discussing help in LiveDocs 39
Document toolbar (in Dreamweaver) 49
Document window
  basics 48
  page size and download time 51
  status bar 50
  tag selector 50
  title bar 48
  Window Size pop-up menu 51
document, creating new 218, 259
document-editing mode 78
documents
  saving 165
downloading, setting the time 51
Dreamweaver
  Assets panel 130
  assets, assembling 130
  Cascading Style Sheets (CSS) 127
  deploying files 132
  editing Fireworks images in
    files 44
    page layouts 127
    site testing 131
    workspace 45
Dreamweaver
  Assets panel 130
  assets, assembling 130
  Cascading Style Sheets (CSS) 127
  deploying files 132
  editing Fireworks images in
    files 44
    page layouts 127
    site testing 131
    workspace 45
Flash
  animation 129
  inserting SWF files 279
  playing content in Dreamweaver 281
  Property inspector 81
  rich media, creating 129
  Timeline 62–69
  workspace 59
Flash documentation, accessing 21
Flash online resources, accessing 26
Flash Video, inserting 282
FlashPaper
  features 118
  files, about 118
  workspace 118
FlashPaper SWF files
  navigating 120
  opening in new browser 120
  printing 119
  resizing 120
  searching 119
  selecting text 119
See also SWF files
FMA (flexible messaging area) 11
Font Mapping Default preference 91
fonts, changing size in help 34
Frame command (in Flash) 67
Frame View button (in Flash) 66
Frame View menu (in Flash) 66
frames
  centering the playhead in 65
  changing the view 65
  converting keyframes into 69
  copying and pasting 68
  copying by dragging 68
  displayed in Timeline 62
  displaying 64
  displaying contents 61
  displaying thumbnails 65, 66
  dragging in Timeline 68
  editing in Timeline 66
  inserting 67
  removing 68
FreeHand assets, creating 128
FreeHand Text on Clipboard preference 90
G
Gradients on Clipboard preference (in Flash) 90
 grids
   editing 81
   showing 80
   snapping to 80
guide layers 75
 guides
   clearing 80
   locking 79
   moving 79
   removing 79
   setting preferences 80
   showing 79
   snapping to 79

H
Hand tool 51, 62
 help
   accessing 33
   changing font size 34
   context sensitive 38
   discussing in LiveDocs 39
   index in 34
   printing 39
   printing a page 39
   purchasing printed versions 39
   searching 33
Help panel
   arranging 40
   opening 36
   searching 36, 37
   table of contents 36
   text size 41
   updating 41
Highlight Color preference 89
How Do I panel (in Contribute) 115

I
image placeholders
   about 176
   creating images from 272
   inserting 175
images 272–278
   creating with Fireworks 128
   creating with FreeHand 128
   exporting with Fireworks 213
   importing 197
   inserting 274, 275, 276
   inserting in Dreamweaver 130
   optimizing 211
   placeholders for 175
   importing images 197
Insert bar categories 51
Insert Blank Keyframe command (in Flash) 67
Insert Keyframe command (in Flash) 67
Insert Layer command (in Flash) 70
installing Macromedia Studio 14

K
keyboard shortcuts
   adding and removing 94
   customizing 92
   deleting 94
   for dialog box controls 98
   for library items 100
   for panel controls 97
   for panels 96
   for Property inspector controls 97
   for the Property inspector 96
   for the Stage 99
   for tree controls 100
Keyframe command (in Flash) 67
keyframes
   converting into frames 69
   creating blank 67
   dragging in tweened frame sequences 69
   inserting 67
   removing 68

L
Layer command (in Flash) 70
layer folders
   adding 70
   changing order of 74
   copying contents of 73
   creating 70
   deleting 74
   editing 72
   locking 73
   organizing 74
   renaming 73
layers
about 69
Add Layer button 70
changing layer height 72
changing number of layers displayed 72
changing order of 74
changing outline color 71
copying 73
creating 70
deleting 74
editing 72
guide layers 75
hiding and showing 70, 71
locking 73
organizing 74
renaming 73
selecting 72
viewing as outlines 71
layout
for web pages 127
table-based 163–180
Library panel (in Flash) 82
library, keyboard shortcuts for items 100
links, creating 290
LiveDocs 39
local folders
defining 140–142
root folders 124
locking layers and layer folders 73

M
Macromedia Flash Development Center 252
Macromedia Flash support 251
Macromedia Studio, installing 14
magnification (zooming) 61
main toolbar (in Flash) 75
maintaining and updating websites 133
masks 207

N
Named Anchor on Scenes preference 89
navigating FlashPaper SWF files 120

O
objects, stacking order 202
On Launch preferences in Flash 88
online resources, accessing 26
opening FlashPaper SWF files in a new browser 120
opening help 36
optimizing images 211
outlines
changing color on layers 71
viewing layer contents as 71

P
page design 125
creating layouts 127
mock-ups for 125
Pages panel (in Contribute) 115
Panel Sets command (in Flash) 86
panels
about 83
Actions 83
arranging 85
Assets 277
closing 84, 85
collapsing 84
creating new group 86
default layout 86
deleting custom layout 86
docking 85, 86
dragging 85
expanding 84
grouping 85, 86
keyboard shortcuts 96
keyboard shortcuts for tree controls 100
Library 82
opening 84
options menu in 84
resetting layout of 86
resizing 84
saving custom set 86
selecting layout 86
sets 86
ungrouping 86
viewing list of 84
Paste Frames command (in Flash) 68
PICT Settings for Clipboard preference (in Flash) 90
planning websites 122
playhead, moving 64
preferences
  Bitmaps on Clipboard (Windows only) 90
  Clipboard 90
drawing 90
Font Mapping Default 91
FreeHand Text on Clipboard 90
general (in Flash) 88
Gradients on Clipboard (Windows only) 90
Highlight Color 89
Named Anchor on Scenes 89
On Launch options 88
PICT Settings for Clipboard (Macintosh only) 90
Printing Options (Windows only) 88
setting (in Flash) 87
Shift Select 89
Show Tooltips 89
Span Based Selection 89
Undo Levels 88
warning 91
warning (in Flash) 91
Preferences command (in Flash) 88
Preview in Browser
  about 292
  changing Preferences 293
previewing frame thumbnails 65
printing FlashPaper SWF files 119
printing help 39
Printing Options preference (Windows only) 88
Property inspector
  about 81
  keyboard shortcuts 96
  using panels and 81
publishing 325–331
purchasing printed help manuals 39

R
registration 16, 251
release notes 251
remote folders 326
  creating with Dreamweaver 327
troubleshooting setup 330
Remove Frame command (in Flash) 68
renaming layers and layer folders 73
resizing FlashPaper SWF files 120
resources 251, 253
rulers
  changing units of 78
  showing and hiding 78

S
searching FlashPaper SWF files 119
searching help 33, 36, 37
selecting layers 72
selecting text in FlashPaper SWF files 119
seminars 252
servers
  access options 328
  uploading files 329
Shift Select preference (in Flash) 89
Show All command (in Flash) 61
Show Frame command (in Flash) 62
Show Grid command (in Flash) 80
Show Guides command (in Flash) 79
Show Tooltips preference (in Flash) 89
sites
  about 137
  assets, adding 139
  defining 140–142
  local 138
  remote 138, 326
See also websites
Snap to Grid command (in Flash) 80
Snap to Guides command (in Flash) 79
snapping
  to grid 80
  to guides 79
Span Based Selection preference 89
Stage
  displaying entire 62
  keyboard shortcuts for selecting 99
zooming 61
Start page 59
status bar
  about 50
  Window Size pop-up menu 51
SWF files 13
switching from
  browsing to editing 117
editing to browsing 117
symbol-editing mode 78
table header menu 168
table of contents 36
tables
  about 168
  creating layout with 163–180
  Expanded Tables mode 170
  inserting 166–170
  setting properties 170–174
tag selector 289
Test Connection button 328
text
  inserting 286
  selecting 286
text files in Code view 286
third-party resources 252, 253
Timeline
  appearance of, changing 63
  Center Frame button 65
  centering the playhead in 65
  converting keyframes into frames 69
  copying and pasting frames 68
  deleting frames or keyframes 68
  docking to the application window 64
  dragging 64
  dragging frames 68
  editing frames 66
  frame display, changing 65
  frames 66
  hiding layers in 70
  inserting frames 67
  keyframes 66
  layer folder order, changing 74
  layer height, changing 72
  layer name fields in 64
  layer order, changing 74
  locking layer folders in 73
  locking layers in 73
  number of layers displayed, changing 72
  playhead 64
  Preview in Context option 65
  Preview option 66
  resizing 64
  showing frame thumbnails 65, 66
  using 62
  viewing layers as outlines 71
  working with frames 62
toolbars
  about 114
  browser 114
  Coding 53
  customizing 77
  Document 49
  editor 114
  image editing 115
  text formatting 114
tools
  customizing the Tools panel in Flash 77
  Hand 62
  selecting in Flash 76
  viewing in Flash 76
  Zoom 61
Tools panel
  Fireworks 103, 104
  Flash 76
training and certification 252
tree controls, keyboard shortcuts for 100
tutorials
  adding content to pages 269
  creating a page banner 195
  creating page mock-ups 143
  creating table-based page layout 163
  formatting your page with CSS 295
  handling photographs 183
  publishing your site 325
  setting up websites for Contribute users 333
  tutorials, building an application 255
  tweened frames, dragging keyframes in 69
Undo Levels preference in Flash 88
updating the Help panel 41
warning preferences 91
websites 130
  assembling assets for 130
  content for 128
  deploying 130
  development environment for 123
  maintaining and updating 133
  mock-ups for 125
  planning 122
  testing 131
Window Size pop-up menu  51
work area, showing and hiding  62
work environment  103
workspace  103
    about  45
    Contribute  112
    Dreamweaver  45
    Fireworks  103
    Flash  59
    FlashPaper  118
    floating layout  46

Z
    Zoom tool (in Flash)  61
    zooming  61