Animating Layers with Timelines

Dynamic HTML, or DHTML, refers to the combination of HTML with a scripting language that allows you to change style or positioning properties of HTML elements. Timelines, in Dreamweaver, use dynamic HTML to change the properties of layers and images over time. Use timelines to create animations that do not require any ActiveX controls, plug-ins, or Java applets (but do require JavaScript).

*Note:* The word *dynamic* can mean different things in different web-related contexts. Don’t confuse Dynamic HTML with the idea of a dynamic web page, which means a web page generated dynamically by server-side code before being served to a visitor.

Timelines allow you to change the position, size, visibility, and stacking order of a layer. (The layer functions of timelines work only in 4.0 or later browsers.) Timelines are also useful for other actions that you want to occur after a page loads. For example, timelines can change the source file of an image tag so different images appear in the page over time.

To see the JavaScript code generated by a timeline, open the Document window’s Code view. The timeline code is in the `MM_initTimelines` function, inside a `script` tag in the `head` section of the document.

When editing the HTML of a document containing timelines, make sure you do not move, rename, or delete anything that a timeline refers to.
Using the Timelines panel

The Timelines panel shows how the properties of layers and images change over time. Choose Window > Others > Timelines to open the Timelines panel.

Timeline pop-up menu specifies which of the document’s timelines is currently displayed in the Timelines panel.

Playback head shows which frame of the timeline is currently displayed in the Document window.

Frame numbers indicate the sequential numbering of frames. The number between the Back and Play buttons is the current frame number. You control the duration of animation by setting the total number of frames and the number of frames per second (fps). The default setting of 15 frames per second is a good average rate to use for most browsers running on common Windows and Macintosh systems.

Note: Faster rates may not improve performance. Browsers always play every frame of the animation, even if they cannot attain the specified frame rate. The frame rate is ignored if it is higher than the browser can manage.

Context menu contains various timeline-related commands.

Behaviors channel is the channel for behaviors that should be executed at a particular frame in the timeline.

Animation bars show the duration of each object’s animation. A single row can include multiple bars representing different objects. Different bars cannot control the same object in the same frame.

Keyframes are frames in a bar where you have specified properties (such as position) for the object. Dreamweaver calculates intermediate values for frames in between keyframes. Small circles mark keyframes.

Animation channels display bars for animating layers and images.
Playback options

The following are the playback options for viewing the animation.

**Rewind** moves the playback head to the first frame in the timeline.

**Back** moves the playback head one frame to the left. Click Back and hold down the mouse button to play the timeline backward.

**Play** moves the playback head one frame to the right. Click Play and hold down the mouse button to play the timeline forward.

**Autoplay** makes a timeline begin playing automatically when the current page loads in a browser. Autoplay attaches a behavior to the page’s `body` tag that executes the Play Timeline action when the page loads.

**Loop** makes the current timeline loop indefinitely while the page is open in a browser. Loop inserts the Go to Timeline Frame behavior in the Behaviors channel after the last frame of the animation. Double-click the behavior’s marker in the Behaviors channel to edit the parameters for this behavior and change the number of loops.

Moving a layer using a timeline animation

The most common kind of timeline animation involves moving a layer along a path. Timelines can move only layers. To make images or text move, create a layer using the Draw Layer button on the Insert bar and then insert images, text, or any other type of content in the layer.

Timelines can also change other attributes of layers and images; for more information, see “Changing image and layer properties with timelines” on page 6.

To animate a layer using a timeline:

1. Move the layer to where it should be when the animation begins.
2. Choose Window > Others > Timelines.
3 Select the layer you want to animate.
Make sure you have selected the desired element. Click the layer marker or the layer selection handle, or use the Layers panel to select a layer. When a layer is selected, handles appear around it as shown in the following illustration.

Clicking inside the layer places a blinking insertion point inside the layer, but it does not select the layer.

4 Choose Modify > Timeline > Add Object to Timeline or simply drag the selected layer into the Timelines panel.
A bar appears in the first channel of the timeline. The name of the layer appears in the bar.

5 Click the keyframe marker at the end of the bar.

6 Move the layer on the page to where it should be at the end of the animation.
A line appears showing the path of the animation in the Document window.

7 If you want the layer to move in a curve, select its animation bar and Control-click (Windows) or Command-click (Macintosh) a frame in the middle of the bar to add a keyframe at the frame you clicked, or click a frame in the middle of the animation bar and choose Add Keyframe from the context menu.
Repeat this step to define additional keyframes.

8 Hold down the Play button to preview the animation on the page.
Repeat the procedure to add additional layers and images to the timeline and to create a more complex animation.
Creating a timeline by dragging a path

If you want to create an animation with a complex path, it may be more efficient to record the path as you drag the layer rather than creating individual keyframes.

To create a timeline by dragging a path:

1. Select a layer.
2. Move the layer to where it should be when animation begins.
   - Make sure you have selected the layer; if the insertion point is in the layer, the layer is not selected. To select a layer, click the layer marker or the layer selection handle, or use the Layers panel.
3. Choose Modify > Timeline > Record Path of Layer.
4. Drag the layer around the page to create a path.
5. Release the layer at the point where the animation should stop.
   - Dreamweaver adds an animation bar to the timeline, containing the appropriate number of keyframes.
6. In the Timelines panel, click the Rewind button; then hold down the Play button to preview your animation.

Modifying timelines

After defining a timeline's basic components, you can make changes such as adding and removing frames, changing the start time of the animation, and so on.

To modify a timeline, do any of the following:

To make the animation play longer, drag the end frame marker to the right. All the keyframes in the animation shift so that their relative positions remain constant. To prevent the other keyframes from moving, Alt-drag (Windows) or Option-drag (Macintosh) the end frame marker.

- To make the layer reach a keyframe position earlier or later, move the keyframe marker left or right in the bar.
- To change the start time of an animation, select one or more of the bars associated with the animation (press Shift to select more than one bar at a time) and drag left or right.
- To shift the location of an entire animation path, select the entire bar and then drag the object on the page. Dreamweaver adjusts the position of all keyframes. Making any type of change with an entire bar selected changes all the keyframes.
- To add or remove frames in the timeline, choose Modify > Timeline > Add Frame or Modify > Timeline > Remove Frame.
- To make the timeline play automatically when the page opens in a browser, click Autoplay. Autoplay attaches a behavior to the page that executes the Play Timeline action when the page loads.
- To make the timeline loop continuously, click Loop. Loop inserts the Go To Timeline Frame action in the Behaviors channel after the last frame of the animation. You can edit the parameters for this behavior to define the number of loops.
Changing image and layer properties with timelines

In addition to moving layers with timelines, you can change the visibility, size, and stacking order of a layer; you can also change the source file of an image.

To change image and layer properties with a timeline:

1. In the Timelines panel, do one of the following:
   • Select an existing keyframe in the bar controlling the object you want to change. (The start and end frames are always keyframes.)
   • Create a new keyframe by clicking a frame in the middle of the animation bar and choosing Modify > Timeline > Add Keyframe. You can instead create a new keyframe by Control-clicking (Windows) or Command-clicking (Macintosh) a frame in the animation bar.

2. Define new properties for the object by doing one of the following:
   • To change the source file of an image, click the folder icon next to the Src text box in the Property inspector, then browse to and select a new image.
   • To change the visibility of a layer, choose inherit, visible, or hidden from the pop-up menu in the Vis text box of the Property inspector. Alternatively, use the eye icons in the Layers panel.
   • To change the size of a layer, drag the layer’s resize handles or enter new values in the Width and Height text boxes in the Property inspector. Not all browsers can dynamically change the size of a layer.
   • To change the stacking order of a layer, enter a new value in the Z-Index text box or use the Layers panel to change the stacking order of the current layer.

3. Hold down the Play button to see the animation.

Using multiple timelines

Instead of trying to control all the action on a page with one timeline, it's easier to work with separate timelines that control discrete parts of the page. For example, a page might include interactive elements that each trigger a different timeline.

To manage multiple timelines, do any of the following:

• To create a new timeline, choose Modify > Timeline > Add Timeline.

• To remove the selected timeline, choose Modify > Timeline > Remove Timeline. This permanently removes all animations from the selected timeline.

• To rename the selected timeline, choose Modify > Timeline > Rename Timeline or enter a new name in the Timeline pop-up menu in the Timelines panel.

• To view a different timeline in the Timelines panel, choose a new timeline from the Timeline pop-up menu in the Timelines panel.
Copying and pasting animations

Once you have an animation sequence that you like, you can copy it and paste it into another area of the current timeline, into another timeline in the same document, or into a timeline in another document. You can also copy and paste multiple sequences at once.

To cut or copy and paste animation sequences:

1. Click an animation bar to select a sequence. To select multiple sequences, Shift-click multiple animation bars; to select all sequences, press Control+A (Windows) or Command+A (Macintosh).
2. Copy or cut the selection.
3. Do one of the following:
   - Move the playback head to another spot in the current timeline.
   - Select another timeline from the Timeline pop-up menu.
   - Open another document, or create a new one, and then click in the Timelines panel.
4. Paste the selection into the timeline.

Animation bars for the same object cannot overlap, because a layer cannot be in two places at one time (nor can an image have two different sources at a time). If the animation bar you are pasting would overlap another animation bar for the same object, Dreamweaver automatically shifts the selection to the first frame that doesn’t overlap.

There are two principles to keep in mind when pasting animation sequences into another document:

- If you copy an animation sequence for a layer and the new document contains a layer with the same name, Dreamweaver applies the animation properties to the existing layer in the new document.
- If you copy an animation sequence for a layer and the new document does not contain a layer with the same name, Dreamweaver pastes the layer and its contents from the original document along with the animation sequence. To apply the pasted animation sequence to another layer in the new document, choose Change Object from the context menu and select the name of the second layer from the pop-up menu. Delete the pasted layer if desired.

Applying an animation sequence to a different object

To save time, you can create an animation sequence once and apply it to each of the remaining layers in your document.

To apply an existing animation sequence to other objects:

1. In the Timelines panel, select the animation sequence and copy it.
2. Click any frame of the Timelines panel and paste the sequence at that frame.
3. Right-click (Windows) or Control-click (Macintosh) the pasted animation sequence and choose Change Object from the context menu.
4. In the dialog box that appears, choose another object from the pop-up menu and click OK.
5. Repeat steps 2 through 4 for any remaining objects that you want to follow the same animation sequence.

You can also change your mind about which layer should be animated after creating an animation sequence; simply follow steps 3 and 4 above (no copying or pasting is necessary).
Renaming timelines

To rename the timeline currently displayed in the Timelines panel:

1. Choose Modify > Timeline > Rename Timeline.
2. In the Rename Timeline dialog box, enter a new name.

If your document contains the Play Timeline behavior action (for example, if it contains a button that the visitor must click to start the timeline), you must edit the behavior to reflect the new timeline name.

Animation tips for timelines

The following suggestions can improve the performance of your animations and make creating animations easier:

- Show and hide layers instead of changing the source file for multiple-image animations. Switching the source file of an image can slow down the animation, because the new image must be downloaded. There will be no noticeable pauses or missing images if all images are downloaded at once in hidden layers before the animation runs.

- Extend animation bars to create smoother motion. If animation looks choppy and images jump between positions, drag the end frame of the layer's animation bar to extend the motion over more frames. Making the animation bar longer creates more data points between the start and end point of the movement and also makes the object move more slowly. Try increasing the number of frames per second (fps) to improve speed, but be aware that most browsers running on average systems cannot animate much faster than 15 fps. Test the animation on different systems with different browsers to find the best settings.

- Don't animate large bitmaps. Animating large images results in slow animations. Instead, create composites and move small parts of the image. For example, show a car moving by animating only the wheels.

- Create simple animations. Do not create animations that demand more than current browsers can provide. Browsers always play every frame in a timeline animation, even when system or Internet performance decreases.